Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
Fallen.Anvil
Novice


Joined: 12 Jul 2012
Posts: 44

PostPosted: Fri Sep 15, 2017 9:42 pm   

Opening URL's in Cmud
 
I recently had to reinstall windows 10.

Before I had to URL links were opening in my default browser, Chrome. Under different tabs.

Now they are opening in Edge and spamming me with multiple copies of edge loading for each link.

Anyone have any ideas?
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3513
Location: Pensacola, FL, USA

PostPosted: Sat Sep 16, 2017 6:37 pm   
 
That is an issue of Windows 10 itself.
Or rather, the way CMUD is processing the URL.
For some reason, it seems to bypass what the default program should be.
I have tried to prevent this behavior by removing edge from my system, and now URLs do nothing when clicked on.
I much prefer chrome myself.
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
Daern
Sorcerer


Joined: 15 Apr 2011
Posts: 809

PostPosted: Sat Sep 16, 2017 7:34 pm   
 
This post by Zugg explains how CMUD chooses the browser to open URLs in:
Zugg wrote:
All I can do is say what CMUD is doing, and CMUD looks at the file association. Specifically, CMUD looks at the registry key HKEY_CLASSES/.htm and then extracts the \shell\open\command value from that key. So, you can check your own Registry to see what your keys are set to.


I don't have a Windows 10 installation set up to test with atm, so I can't say if there's been any registry changes that could affect this. What I would suggest is:
- Follow these instructions to ensure that Chrome is set as the default program for the ".htm" file extension
- Check the value of the HKEY_CLASSES/.htm registry key and update it to point to Chrome if necessary. As with any registry modifications, I would highly suggest taking a backup first just in case.
Reply with quote
Fallen.Anvil
Novice


Joined: 12 Jul 2012
Posts: 44

PostPosted: Thu Sep 21, 2017 5:22 pm   
 
Alas.

I looked at my .htm default settings and they were already set to Chrome and went into my registry and they were also set to Chrome.

I'm going to download firefox and make that the default and see if the situation improves.
Reply with quote
Fallen.Anvil
Novice


Joined: 12 Jul 2012
Posts: 44

PostPosted: Thu Sep 21, 2017 5:32 pm   
 
I made Firefox my default browser and now the URLs open in Firefox. I tried to reset the associations back to Chrome and the URLs keep opening in Firefox. I suppose it's a Chrome issue.

My problem is partially resolved, they no longer open in Edge and the files are all opening in tabs on the Firefox browser.

Thanks one and all for the helpful insight.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net