Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
David256
Beginner


Joined: 07 Nov 2006
Posts: 22

PostPosted: Mon Nov 19, 2007 12:51 pm   

[2.12Pro] #URL always opens webpage in IE instead of the default browser
 
Running under vista x64 with firefox set as my default browser.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Nov 19, 2007 5:51 pm   
 
Works fine for me here. Can anyone else reproduce this? CMUD is just asking Windows what application is assigned to "open" a *.htm file, so it sounds like maybe Firefox isn't properly associated with that file extension on your system.
Reply with quote
Arlie
Wanderer


Joined: 09 Jun 2006
Posts: 62
Location: Florida

PostPosted: Mon Nov 19, 2007 6:11 pm   
 
It's a file association problem. Mine's properly opening the webpage with Opera.
Reply with quote
Fang Xianfu
GURU


Joined: 26 Jan 2004
Posts: 5155
Location: United Kingdom

PostPosted: Mon Nov 19, 2007 11:13 pm   
 
I was getting this earlier on my laptop with Abobe Reader, actually, which is really annoying (the pdf I was looking as is basically a big list of links). All the filetypes are associated right, too, which makes me wonder if it's a Windows bug (with optional sarcasm quotes Twisted Evil ).
_________________
Rorso's syntax colouriser.

- Happy bunny is happy! (1/25)
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Nov 19, 2007 11:56 pm   
 
Some programs *do* force Internet Explorer to be used. Wouldn't surprise me if Adobe did that. Some of them want to use ActiveX plugins for various stuff so they will forcefully call iexplore.exe instead of looking at the default web browser.

So, I cannot vouch for whether other programs work or not. All I can do is say what CMUD is doing, and CMUD looks at the file association. Specifically, CMUD looks at the registry key HKEY_CLASSES/.htm and then extracts the \shell\open\command value from that key. So, you can check your own Registry to see what your keys are set to.
Reply with quote
Arlie
Wanderer


Joined: 09 Jun 2006
Posts: 62
Location: Florida

PostPosted: Tue Nov 20, 2007 12:05 am   
 
For the record, it isn't enough to associate file types in Vista for certain programs, if I'm not mistaken. In Vista if you go to Start, "Default Programs" then select "Set Program Access and Computer Defaults", the value in there could potentially override your default web browser. You can select "Use my Current Web Browser", or you can select any of the other various installed browsers. Same for email and media player.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Nov 20, 2007 1:40 am   
 
If someone can point me to a link that documents the appropriate Registry entries to check on Vista, then I'd be happy to make the change. I've tried to do this in the past but have always found that the *.htm file association works the most reliably for all browsers. But I can certainly improve it. Just don't have a lot of time to research something minor like this right now while I'm trying to get the public release working.
Reply with quote
Arlie
Wanderer


Joined: 09 Jun 2006
Posts: 62
Location: Florida

PostPosted: Tue Nov 20, 2007 1:45 am   
 
My apologies Zugg, my post wasn't to you, it was to David256. I've changed my browser to all of the installed browsers on my system and CMud appropriately opened the right one afterward. Your code is perfectly fine, I was just posting to let anyone else using Vista know they may need to change the default program as opposed to the file associations.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Nov 20, 2007 2:00 am   
 
Ahh, ok, thanks for the clarification.
Reply with quote
David256
Beginner


Joined: 07 Nov 2006
Posts: 22

PostPosted: Tue Nov 20, 2007 12:47 pm   
 
Ah, thanks Arlie, setting the 'default programs' did it.

Before setting the default program, HKCR/.htm was pointing to IE, and after setting the default, it was pointing to firefox.
But, curiously, opening *.htm files from explorer always launched firefox regardless of that entry.
*shrug*

Certainly CMUD's behaviour seems reasonable anyway
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net