Register to post in forums, or Log in to your existing account
 

Post new topic  Reply to topic     Home » Forums » zMapper Discussion
Talahaski
Enchanter


Joined: 10 Oct 2000
Posts: 656
Location: USA

PostPosted: Mon Aug 26, 2002 1:40 am   

bitmap editor
 
I'm having a lot of trouble trying to get the bitmap editor to retain changes.

I've created a new map and set up the xy and directions for a hex map.

I then try to edit the room description, add the polygon hex shape, then go into the edit fill pattern for the room.

Most of the time any changes I make so not get applied or saved. At one point I finally got it to remain transparent, but after I closed the map and opened it again later, all the rooms reveryed back to having a grey square in the center.

It seems that the transparent option always has a check box in it when you open the bitmap editor, even if you took this off the last time you were in it.

I hope I'm making some sense here.

Talahaski
Processor PIII 1000
Memory 265MB
Video NVIDIA 64MB
Windows XP
Zmud Version 6.34
Zmapper Version 1.10
Reply with quote
Talahaski
Enchanter


Joined: 10 Oct 2000
Posts: 656
Location: USA

PostPosted: Wed Aug 28, 2002 1:24 am   
 
After more testing this appears to be caused by the default room option being on. If I removed this option, the rooms get fixed.

Talahaski
Processor PIII 1000
Memory 265MB
Video NVIDIA 64MB
Windows XP
Zmud Version 6.34
Zmapper Version 1.10
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Sat Aug 31, 2002 8:15 pm   
 
I'll add this to the bug list and try to make it more intuitive. Handling transparent bitmaps in Windows is *very* tricky, since Windows doesn't really support them. You'll notice that the lower-right pixel is used to set the transparent color for a bitmap.

On the changes not being handled, yes you need to turn off the Default flag. You can use a bitmap for a room with the default option on and the bitmap is just drawn after the normal gray box. Same thing with the shape. So, the filled shape was probably getting drawn underneath the default room box, causing the problem.

Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMapper Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
© 2009 Zugg Software. Hosted on Wolfpaw.net