Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
iosman
Beginner


Joined: 06 May 2019
Posts: 12

PostPosted: Sat Jul 06, 2019 4:07 pm   

A little help with bringing a Zmud script to Cmud
 
Hi,

Been trying to get this thing to work in Cmud for well over a week now and still no success. Not knowing what I'm doing isn't helping too much but I've read and reread every help file I can find and still no closer to a solution.


#ALIAS startmine {
#T+ mine1
#T+ mine2
minedir="%1"
mine %1
}
#TRIGGER "mine1" {You didn't find any resources.} {mine @minedir}
#TRIGGER "mine2" {You dig up * and drop it on a stack!} {mine @minedir}
#ALIAS stopmine {
#T- mine1
#T- mine2
minedir=""
}

The problem seems to be the %1 and Cmud, instead of it continuing along with mine e it returns a mine %1 which throws an error back from the mud. I'm at a loss how to get this to work, tried everything that I can think of and I know it's going to be something simple that is the problem. Maybe I can't see the forest for the trees as the saying goes. Any help of suggestions on this one would be very much appreciated.


Thanks
iosman
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3951
Location: Pensacola, FL, USA

PostPosted: Sat Jul 06, 2019 9:12 pm   
 
The issue is that you put the %1 in quotes, which treats it as a string and prevents it from being evaluated.
Get rid of those and you should be fine.
_________________
Discord: Shalimar#3679
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net