Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
ToyMage
Apprentice


Joined: 01 Sep 2005
Posts: 120

PostPosted: Sat May 11, 2019 8:00 am   

Alias in Alias?
 
sorry, i'm really a noob...

I been trying to get my alias to run right:

I have the following mapped to my alias "CK"

%if(@Status=0, Alias1, Alias2)

but it doesn't expand Alias1 and Alias2, it just sends "Alias1" and "Alias2" command literally..

what am i doing wrong?
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4016
Location: Pensacola, FL, USA

PostPosted: Sat May 11, 2019 12:49 pm   
 
You are using the function %if (which doesn't expand) instead of the command #IF

#IF (@Status=0) {Alias1} {Alias2}

You could wrap the function in an #EXEC command to force it to expand, but that is not the preferred methodology.
_________________
Discord: Shalimar#3679
Reply with quote
ToyMage
Apprentice


Joined: 01 Sep 2005
Posts: 120

PostPosted: Thu May 23, 2019 8:01 am   
 
how to type that?

"You could wrap the function in an #EXEC command to force it to expand,"
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4016
Location: Pensacola, FL, USA

PostPosted: Thu May 23, 2019 1:14 pm   
 
#EXEC {%if(@Status=0, Alias1, Alias2)}

That should work, but as i said the regular #IF command should do the same thing.
_________________
Discord: Shalimar#3679
Reply with quote
ToyMage
Apprentice


Joined: 01 Sep 2005
Posts: 120

PostPosted: Sun May 26, 2019 5:17 am   
 
Thanks thanks
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net