Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
senseofeven
Newbie


Joined: 08 Nov 2018
Posts: 5

PostPosted: Thu Nov 08, 2018 4:02 pm   

Sudden CMUD Mapper unable to speedwalk
 
Hi everyone,

I've been trying to figure out how come my CMUD is suddenly unable to autowalk like it usually does. I've tried to reconfigure, tweak and fiddle with the configurations and also attempted to do a clean reinstall and try to auto configure the map again.. unfortunately the problem still persists.

-
When I try to double click on one of my rooms, no command is sent and the slow walk timeouts and aborts itself.

When checking the room properties, it does seem linked, but it does not show the Dir or DirTo in there as example below:


I've doubled check that my prompt matches with the speedwalking prompt and it matches snugly...

After that I'm a bit out of ideas.

Thank you for your assistance.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3836
Location: Pensacola, FL, USA

PostPosted: Thu Nov 08, 2018 4:39 pm   
 
If you have recently migrated to a new game the mapper may have less of the known indicators for recognizing that a room has been shown at all.
You may need to make some #TRIGGERs to help it along.

#TAG the various parts of the room. (name, exits, etc)
Give the #OK when standard indicators aren't shown (like when its dark, or you are snowblind)
Throw out a #NODIR when you get a movement error message (like if you slam your face into a wall, don't have a key, or are just plain tired)
You might even need a #NOMAP if there are certain atmospheric type lines that are irrelevant. (like weather or moon phase)

Make sure to reconfigure the mapper after making any such changes.

In your specific case, it looks like you may have a rather substantial map already. Hopefully, this isn't a corruption issue.
Have you tried running it through the map convert utility? That might be in the CMUD Beta side of the forums.
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
senseofeven
Newbie


Joined: 08 Nov 2018
Posts: 5

PostPosted: Fri Nov 09, 2018 8:18 pm   
 
Thanks for your input shalimar.

I have tried as you advised and #TAG my room names, however, it just doesn't seem to capture as correct as I would like it.

The room line: A Large Room [E, S, U, Save]

Code:
<trigger priority="30" regex="true" id="2">
  <pattern>^(.+?) \[(.+?)\]$</pattern>
  <value>#cw gold
#TAG name, exit {%1} {%2}</value>
</trigger>


If I were to settle with that tag; when I run the reconfigure of the mapper, I'm being shown that the entire line, even the room name is the exit and that's not what I want. If I were to omit the room and exit #TAG, then the mapper can auto detect the room name and exit names separately in blue and red.

I've then gone about to automap over some rooms and tried to double click to test speedwalking but to still no avail.

If it helps, I have also #TAG my prompt. Do note that I did my map freshly with the client when I started on my MUD, but it's just a few days ago that it all went haywire and I cannot recall what I did that made it go bonkers..

I hope that this information is helpful enough to bring resolution to the problem.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3836
Location: Pensacola, FL, USA

PostPosted: Fri Nov 09, 2018 11:41 pm   
 
Sounds like you may have corrupted your map file then.

You might have some luck if you convert it to the old zMUD style map, and back to CMUD with: http://forums.zuggsoft.com/forums/viewtopic.php?t=34544

But you may have to remake it unless someone else can think of a possible solution.

If you keep backups you might have a version of your map file from before it turned south.
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
senseofeven
Newbie


Joined: 08 Nov 2018
Posts: 5

PostPosted: Sat Nov 10, 2018 1:27 pm   
 
Wow this is unfortunate.

I've tried to convert and reconvert back the map with the mapconverter .exe but the problem still persists. I've made a completely new map though with what seems to be detecting all the correct room names and exits as per the auto configurator but alas, I am still unable to speedwalk to a room.

Any more ideas?
Reply with quote
senseofeven
Newbie


Joined: 08 Nov 2018
Posts: 5

PostPosted: Sat Nov 10, 2018 2:03 pm   
 
Okay, I managed to find my old map and used it instead. It's working correct and well.. I'm able to see the Dir and DirTo in the room properties.

Is there anyway to resolve or workaround to prevent it from happening again?


Last edited by senseofeven on Sat Nov 10, 2018 2:14 pm; edited 2 times in total
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3836
Location: Pensacola, FL, USA

PostPosted: Sat Nov 10, 2018 2:14 pm   
 
Map corruption seems a rather rare thing, honestly.
Without knowing the true cause it is hard to prevent.
The best workaround is to keep regular backups.
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
senseofeven
Newbie


Joined: 08 Nov 2018
Posts: 5

PostPosted: Sat Nov 10, 2018 3:00 pm   
 
Hmm, it's speedwalking well now, but it keeps skipping over many rooms. My prompt is correct and matching, what else am I missing?
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3836
Location: Pensacola, FL, USA

PostPosted: Sat Nov 10, 2018 4:17 pm   
 
You might want to put it into slow or safe mode if you want to confirm each step along the way instead of just flinging ever command to get there all at once
Some games have a type ahead limit.
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net