Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
Kumba42
Newbie


Joined: 11 Apr 2017
Posts: 1

PostPosted: Tue Apr 11, 2017 6:20 am   

CMUD 3.34 mapper extrenmly slow when creating new rooms
 
I've been playing the Materia Magica MUD off and on over the years, and have built out several fairly detailed zones of several of the cities in the game. After returning to the game after a couple of months' break, I've noticed now that creating new rooms is extremely slow. On the order of 15+ seconds for the mapper to generate the new room when I navigate in a given direction. There are a couple of spots where it will create the room pretty quickly, but most of the time, I just have to sit and wait. This doesn't seem right. I've run the map converter tool several times to repair the SQLite database file, as well as converting it to the older zMud/MDB format and repairing it in MS Access, then converting it back. Nothing seems to work. While waiting, the mouse cursor blinks constantly as it switches the cursor back and forth to the arrow/i-bar, or the busy cursor.

Are there any known size limits on mapper databases that may cause this? Has anyone else run into an issue like this before? I have also noticed that closing CMUD will lock the program up unless I close the MUD session itself first, so that the mapper gets closed. Opening CMUD and selecting my Materia Magica session also takes about 30+ seconds to load the mapper database, and when switching zones (such as when I enter a new town/city), that also takes 30-45 seconds.

I have not yet tried the stand-alone zMapper tool -- is that compatible with CMUD (e.g., can I use that instead)? Does anyone know of third-party mapper programs that can parse the SQLite database and draw the same stuff as CMUD and basically replace the built-in mapper? I can tell that CMUD development is dead, so I am hoping someone has done something, as it seems like Zugg won't be open-sourcing the code anytime soon (even if it was stripped of proproetary components).

Thanks!
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3653
Location: Pensacola, FL, USA

PostPosted: Tue Apr 11, 2017 7:43 pm   
 
I was experiencing similar issues on my last system.
I would actually suspect the package files.
To test the theory... try making a new session without the main body of scripts, but use the same map and see if the zone switching is still laggy.
If that does fix the issue, then it likely is package corruption.
You can try exporting to XML to save your settings for a package remake.
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net