Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion Goto page Previous  1, 2
Ardath Posted: Sun Jan 17, 2010 12:49 am
cMud 2.37 slow/choppy to enter longer commands
peterwiggin
Beginner


Joined: 07 Sep 2012
Posts: 20

PostPosted: Sat Sep 08, 2012 7:18 am   
 
peterwiggin wrote:
I tested on plain, freshly installed trial version. The problem continues.


With all scripting and changes removed. Unless my scripts are held in some other place than either instalation folder or My Games, from where I've deleted them, and in spite of opening raw session with no scripting, that's not the problem with my scripts - which currently are non-existing, and the problem goes on.

reinstalation procedure:
uninstal via Programs and Functions
delete Program Files/Cmud
delete My Games/Cmud
repair registry with ccleaner
reboot
install cmud, do not copy any data from previous instalation

Problem not solved.
Reply with quote
Rahab
Wizard


Joined: 22 Mar 2007
Posts: 2307

PostPosted: Sat Sep 08, 2012 1:58 pm   
 
If you actually deleted Cmud from My Games and Program Files before reinstalling, then I'm at a complete loss. That would have removed any possible corruption, so that's not the problem. You say it was fine before the crash? And Cmud is the only program affected after the crash? This doesn't make sense. Completely deleting Cmud would have removed anything that could possibly have been corrupted that would affect only Cmud.

I'm sorry. I don't even know the questions to ask to try to track down a problem like this. It has to be something else running on your system, but I can't imagine what.
Reply with quote
ellie.1232
Newbie


Joined: 11 Sep 2012
Posts: 1

PostPosted: Tue Sep 11, 2012 2:30 am   
 
I'm also having a similar problem.

When I type in the command line its as though its in slow motion. This is very exasperating for me as I am a fast typer and can rattle off several long sentences into my MUD before the first one is halfway through "typing".

This started up about four days ago, and I have been trying for four days to fix it. I have completely uninstalled, reinstalled, and upgraded CMUD as well as updated video/audio drivers... basically everything I can think of. I'm wondering if the problem is related to a windows update? I have been using 3.31 for the last year without any trouble, and did not make any changes to settings or have any corruption of files last week when the 'slowness' problem started up. I haven't changed any settings on my PC recently either (ie: new antivirus etc)

Also, turning off spell check etc as mentioned in previous posts hasn't made a difference. In the newly installed 3.34 version, with no packages or anything added - the command line is just as slow. Even when I connect to a different mud from what I typically play - its acting up.

Looking for suggestions on how to fix this. I really am getting quite frustrated!

Thanks,
Reply with quote
Daern
Sorcerer


Joined: 15 Apr 2011
Posts: 809

PostPosted: Tue Sep 11, 2012 11:58 am   
 
If the problem started for both of you around the same time, it could definitely be a windows update. Have you tried restoring your computer back a few days, to when CMUD was working? If that fixes it, I'd start reinstalling the windows updates one at a time at see which one breaks it.
Reply with quote
peterwiggin
Beginner


Joined: 07 Sep 2012
Posts: 20

PostPosted: Sun Sep 16, 2012 6:38 pm   
 
The problem is this didn't start after any update. At least for me. The CMUD crashed and after restarting app it was going in slowmotion. If it was a problem with windows update, it should start after restarting computer, wouldn't it?
Reply with quote
nitroxthief
Newbie


Joined: 16 Sep 2012
Posts: 5

PostPosted: Sun Sep 16, 2012 7:15 pm   
 
i have the same problem. mine has been going on for about 1.5 weeks. cmud v3.34 crashed on me and i logged back in and BAM! slow motion.
Reply with quote
Daern
Sorcerer


Joined: 15 Apr 2011
Posts: 809

PostPosted: Mon Sep 17, 2012 2:43 am   
 
Well, I'm not sure what to say. Three people have the same problem, and it started for all of them at the same time. That can't be a coincidence. I doubt it happened because of the crash, as you said you did a complete reinstall and that didn't fix it. On top of that, anyone who used CMUD in early beta versions can tell you that it crashed literally daily and they don't have this problem. It's obviously not an update to CMUD that broke it, because none of you have updated it - you're also all using different versions. That leads me to believe it's something else on your systems that changed and is conflicting with CMUD somehow. If you didn't install windows updates (and I actually looked into what recent windows updates do, there was nothing keyboard-related), it could be an anti-virus program or something. Sorry I can't be of more help, but since it isn't happening to me...
Reply with quote
nitroxthief
Newbie


Joined: 16 Sep 2012
Posts: 5

PostPosted: Mon Sep 17, 2012 8:14 am   
 
i use kaspersky anti-virus 2011....i use lavasoft ad-ware pro for spyware
Reply with quote
Daern
Sorcerer


Joined: 15 Apr 2011
Posts: 809

PostPosted: Mon Sep 17, 2012 12:43 pm   
 
I know people have reported Kaspersky having problems with CMUD in the past. Does the problem go away if you disable it?
Reply with quote
peterwiggin
Beginner


Joined: 07 Sep 2012
Posts: 20

PostPosted: Mon Sep 17, 2012 4:20 pm   
 
Daern: if you looked into updates, was there anything memory managment related? Cause I feel lays the problem. CMUD behaves as if it had restricted memory access (and keyboard menagment was using up all of it).
Reply with quote
nitroxthief
Newbie


Joined: 16 Sep 2012
Posts: 5

PostPosted: Mon Sep 17, 2012 10:37 pm   
 
Holy crap disabling kaspersky worked. How in the hell....I have had the same anit-virus on this computer for like as long as I have had cmud on the system. Now the question is why is kasperky affecting it now?
Reply with quote
peterwiggin
Beginner


Joined: 07 Sep 2012
Posts: 20

PostPosted: Thu Oct 11, 2012 10:26 am   
 
Me to. Disabling Kaspersky did a miracle. But why? And CMUD was in exceptions before and there was no diffrence. Only fully disabling Kaspersky worked. Could you please look into it? What is the matter with that antivirus that is causing lag on input?
Reply with quote
Ansjovis
Newbie


Joined: 24 Apr 2003
Posts: 6
Location: Sweden

PostPosted: Sat Dec 01, 2012 9:59 am   
 
Hi! I have the same problem after installing Kaspersky Internet Security 2012. Used Kaspersky Anti-virus before without any problem. I use Zmud 7.21. And the command lag when i type is killing me, cant play mud anymore. If anyone has a solution for this problem it would be great! Only thing that solves it is to disable KIS. But i dont want to do that cause of the risk of getting infected.
Reply with quote
Ansjovis
Newbie


Joined: 24 Apr 2003
Posts: 6
Location: Sweden

PostPosted: Sat Dec 01, 2012 10:11 am   
 
Hi again. I believe its the Kaspersky component called "System Watcher" that cause this problem. By disabling it the problem goes away. So try that.
Reply with quote
Nair
Newbie


Joined: 24 Jan 2012
Posts: 1

PostPosted: Wed Aug 21, 2013 5:13 pm   
 
I just recently started having the same issues of "choppy" commands, but only after I installed and started using the Maxthon web browser. When you use this browser a toolbar opens and pins itself to the desk top and I guess it does something to lag the program.

I closed the browser and rebooted my PC and started running cmud 2.37 without any more issues. I agree everyone should check programs that are running in the background or at start up and make sure they are not draining your resources.

Zugg wrote:
It's still more likely to be a specific piece of background software or computer-specific setting..
Reply with quote
Quecha
Newbie


Joined: 30 Jul 2008
Posts: 4
Location: Mexico

PostPosted: Mon Jul 18, 2016 10:23 pm   
 
Anyone found a solution to this problem?

I have this same issue since last week and I havent had any changes on my laptop.

Its really frustating to have inpute lag issues as I type text on the command line.

I used Cmud for a long time and never had this problem before.

I tried another client to see if it was my laptop but the other client runs fine.


Please help!!!

I use Bitdefender and I disable it and still have the same problem :(
Reply with quote
Rain
Newbie


Joined: 10 May 2008
Posts: 6
Location: Denmark

PostPosted: Sat Jul 23, 2016 9:49 am   
 
I started having the same problem a few days ago, everything i type in the text field is super slow. I can't think of any programs i installed, or any changes that happened to the mud to make this happen.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3798
Location: Pensacola, FL, USA

PostPosted: Sat Jul 23, 2016 12:25 pm   
 
I had similar issues when my GPU was dying. Not sure if it was related or not.
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
Rain
Newbie


Joined: 10 May 2008
Posts: 6
Location: Denmark

PostPosted: Sun Jul 24, 2016 9:28 am   
 
Cmud is the only place where i have this input lag, if i completely close down Cmud and start it again then the lag is gone, but then it slowly comes back over an hour or so.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net