Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
hojotrolloc
Beginner


Joined: 08 Jun 2008
Posts: 14

PostPosted: Fri Sep 27, 2013 9:57 am   

Need help with a couple scripts that worked fine in zMud...
 
So I reformatted my machine, been running zMud on vista no problem for the last 3-4 years, and now zMud wont work. Crying or Very sad

I already had bought cMud for my sisters comp and figured WTF i'll change over. now when i put my scripts into her cMud it took them all no problem, but now when I am doing for me, heh, it's giving me a hard time. Maybe someone can help me out with these two scripts...

Code:
#CLASS {ColorPrompt}
#VAR health1list {Fresh|Healthy|Bursting}
#VAR health2list {Full|Scratched|Full}
#VAR health3list {Strong|Hurt|Strong}
#VAR health4list {Tiring|Wounded|Good}
#VAR health5list {Winded|Battered|Fading}
#VAR health6list {Weary|Beaten}
#VAR health7list {Haggard|Critical|Trickling}
#VAR health8list {Exhausted|Incapacitated|None|Dead?}
#TRIGGER {{@health1list}} {#CW cyan} "" {case}
#TRIGGER {{@health2list}} {#CW blue} "" {case}
#TRIGGER {{@health3list}} {#CW green} "" {case}
#TRIGGER {{@health4list}} {#CW magenta} "" {case}
#TRIGGER {{@health5list}} {#CW brown} "" {case}
#TRIGGER {{@health6list}} {#CW yellow} "" {case}
#TRIGGER {{@health7list}} {#CW red} "" {case}
#TRIGGER {{@health8list}} {#CW black} "" {case}
#CLASS 0


/\ Worked great in zmud, but now it won't color the first line at the bottom of the screen, or any line that i typed a command on, resulting in the colors only showing up maybe half the time...

Code:
#ALIAS atconnect {#LOG {C:\cMud\WheelofTime\logs\%time(mm-dd-yy)};#SAY Timestamp: %time}


/\ Can I no longer save logs now that I am using cMud? Or do I need a totally new trigger?


Any help would be much appreciated. (I MISS ZMUD! Crying or Very sad )
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3513
Location: Pensacola, FL, USA

PostPosted: Fri Sep 27, 2013 6:04 pm   
 
If you made it trigger on prompt and newline, it would likely resolve the color issue

as for the log...

the atConnect alias no longer works

instead try using the OnConnect #EVENT
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
hojotrolloc
Beginner


Joined: 08 Jun 2008
Posts: 14

PostPosted: Sat Sep 28, 2013 6:51 am   
 
Awesome, got them both working now, Thanks!

Now If I could just get help with one more thing...

How do i gag my passphrase from the logs? Zmud was doing it automatically, Cmud is not.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3513
Location: Pensacola, FL, USA

PostPosted: Sat Sep 28, 2013 5:59 pm   
 
It should be doing in by default, however there is an option in preferances, under scripting

P.S. the Beta forum is not really active anymore since CMUD is out of beta, you should post any other questions you have over there
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
clk4suport
Newbie


Joined: 21 Nov 2013
Posts: 8
Location: NOida

PostPosted: Fri Dec 13, 2013 12:26 pm   
 
Hi there,

i will try get those scripts that work for you.

Thank You.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net