Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
charneus
Wizard


Joined: 19 Jun 2005
Posts: 1876
Location: California

PostPosted: Mon Sep 27, 2010 9:28 pm   

[3.29b]BUG: Aliases to add keys with nested lists corrupts? list.
 
An alias that works similar to the test alias I have below worked before (though I can't say when it stopped working as I haven't needed to use it until I started remapping). Here's what happens.

Code:
<?xml version="1.0" encoding="ISO-8859-1" ?>
<cmud>
  <alias name="testadd" copy="yes">
    <value>#ADDKEY TestDB {$FirstParam} {$SecondParam|$ThirdParam|1|$FourthParam|0|1|%random(1,12000)}</value>
    <arglist>FirstParam, SecondParam, ThirdParam, FourthParam</arglist>
  </alias>
</cmud>


Using the alias above in an untitled session, type the following on the command line:
1. testadd one two three four
2. testadd "two" "three" "four" "five"
3. #ADDKEY TestDB {three} {four|five|1|six|0|1|%random(1,12000)}

Now open up Package Editor and look at the database. You'll see that the second and third parameters are not put in correctly, and the only param put in properly is the fourth param for the first two, but the manual #ADDKEY works properly. Not sure what the situation is that causes this, however, unless I'm missing something.

Charneus
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Sep 27, 2010 10:20 pm   
 
Not sure what the situation here is either, but I confirmed it and added it to the bug list.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net