Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum

Joined: 07 Feb 2002
Posts: 333
Location: Central Virginia

PostPosted: Wed Sep 15, 2010 1:53 am   

[3.26] Diagionals sent from Mapper or Paths busted.
I haven't found a way to reproduce this yet. So I guess this is just a heads up/what could be causing the problem post? I'll be running around the MUD using my paths and the mapper click/speedwalk to room option with no problems. Then all of the sudden i go to use one of the two previously mentioned speedwalks and if the path contains more than one diagonal direction in a row only the first gets sent to the mud as a direction.

Here is the Path:
<path name="dirtest" id="268">2ks2en2h</path>

I type .dirtest on the command line and this is what gets sent to the mud:
0.0021 | a  MUD|sw
0.0036 | i  MUD>sw<CR><LF>
0.0357 | m  MUD|  Event "onRoomWalk" raised : (%1="83", %2="", %3="", %4="")
0.0007 | m  MUD|  Event "onRoomEnter" raised : (%1="83", %2="", %3="", %4="")
0.0010 | a  MUD|ks2en2h
0.0035 | i  MUD>ks2en2h<CR><LF>

The script debugger looks the same if I'm using the mapper to speedwalk with.

If I go over to the main session window though and type .h .j .k or .i on the command line they are converted to the correct directions and sent to the mud just fine.

If I want to go two sw and type .k and hit enter twice (I don't have my command line set to clear) SW will be sent to the mud twice.

If I type .2k however

is sent to the mud.

I go into the package editor at this point and disable everything that you could possibly disable setting wise here and the results are still the same (more than one diagonal in a path . That should eliminate any script interference keeping the package from working so I guess the question I should be asking myself now is what's causing this malfunction. I think to myself maybe the English directions package is corrupted somehow. In the process of getting a fresh copy from the library and restarting cmud to test it access violation error that will not let me reopen the package I'll send the error report in.

EDIT: It usually takes a couple hours of being connected for this to happen so right now i'm sitting here in a new clean session with a new map running a small circuit every 13 seconds. I already managed to get the old session exported. if nothing happens in a bit i'll start by trying to add my old map files to this session I guess. and re run the path loop for a while.
Reply with quote

Joined: 25 Sep 2000
Posts: 23379
Location: Colorado, USA

PostPosted: Wed Sep 15, 2010 4:25 pm   
Looks like the English Directions in the library might be messed up. That's what your crash dump pointed to. Try deleting your English Directions package and then just reinstall CMUD. That will restore your copy of the package and shouldn't have any other side effects.

Since your original error with the diagonals only happens after a few hours, it's going to be really tough to pin this down.

Are you on a MUD that is using GMCP, or is this happening with the regular mapper on a non-GMCP mud?
Reply with quote

Joined: 07 Feb 2002
Posts: 333
Location: Central Virginia

PostPosted: Wed Sep 15, 2010 9:21 pm   
This is on a mud without GMCP. I ran a path bot for about 7 hours while sleep with only a hand full of settings enabled and everything is still functioning normally. So I've pulled them from the package and am working with the remaining settings now trying to find anything that will cause this snag.
Windows Vista Home Premium SP2 32-bit
AMD Athlon Dual Core 4400+ 2.31 GHz
CMUD 3.34
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by