Register to post in forums, or Log in to your existing account
 

Post new topic  Reply to topic     Home » Forums » zMapper Discussion
boy_icon
Newbie


Joined: 07 May 2009
Posts: 7

PostPosted: Thu May 07, 2009 11:42 am   

Restoring Map files
 
I downloaded and played with zmapper a little, considering whether to buy it or not. I was careless and unknowingly altered the room shapes of a large map file I use regularly in Cmud. The rooms are still just squares, but they no longer scale up or down when zooming on the map. Also, when I downloaded the newest beta of Cmud and it converted my maps to the new format, the rooms were completely invisible, and only the exits were visible.

Is there a way to reset or strip the room shapes so that this does not happen? Thanks in advance.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Thu May 07, 2009 5:37 pm   
 
Did you change the room shape of the normal default room? Or did you create a new room type?

zMapper is very finicky (which is why it's still Beta software), and is not intended to be used with the newer CMUD 3.x versions (which uses a different map format). If you convert a zMapper map into CMUD 3.x, then you won't be able to edit it using zMapper anymore. An updated version of zMapper (called cMapper) is planned for the future, but it's a while away.

To restore the default room shape, open your map in zMapper and then go to the Palette tab. Right-click on the first "Room" and select Edit Shape. On the right side of the toolbar on the top is a button that looks like a square. Click on this button and make sure it is selected. This is the "draw default shape" button. Now, the tricky part is that clicking this button doesn't cause the new shape to be saved...you have to make some other change to the shape. For example, if you have any custom shapes, delete them. Or, draw a rectangle, then delete it. Anything to mark the record as "changed". Then click the green Apply checkbox and close the window. That *should* restore the default room shape.

I'm not sure why your custom shape didn't scale with the map. The whole point of shapes is that they are vectors and *do* scale when zooming the map.
Reply with quote
boy_icon
Newbie


Joined: 07 May 2009
Posts: 7

PostPosted: Thu May 07, 2009 6:33 pm   
 
I was afraid that this would involve using zmapper to fix the problem. I apologize that I didn't mention that the trial has expired, and I can no longer use the program. I was OK with living with the non-scaling rooms, but when Cmud beta came out and the rooms disappeared, the trial period had expired. To answer your question, I believe that I changed the shape of the default room.
Not 100% sure on that one though.

Thank you Zugg for responding. I have been using your programs (Z/Cmud) for as long as I can remember. And I have been recommending them to people the whole time.

Anybody have a workaround?
Reply with quote
Tech
GURU


Joined: 18 Oct 2000
Posts: 2733
Location: Atlanta, USA

PostPosted: Thu May 07, 2009 10:36 pm   
 
Your best bet is to find a friend who has zMapper...

If you don't can't find one PM and I'll see if I can't get it back to the default for you. But as zugg mentioned zMapper only works the the .mdb files. If you made changes to the .dbm version of the mapper file that the beta version uses, then you'll lose those changes.
_________________
Asati di tempari!
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMapper Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
© 2009 Zugg Software. Hosted on Wolfpaw.net