Register to post in forums, or Log in to your existing account
 

This forum is locked: you cannot post, reply to, or edit topics.  This topic is locked: you cannot edit posts or make replies.     Home » Forums » TeSSH Discussion
Nezic
Apprentice


Joined: 10 Oct 2000
Posts: 119
Location: Colorado

PostPosted: Wed Aug 27, 2008 4:58 pm   

[2.36] Option to disable popup window for login
 
I am trying out TeSSH for possible use at work, however I would like to be able to disable the popup window that requests my user/pass, and instead type it in normally in the terminal window.

My immediate reason is because we have a authentication system setup that has a significant delay (~20 seconds) when I use TeSSH, but only a couple of seconds or less when I log in normally with something like putty or ssh from a unix terminal. The only difference that I see is that TeSSH has the popup window, while others don't (keep in mind that I'm no terminal-type expert).

The cause of the delay could easily be a problem with our own authentication system, but I'm also pretty sure I won't have any luck getting it investigated/fixed Wink .

[Note: I just noticed that the entire TeSSH application is frozen during that 20 seconds.. which is also annoying :/ The #debug window didn't show anything that would explain the delay.]

However, it also seems unusual to have a terminal client show a popup window for logging in and I think people using TeSSH professionally would be more comfortable with standard log in behavior. (An example where it would be more useful is if you're connecting with multiple (floating) windows to some equipment under test, because it would allow you to copy the login and then paste into each window with a single right-click.)

Is there a way to change the login behavior?
Reply with quote
Tech
GURU


Joined: 18 Oct 2000
Posts: 2733
Location: Atlanta, USA

PostPosted: Wed Aug 27, 2008 7:23 pm   
 
Try this. Edit your session, and on the AutoLogin tab uncheck the "Automatically use ... to log in" option.
_________________
Asati di tempari!
Reply with quote
Nezic
Apprentice


Joined: 10 Oct 2000
Posts: 119
Location: Colorado

PostPosted: Wed Aug 27, 2008 7:43 pm   
 
I didn't get the popup window this way, but I still have the long delay with TeSSH freezing up.

Also, I don't always want to use the same user/pass (the account I need to use can vary), so using the auto-login isn't a good solution in my case.
Reply with quote
Tech
GURU


Joined: 18 Oct 2000
Posts: 2733
Location: Atlanta, USA

PostPosted: Wed Aug 27, 2008 8:21 pm   
 
Right since you disabled it you won't use autologin anymore. As for the long delay there were some other discussion regarding that a few weeks ago. It may depend on what type SSH server you're connecting to.. It may also help to change your terminal type. Try vt100 or xterm.
_________________
Asati di tempari!
Reply with quote
Nezic
Apprentice


Joined: 10 Oct 2000
Posts: 119
Location: Colorado

PostPosted: Wed Aug 27, 2008 9:34 pm   
 
Err.. sorry I misread your first response (thought you said 'check' rather than 'uncheck').

Anyway, when I uncheck the box to automatically use this name and password, I still get the popup. So I guess this is a bug report instead of a feature request, unless I'm still doing something wrong.

[Edit]
I tried both vt100 and xterm -- both give me the delay.

I should also note that this is on Win2000.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Wed Aug 27, 2008 11:46 pm   
 
The login delay has nothing to do with the popup window. As someone else posted a while back, there is currently some sort of delay issue involved in the SSH negotiation that I haven't been able to track down. This is a known problem.

If the "automatically use this name and password" option is checked, the TeSSH sends your username/password automatically and won't prompt at all. This information is stored very securely in the sessionkeys.db database. You can set a Master password for this database which sets your own custom encryption key to ensure that this stored information cannot be hacked (it's a 128bit RSA encryption key).

If you turn off the "automatically use..." option, the TeSSH will prompt you for the username/password if the SSH server requests the "password" authentication method. There are several authentication methods an SSH server can use, so that's why you get the popup instead of typing in the main window.

I personally find typing the username/password into the main text window to be an archaic way of handling login. A user prompt is much better in my opinion. It makes it very obvious that the server is requesting information. It also allows the password data to be easily hidden in the edit box instead of just not echoing anything like other clients do in the main text window.

So, the authentication is working as designed and I have no plans to remove the popup. The only problem is the known delay issue that seems to be very server dependant.
Reply with quote
Nezic
Apprentice


Joined: 10 Oct 2000
Posts: 119
Location: Colorado

PostPosted: Thu Aug 28, 2008 1:05 am   
 
Ahh, I didn't realize that the delay was already a known issue.. I'm sure it will be fixed later on.

As for the login popup, I agree that it isn't bad, but there are still cases where the regular style is useful, so the option would be nice.

It'd be cool to have scripts or aliases that are constructed to open a variable number of windows connecting to different things at the same time (with certain window sizes, locations, and z-order), but not have a pre-defined user/pass or popup login window.
Reply with quote
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.     Home » Forums » TeSSH Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
© 2009 Zugg Software. Hosted on Wolfpaw.net