Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
alluran
Adept


Joined: 14 Sep 2005
Posts: 223
Location: Sydney, Australia

PostPosted: Tue Jun 10, 2008 5:02 am   

Clicky Url Request
 
Can you make it open links in the default browser program instead of IE...
IE == bad, Firefox == good.

Or if too tricky to get working properly, give us an option to set what program to launch mailto, ftp, and http links in?

(Zmud and cmud both do this when using #url too afaik)
_________________
The Drake Forestseer
Reply with quote
charneus
Wizard


Joined: 19 Jun 2005
Posts: 1876
Location: California

PostPosted: Tue Jun 10, 2008 5:05 am   
 
I have both IE and Firefox installed, and using #URL or clicking on the links open up in Firefox. mailto opens up in Thunderbird. Are you sure firefox is your default browser?

Charneus
Reply with quote
alluran
Adept


Joined: 14 Sep 2005
Posts: 223
Location: Sydney, Australia

PostPosted: Tue Jun 10, 2008 5:21 am   
 
Vista Ultimate 64x, Firefox 2 (latest), Cmud 2.2# (6? i think)

I think there's multiple ways to detect the default, and the default installation of firefox (and even setting all the programs defaults correctly using the Vista UI) doesn't seem to capture properly. Have seen this in a few programs. Outlook throws an error but opens correctly (Therefore it can find it correctly, but is still buggy), MSN ads open in IE (so incorrect use there), yet all web pages and shortcuts on my local drive open fine. I can reproduce it easily (every time i install, you know, every 2nd week ;) will duble check #url now.. and nope, thats still IE.

Perhaps the easiest thing is a setting that attempts to autodetect until you set it. I can (almost?) guarantee that I wouldn't be the only one that has this issue on this particular setup.

Oh, and yes defaults are set proper
_________________
The Drake Forestseer
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Jun 10, 2008 5:11 pm   
 
Both CMUD and zMUD are looking for what program is set in Windows to be assigned to the ".htm" extension. Sounds like your Firefox didn't get installed properly or something. I have Vista here and Firefox and links open in Firefox just fine. You might do a Google search on how to set your default web browser to get instructions on how to do it because it sounds like something is messed up in your Windows Registry that is preventing Firefox from setting itself as the default.

But I've always just used the default installer for Firefox and never had trouble, even on Vista, so I'm not sure what else to suggest.

Unfortunately, there isn't any good way for me to add options for this myself. I am using several 3rd party components and they all rely upon Windows being set up for the default browser correctly. I haven't looked at the detailed code in a while, but I'm pretty sure they look in the registry for the ".htm" extension entry and look at the entry for the "open" command for that file extension.

Also, you say it also happens in zMUD, but I've never gotten any bug reports about this in zMUD either, so I really think the problem is more unique to your computer than you might think.
Reply with quote
alluran
Adept


Joined: 14 Sep 2005
Posts: 223
Location: Sydney, Australia

PostPosted: Wed Jun 11, 2008 12:30 am   
 
Happened to me on ASUS G2S + Vista 64 Ultimate + z/cmud, and on ASUS M70SA + Vista 64 Ultimate + cmud (can't remember 100% if it was happening on the ASUS A2K + WinXP Pro + zmud, probably not, I think this is more a Vista compatability issue)

Every time it was just a default install of windows + cmud + firefox for it to act funny. I'll double check all the file extensions now and edit this post... Though if this is the case, it's still going to happen for alot of people, as I haven't done anything for IE to take over file extensions (I hate that software like I hate the plague, being a web dev ;) )


IE currently has:
.gif (again, goddamn I keep fixing that :( )
.mfp
.mht
.mhtml
.url (are you using these?, I'll edit again after I check if firefox opens these)
.vdx
.vsd
.vss
.vst
.vsx
.vtx
.xevgenxml
.xrm-ms
.xsl

So unless it's a gif, propriatary microsoft format, some xml, or the "url" option, it should be opening in firefox :) will check url now

Just changed .url, still opened in IE, .htm and .html both set to firefox, gonna try explicitly setting my browser in "program defaults" instead of telling it to use my "web browser" (which is set to firefox)

Ok, got it, I had to explicitly set firefox as the program by going Control Panel->Default Programs->Set Program Access And Computer Defaults->Custom->Use a default web browser->"Mozilla Firefox" (vs using "Use my current Web Browser")
_________________
The Drake Forestseer
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Wed Jun 11, 2008 12:59 am   
 
Quote:
Ok, got it, I had to explicitly set firefox as the program by going Control Panel->Default Programs->Set Program Access And Computer Defaults->Custom->Use a default web browser->"Mozilla Firefox" (vs using "Use my current Web Browser")

I seem to recall something like that mentioned elsewhere for Firefox. But I'm not sure exactly what circumstances it is required. I just checked my Vista Business system and my default web browser setting is "Use my current Web browser" and it still works fine. So my guess is that there was still something fishy in your registry that you are overriding with this setting.

At least you found a way to get it working. Honestly, with all of the UAC crap and mirrored "compatibility" files and registry entries, I'm not even sure myself anymore how Vista works (or doesn't). It's possible that something just didn't get installed or run "as admin" when it needed to. It seems like I had to originally install Firefox by running the installer "as admin", but it's been too long ago to really remember.

I looked more closely at the code used by the #URL command in CMUD and here is what it is doing exactly.

It looks in the HKEY_CLASSES_ROOT registry area for the ".htm" entry. It takes the default value of that key, then appends "\shell\open\command" to it and fetches that registry key. It then executes this key (assuming it's a *.EXE file) with the URL passed as the first argument, or with %1 in the key value replaced with the URL

On my system, the default value of the ".htm" key was "FirefoxHTML". And the value of the "FirefoxHTML\shell\open\command" key was "C:\PROGRA~1\MOZILL~1\FIREFOX.EXE -requestPending -osint -url "%1"". In this case, the %1 would be replaced with the URL.

So, you'd need to actually open REGEDIT and look at the value of your HKEY_CLASSES_ROOT\.htm key to see what it is set to. Just looking at what extensions IE is using isn't good enough since who knows what registry entries that is really looking at.

For example, I've had a similar problem in Vista where I try to assign ZIP files to open in ZipGenius instead of WinZip. And even though ZipGenius "thinks" that the ZIP extension was assigned to it, no amount of telling it to assign the extension would fix it. I finally had to go into RegEdit manually myself and change the ".zip" entry to point at ZipGenius instead of WinZip. My guess is that there was some sort of permission problem. In Vista, each and every registry key has access permissions. And if these get screwed up, then Vista will just refuse to update a registry key that it thinks you don't have permission for (and often won't give you any message or indication of the failure). When you right-click on a key in the tree on the left side of RegExit, there is a Permissions menu entry that can be used to look for this problem. You'll notice that regular Users only have "Read" access to the keys. So unless Firefox is running "As Admin" or tries to elevate itself, it is not able to modify the ".htm" key itself.
Reply with quote
alluran
Adept


Joined: 14 Sep 2005
Posts: 223
Location: Sydney, Australia

PostPosted: Wed Jun 11, 2008 1:08 am   
 
Step 1 before I install anything on Vista is disabling UAC, and I always run as admin, so I don't think it's a permissions issue. Wasn't really saying this was a bug with cmud so much as a problem which cmud had the potential to fix. Either way, there's a solution on the forums now if anyone else runs into the problem, and I've filed a bug report with mozilla.

Thanks for the prompt replies Zugg :)
_________________
The Drake Forestseer
Reply with quote
Alsith
Newbie


Joined: 12 Jul 2002
Posts: 7
Location: Australia

PostPosted: Sat Aug 27, 2016 4:58 pm   
 
Anyone got clicked urls to open in zmud in windows 10? I get the appropriate mouse-over icon change, but chrome won't fire.
Reply with quote
Fallen.Anvil
Novice


Joined: 12 Jul 2012
Posts: 44

PostPosted: Thu Sep 15, 2016 1:03 am   
 
I do. I use Chrome for my regular web browsing but it's not the default. Firefox is my default and the MU* links open in there for me.
Reply with quote
Alsith
Newbie


Joined: 12 Jul 2002
Posts: 7
Location: Australia

PostPosted: Thu Sep 15, 2016 4:17 am   
 
If anyones got it to work with chrome I'd love to know.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3597
Location: Pensacola, FL, USA

PostPosted: Thu Sep 15, 2016 8:45 pm   
 
I just tried disabling Internet Explorer 11, and now the links don't do anything when clicked upon.
Chrome is set as default for all the things it can be set for.
Might be able to COM into it somehow, but there seems to be no native way to do this.
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
Kaeros
Newbie


Joined: 21 Jan 2017
Posts: 1

PostPosted: Sat Jan 21, 2017 5:22 pm   
 
Has anyone had any luck fixing this? It's driving me crazy, and is nearly the -last- bug I'm trying to fix. :(
Reply with quote
elokk
Newbie


Joined: 15 Nov 2010
Posts: 1

PostPosted: Tue Jan 30, 2018 5:13 am   HALP!!
 
Nope :D

I haven't been able to solve it. I have Windows 10 and .htm, .html, web browser, etc all set to Chrome but everything opens in IE.

Zugg, if you're alive, fix eeetttt!!
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net