Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
eclpmb
Novice


Joined: 29 Feb 2004
Posts: 36
Location: United Kingdom

PostPosted: Mon Dec 18, 2006 5:03 pm   

[1.24] Autolog strangeness
 
If i have 'Automatically use this character name and password to log in' on a session ticked, it only sends the username.

If i have it unticked it sends both the username and password.

This seems the wrong way round to me.
Reply with quote
Fang Xianfu
GURU


Joined: 26 Jan 2004
Posts: 5155
Location: United Kingdom

PostPosted: Thu Dec 21, 2006 1:28 am   
 
It shouldn't be sending the username OR password if the option's disabled. The autologging just creates two triggers that send #ch and #pw in response to the right message - check you haven't got your own triggers using those commands.

Try recreating the session with a new package file and see if that solves the problem. It's possible, especially if you've used a beta version, that the package has become corrupt somehow. If this turns out to be the problem, keep the corrupted .pkg around in case Zugg wants to see it.
_________________
Rorso's syntax colouriser.

- Happy bunny is happy! (1/25)
Reply with quote
eclpmb
Novice


Joined: 29 Feb 2004
Posts: 36
Location: United Kingdom

PostPosted: Thu Dec 21, 2006 1:18 pm   
 
This is from a complete fresh install of cmud (due to hdd badness)

I had not created any triggers at all, let alone autolog ones.

Hence 'strangeness'
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Wed Jan 17, 2007 9:43 pm   
 
I cannot reproduce this at all. There is no way for CMUD to send your username (or password) unless you have some triggers for it.

The option only controls triggers created within the AutoLog class folder. If you create triggers in other folders, then they won't be effected by the "Automatically use this character name and password to log in" option. The "AutoLog" class is a special class that gets enabled and disabled by this option. It is also effectively disabled after you have received a lot of text from the MUD already (I don't remember how many lines it currently looks at)...this prevents your autolog triggers from firing accidentally in the middle of a mud session and sending your password to the MUD.

Anyway, if you had not created any triggers, then there is no way for CMUD to have sent your username to the MUD.
Reply with quote
eclpmb
Novice


Joined: 29 Feb 2004
Posts: 36
Location: United Kingdom

PostPosted: Thu Jan 18, 2007 9:35 am   
 
I've since deleted and reinstalled, and that particular problem has gone.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net