Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » zMUD General Discussion

Joined: 14 Aug 2001
Posts: 2
Location: Germany

PostPosted: Fri Feb 01, 2002 9:50 am   

Problems with a mud-command containing a #

there is a command in our game called chat#newbie to retrieve the 10 last messages send to the channel "newbie". But when typing this in, zMUD seems to break in some kind. No other mud command is possible.
We found out, that a "0;1c" is prepended to each mud command.

I tried to disable the parsing in zMUD completely but it did not help.

Please help.


Bardioc of Evermore

PS: This problem does not occur in tf or other mud clients, so it seems to be a problem of zMud.
Reply with quote

Joined: 19 Jan 2002
Posts: 34
Location: Austria

PostPosted: Fri Feb 01, 2002 11:54 am   
zMUD uses the "#" for internal commands, so it thinks you are sending it to zMUD and not to the MUD itself. two things you can do:
look under prferences at the special characters, where you can turn the internal use of special characters on and off, or type a "~" before the "#".
"~" which will tell zMUD that the following character must not be computed internally, but has to be sent to the MUD.
i suggest, you use the second option, otherwise some things might not work in zMUD.
so, if you type chat~#newbie, it should work.

what you can do, to make it easier, is to set an alias like:
#alias chatnew {chat~#newbie}
just copy the above line and paste it into zMUD-prompt.
now, whenever you type "chatnew blahblahblah"
zMUD will send "chat#newbie blahblahblah" to the MUD

Reply with quote

Joined: 20 Dec 2001
Posts: 39
Location: USA

PostPosted: Sat Feb 02, 2002 8:50 am   
Another option, is to change the character used for commands:
View Menu -> Preferences -> Special characters

Set command character to something besides # (something you find easy to use, but that your mud doesn't expect in its input. If you have many triggers, scripts, etc. defined that execute zmud commands the quote solution (~#) is probably easier.

Bob, aka Kayd on SWMud and a few others.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMUD General Discussion All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by