Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
edb6377
Magician


Joined: 29 Nov 2005
Posts: 482

PostPosted: Tue Jan 10, 2012 1:02 am   

#MXP and URL/color ISSUE
 
Code:
#MXP <color white><a @questurl >Here</a></color>


or

Code:
#MXP This is a <a 'http://www.zuggsoft.com' 'Zugg Software'>hyperlink</a>


makes my mud end up from perfect MXP to the following and all MXP tags are "Broken/Visible" until i relog. The next time it triggers it happens again etc.

Code:
<245</V>hp 250</V>sp <V St>289</V>st>
_________________
Confucious say "Bugs in Programs need Hammer"
Reply with quote
Anaristos
Sorcerer


Joined: 17 Jul 2007
Posts: 821
Location: California

PostPosted: Tue Jan 10, 2012 2:40 am   
 
Though I haven't seen it in this aspect, there has been a bug in this MXP pattern from as far as I remember. I did post it once a few years back. The workaround I found was to put the color inside the tags and not outside. eg.,
Code:

#MXP <a @questurl ><color white>Here</color></a>
_________________
Sic itur ad astra.
Reply with quote
edb6377
Magician


Joined: 29 Nov 2005
Posts: 482

PostPosted: Thu Jan 12, 2012 7:14 am   
 
Okay let me give that a go and see what i get.
_________________
Confucious say "Bugs in Programs need Hammer"
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4578
Location: Pensacola, FL, USA

PostPosted: Thu Jan 12, 2012 12:55 pm   
 
I find that a simple #CW after all your MXP code works as well
_________________
Discord: Shalimar#3679
Reply with quote
edb6377
Magician


Joined: 29 Nov 2005
Posts: 482

PostPosted: Mon Jan 16, 2012 10:52 pm   
 
Interestingly enough if i turn off the system entity <stat the problem disappears.. I will play with it some more to be sure.
_________________
Confucious say "Bugs in Programs need Hammer"
Reply with quote
Anaristos
Sorcerer


Joined: 17 Jul 2007
Posts: 821
Location: California

PostPosted: Tue Jan 17, 2012 2:33 am   
 
What you showed:
Code:

<245</V>hp 250</V>sp <V St>289</V>st>

indicates that the Stats element is involved somhow, which is why disabling it helped.
Disabling the tag is a solution that addresses the symptoms, though, not the problem. Somewhere in your code you are doing something that makes MXP think you are using the <ST> (Stats) tag.
_________________
Sic itur ad astra.
Reply with quote
edb6377
Magician


Joined: 29 Nov 2005
Posts: 482

PostPosted: Wed Jan 18, 2012 8:23 pm   
 
lol nope it returned on next logon with it still disabled. It must disable something else that is re-enabled on session reconnect.
_________________
Confucious say "Bugs in Programs need Hammer"
Reply with quote
edb6377
Magician


Joined: 29 Nov 2005
Posts: 482

PostPosted: Wed Jan 18, 2012 8:27 pm   
 
when typing manually it does not break

When using in a trigger it breaks

Original
<<V Hp>561</V>hp <V Sp>520</V>sp <V St>550</V>st>

After Trigger
<<V Hp>561</V>hp <V Sp>520</V>sp <V St><V St>550</V>st>

Looks similar right? well except for two things

1. extra <v st> in there
2. all the </v> no longer show up in the blue but in the color of the #'s
_________________
Confucious say "Bugs in Programs need Hammer"
Reply with quote
edb6377
Magician


Joined: 29 Nov 2005
Posts: 482

PostPosted: Mon Feb 06, 2012 3:09 pm   
 
okay guys i think i got this one. The only time i had this problem is when i called a trigger and then use #SHOW or #MXP with mxp commands. #SUB MXP Command works fine however. So until Zugg takes a gander and sees if there is an issue or not this might be a work around for you guys.

Below works fine and is an example of one of the ways i use it.
Code:

#LOCAL $quest $questurl
$quest=%-1
$questurl="http://annwn.info/quest/search?search=quest&sort=questname~&keyword="%replace( $quest, " ", "+")
#SUB {%trigger<A '$questurl' '$quest'>%ansi(bright,white)Check Annwn for quest</a>}
_________________
Confucious say "Bugs in Programs need Hammer"
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net