Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion

Joined: 07 Feb 2002
Posts: 333
Location: Central Virginia

PostPosted: Thu Dec 23, 2010 5:58 am   

[3.33a] Something went terribly wrong.
I was trying out a MUD someone suggested the other night when something went terribly wrong. I was feeling things out and had put a few scripts in place to make life easier. I figured it was time to set the mapper up and do a bit more exploring. I clicked the map button and CMUD started to create the .dbm file I guess. All of the sudden this little window pops up:

Mind you this was a brand new session I had just created with no previous map file on my pc for the MUD. I clicked ok the CMUD error box popped up. Here is the report.:
date/time         : 2010-12-23, 00:35:05, 987ms
computer name     : MIKE-PC
user name         : mike <admin>
registered owner  : mike
operating system  : Windows Vista Service Pack 2 build 6002
system language   : English
system up time    : 46 minutes 31 seconds
program up time   : 26 minutes 13 seconds
processors        : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
physical memory   : 1723/3070 MB (free/total)
free disk space   : (C:) 158.20 GB
display mode      : 1440x900, 32 bit
process id        : $8e8
allocated memory  : 74.82 MB
executable        : cMUD.exe
exec. date/time   : 2010-12-15 17:14
version           :
compiled with     : BCB 2006/07
madExcept version : 3.0k
data dir          : C:\Users\mike\Documents\My Games\CMUD\
contact name      : Mike Davis
contact email     : omitted
callstack crc     : $09cb2bc4, $5a7fa924, $5a7fa924
exception number  : 2
exception class   : EZSQLException
exception message : SQL Error: SQL logic error or missing database.

Main ($730):
0089f738 +0f8 cMUD.exe     ZDbcSqLiteUtils       229  +14 CheckSQLiteError
008a860d +085 cMUD.exe     ZDbcSqLiteStatement   177   +8 TZSQLiteStatement.ExecuteQuery
0089a1b2 +036 cMUD.exe     ZDbcStatement        1984   +1 TZEmulatedPreparedStatement.ExecuteQuery
0089a2b3 +02f cMUD.exe     ZDbcStatement        2025   +1 TZEmulatedPreparedStatement.ExecuteQueryPrepared
009071f4 +1a4 cMUD.exe     ZAbstractRODataset   1564  +25 TZAbstractRODataset.CreateResultSet
009000de +02e cMUD.exe     ZAbstractDataset      329   +1 TZAbstractDataset.CreateResultSet
009072f6 +0a2 cMUD.exe     ZAbstractRODataset   1588  +12 TZAbstractRODataset.InternalOpen
0060a56d +019 cMUD.exe     DB                             TDataSet.DoInternalOpen
0060a626 +01e cMUD.exe     DB                             TDataSet.OpenCursor
0060a4e1 +055 cMUD.exe     DB                             TDataSet.SetActive
00dc7a32 +146 cMUD.exe     RoomRec3              437  +30 TRoomRec.Create
00dbb0e3 +29b cMUD.exe     MapList3             1226  +44 TMapNode.LoadMap
00dc2fa5 +035 cMUD.exe     MapList3             4091   +3 AddMapDB
00dc2fd4 +018 cMUD.exe     MapList3             4100   +2 GetMapDB
00dc3044 +044 cMUD.exe     MapList3             4112   +6 UpdateMapDB
00cce554 +110 cMUD.exe     PARENT               2504  +23 TParentForm.CreateWindows
00dd4821 +011 cMUD.exe     PrefDat              3329   +1 PkgData.CreateWindows
00dd4f5c +528 cMUD.exe     PrefDat              3524  +95 PkgData.Load
00cce979 +29d cMUD.exe     PARENT               2657 +112 TParentForm.NewWindow
00ce203f +053 cMUD.exe     PARENT              11108   +6 TParentForm.WMCheckDock
004bc0b7 +2bb cMUD.exe     Controls                       TControl.WndProc
004c00bb +4fb cMUD.exe     Controls                       TWinControl.WndProc
004a261b +553 cMUD.exe     Forms                          TCustomForm.WndProc
00725587 +0a3 cMUD.exe     aqDockingBase        2604  +11 TaqDockCaptionButtonsEx.RelocateCustomButton
00c7b20c +020 cMUD.exe     DXSounds             2128   +9 TCustomDXSound.FormWndProc
00c796fc +00c cMUD.exe     DXClass               635   +1 TControlSubClass.WndProc
004bf7e4 +02c cMUD.exe     Controls                       TWinControl.MainWndProc
0047d448 +014 cMUD.exe     Classes                        StdWndProc
7694b754 +016 USER32.dll                                  CallWindowProcA
006f96b7 +0a7 cMUD.exe     aqDockingUtils       1728   +7 CallDefWndProc
006f97a5 +0dd cMUD.exe     aqDockingUtils       1776  +41 TaqWindowEventFilter.WndProc
0047d448 +014 cMUD.exe     Classes                        StdWndProc
76938b77 +00a USER32.dll                                  DispatchMessageA
004aa790 +0fc cMUD.exe     Forms                          TApplication.ProcessMessage
004aa7ca +00a cMUD.exe     Forms                          TApplication.HandleMessage
004aaabf +0b3 cMUD.exe     Forms                          TApplication.Run
00e8cdec +088 cMUD.exe     CMUD                  371  +20 initialization
7725d0e7 +010 kernel32.dll                                BaseThreadInitThunk

I created the session using the built in MUD selector and didn't realize the session folder got assigned a name with ... at the end of it. I'm thinking maybe this has something do do with the problem. So I decide I'll just wipe the session and create a new one without the punctuation at the end of the name. If only it was that simple... I open windows explorer, go to CMUD's MyDocuments location and well I can't delete the folder....

This presents an interesting problem. I ran chkdisk just for the heck of it and came up with no problems. I rebooted and tried to delete the folder again but the problem is still there. Any suggestions on how to remove the folder?
Windows Vista Home Premium SP2 32-bit
AMD Athlon Dual Core 4400+ 2.31 GHz
CMUD 3.34
Reply with quote

Joined: 07 Feb 2002
Posts: 333
Location: Central Virginia

PostPosted: Thu Dec 23, 2010 8:32 am   
I found an article that suggested I should re index my drive, so I'm in the process of doing that now. In the mean time I've recreated a session for the mud excluding punctuation from the name. I opened the session and tried to create a map with success. No errors so far. So this leads me to believe the problem was in the ... at the end of the session name. If I manage to remove the original problem folder I will create a new session with a similar name and see if the error occurs again. I don't want to compound the problem right now though.

If this does turn out to be the issue there should probably be some sort of check added in when creating a new session, using the built in mudconnector list. So that MUDs that have punctuation at the end of their names will not cause such errors for others in the future.
Windows Vista Home Premium SP2 32-bit
AMD Athlon Dual Core 4400+ 2.31 GHz
CMUD 3.34
Reply with quote

Joined: 10 Apr 2009
Posts: 145

PostPosted: Thu Dec 23, 2010 10:53 am   
Interesting. A problem with Windows, certainly.
I found a way you could use to delete the ... folder:

Make a new folder in C:\Users\mike\Documents\My Games, call it CMUD2 or something.
Move everything from the CMUD folder into CMUD2, except the strange ... folder.
In a command prompt:
cd "c:\Users\mike\Documents\My Games"
rmdir CMUD /s

This should remove the old CMUD folder, along with the ... folder. Then you can rename CMUD2 to CMUD and everything should be back to normal.

This works in Windows 7, and I think the rmdir /s feature was added in a recent version, but not sure if it was 7 or Vista... Good luck.
Reply with quote

Joined: 07 Feb 2002
Posts: 333
Location: Central Virginia

PostPosted: Thu Dec 23, 2010 12:15 pm   
Thanks Moo, that cleared the garbage out of the folder. Vista will not let you create a folder with a name that ends in periods. I tried both creating a new folder in the explorer named test... and using mkdir test... on the command line. Both times the folder was created as test not test... . Now if you open CMUD and create a new session called test... the folder is created as test... . I'm not sure what other characters might present similar issues to this, and there only looks to be a hand full of MUDs on the list that end in periods on the mudconnector list in CMUD. I'm not sure what would be the best way to address this, but something should be done to prevent CMUD from creating folders with invalid names.
Windows Vista Home Premium SP2 32-bit
AMD Athlon Dual Core 4400+ 2.31 GHz
CMUD 3.34
Reply with quote

Joined: 25 Sep 2000
Posts: 23379
Location: Colorado, USA

PostPosted: Mon Jan 03, 2011 6:02 pm   
CMUD already tries to check for invalid names, but since the "." character is a valid character in a filename, CMUD allows it. The fact that Windows normally allows "." in a file name but then screws up when multiple dots are used in a row like this is definitely a Windows issue and I really don't want to try coding special cases like that into CMUD itself. And I don't think the Windows API has any simply routine to check for a valid filename, but if somebody knows of a routine that will do that, let me know.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by