Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
Gerth
Newbie


Joined: 30 Jul 2007
Posts: 4

PostPosted: Mon Jul 30, 2007 2:11 am   

Mapper Won't Follow
 
The mapper works fine in mapping mode (usually), but when I'm done mapping and try to use it in follow mode it doesn't follow no matter what I try.
Reply with quote
Fang Xianfu
GURU


Joined: 26 Jan 2004
Posts: 5155
Location: United Kingdom

PostPosted: Mon Jul 30, 2007 2:15 am   
 
The main culprit of this is when the room description (or what the mapper thinks is the room description) changes. This can include things like weather and items in the room if the mapper thinks they're part of the description. Right-click on a room in the mapper and view its properties and see if the room descriptions match. If they don't, reconfigure the mapper, but this time uncheck the "Room Description" box so that the mapper will ignore it.

If that's not the issue, fixing it will involve the #tag command. If you need help using it, just ask.
_________________
Rorso's syntax colouriser.

- Happy bunny is happy! (1/25)
Reply with quote
Gerth
Newbie


Joined: 30 Jul 2007
Posts: 4

PostPosted: Mon Jul 30, 2007 2:38 am   
 
Well, when I made the map I only recorded exits... so there were no room descriptions (because I play in brief setting w/out displaying room descrip.)
But I tried again recording room descriptions, and everything matches. But when I go into follow mode, the blue dot just doesn't move. It never follows... I don't get it.
Reply with quote
Gerth
Newbie


Joined: 30 Jul 2007
Posts: 4

PostPosted: Mon Jul 30, 2007 2:46 am   
 
In fact, when I go into mapping mode, the blue dot only goes into new rooms (i.e., only creates new rooms and moves around only in the rooms I've just created). But when I try to go into a room I've already mapped (i.e., rooms of the map I just loaded), it doesn't move.
Reply with quote
Gerth
Newbie


Joined: 30 Jul 2007
Posts: 4

PostPosted: Mon Jul 30, 2007 2:50 am   
 
Ok, sorry, I just realized this problem is only happening with one of my maps. That one must just be glitched *shrug*
Reply with quote
Oozenthor
Beginner


Joined: 31 Jul 2006
Posts: 18

PostPosted: Mon Jul 30, 2007 9:38 pm   
 
I have had this happen when rooms have certain flags set. To fix it I set all the flags to off.
Reply with quote
DeReP
Adept


Joined: 14 Jun 2003
Posts: 222
Location: Chile

PostPosted: Thu Sep 13, 2007 4:19 pm   
 
Well, appearently Im having a similar problem. Map just doesnt follow me, even in fast walk. I've noticed that the queue is not parsing descriptions. Only when I use the #FIND command from the main mud screen I see a change in the mapper (Switches to Mapping mode and back to Follow). When I use Macros From the Keypad the Mapper is unresponsive to any movement, anyone had a similar Issue?
On another note, are you sopoused to configure the Keypad Keys or they come predifenide like in Zmud?
I hear about this English Directions Package and Keypad but nothing was configured when I created the new Character, and the files are installed and all, maybe Im missing something?
Thanks in advance.
Reply with quote
Fang Xianfu
GURU


Joined: 26 Jan 2004
Posts: 5155
Location: United Kingdom

PostPosted: Thu Sep 13, 2007 5:02 pm   
 
To check for the English Directions and Keypad packages, open your preferences and look at the Packages tab in the Scripting section. They should both be listed there.

The english keypad package configures the keypad keys to match direction commands. The english directions package links those direction commands to the mapper. If those packages are enabled, you don't need to confgure it yourself.

PS. If they're not on the list, to add them - on the Select Session dialogue that pops up when CMUD starts, right-click your session and choose Edit Session. On the Package Files tab, click the plus symbol and find the English Directions package (probably in My Documents\My Games\CMUD\packages\) and open. Then do the same for the Keypad and save changes.
_________________
Rorso's syntax colouriser.

- Happy bunny is happy! (1/25)
Reply with quote
DeReP
Adept


Joined: 14 Jun 2003
Posts: 222
Location: Chile

PostPosted: Thu Sep 13, 2007 5:31 pm   
 
Thanks for the reply. Both of the packages are listed where you pointed me, but I guess none of them are loaded correctly for the session. First time I installed Cmud I had to write myself the macros for the keypad couse it wasnt working, I found this to be a bit odd.
Could it be that I'm running multiple windows in my layout and the mapper is assigned to a different window or something? Though it does have the name "Map for PeReD" (PeReD is my main window) in the title bar.
Thanks again.
Reply with quote
Seb
Wizard


Joined: 14 Aug 2004
Posts: 1244

PostPosted: Thu Sep 13, 2007 9:04 pm   
 
When you have the mapper in follow mode, do you get anything in the mapper queue? Does the mapper work in map creation mode?
Reply with quote
DeReP
Adept


Joined: 14 Jun 2003
Posts: 222
Location: Chile

PostPosted: Fri Sep 14, 2007 5:05 am   
 
Havent tried the map creation mode, Im trying to import stuff from Zmud to Cmud. The massive import just didnt work for me, crashed Cmud all the time, must be some buttons or something, who knows, theres a lot of stuff.
Map follow mode doesnt respond to any movement, nor does it queue any command.
Reply with quote
Tech
GURU


Joined: 18 Oct 2000
Posts: 2733
Location: Atlanta, USA

PostPosted: Fri Sep 14, 2007 4:51 pm   
 
Did you try reconfiguring the mapper in CMUD?

It sounds like you had a problematic conversion, so reconfiguring the mapper should help.
_________________
Asati di tempari!
Reply with quote
DeReP
Adept


Joined: 14 Jun 2003
Posts: 222
Location: Chile

PostPosted: Fri Sep 14, 2007 6:01 pm   
 
yeah I already reconfigured, it seems to me that the problem is with the keypad package. When I first ran CMUD with this new Session, I didnt have the keypad enabled by default, as in Zmud. The packages are there, but I guess they are not being loaded. Is there a way to reinstall this packages or "reload" them?
Right now the mapper will only make a slight response when I enter a #look command in the main window.
Thanks in advance.
PeReD.
Reply with quote
Seb
Wizard


Joined: 14 Aug 2004
Posts: 1244

PostPosted: Fri Sep 14, 2007 10:50 pm   
 
Yeah, I think you are right - the directions packages are probably not loaded. With your session open, if you go to "Preferences, Scripting, Packages", you should normally have "English Keypad" and "English Directions". Do you? If not, add them.
Reply with quote
DeReP
Adept


Joined: 14 Jun 2003
Posts: 222
Location: Chile

PostPosted: Sat Sep 15, 2007 7:03 am   
 
Yeah they are both there in the list. Not sure what is going on atm, but I guess they should have worked on first install, wich they didnt.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net