Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » zMUD General Discussion Goto page Previous  1, 2, 3, 4, 5, 6  Next
undergod Posted: Sun Sep 22, 2002 3:05 am
ZMud and Linux?

Joined: 12 May 2002
Posts: 7

PostPosted: Fri Nov 21, 2003 4:44 am   
Not only am I doing this to make the 100th post (or is it 100th reply? ^_^), but to ask a question: has anyone who has a copy of WineX tried installing MDAC (and so making zMud actually work), instead of Wine? Any results in that direction?
Reply with quote

Joined: 10 Oct 2000
Posts: 698

PostPosted: Sat Nov 22, 2003 3:10 pm   
I don't know a thing about .nix stuff but came across this. It was posted on a mud board. Any chance this will help zmud do its thing?
Reply with quote

Joined: 23 Nov 2003
Posts: 1
Location: Sweden

PostPosted: Sun Nov 23, 2003 2:30 pm   
I don't quite follow you when you claim that linux users are worse than the windows crowd when it comes to paying for stuff they can get for free.

I know alot of people that have copies of Windows installed that they havn't payed for. Copies of MS Office, winzip, winamp and not to forget all the games people download. The list can be made long. I payed for my copy of zmud and am now using Fedora linux and I think that most linux users would indeed pay for their copy of zmud. Alot of linux users are programmers that realize that other have spent lots of time in making the program.

Isn't this thread and the length of it a pretty good sign that zMUD for Linux is wanted!

Please consider it!


Originally posted by Kjata

Two of the greatest problem of porting zMUD have been that it uses some third-party components that are only available for the Windows version of Delphi and, most importantly, that it does some speed tricks which are Windows-specific. Bottom line is, Linux zMUD would not be the zMUD we have come to know and love.

That is not completely true, since I believe Zugg could work hard to overcome these problems. However, since right from the start he is confronted with these sort of problems in porting zMUD, he needs a good reason for porting zMUD to Linux. Let's face it, although many us would buy zMUD with no problems, the Linux crowd is worse than the Windows crowd when it comes to paying for stuff they can get for free (even if the replacement is inferior). As a result, the risks involved in porting zMUD outweight the possible benefits.


Reply with quote

Joined: 10 Oct 2000
Posts: 4379
Location: USA

PostPosted: Sun Nov 23, 2003 8:28 pm   
Yeah, and I know a lot of Linux users, and have seen countless others in the Internet, that when offered a choice between a great product and a free, but inferior product, they choose the free one. I know Windows users like what you described too, but if I believe that if you put these two groups of people into percentages with respect to their respective total OS user base, you will find that Linux's percentage is bigger.

There are currently 7801 registered members in this forum. Of those, around 40 have posted in this thread. If we take these numbers as a really bad aproximation, we get around .5% of customers that would pay for a Linux version of zMUD. I'm quite sure that possibly the most you can get this number to is around 5% of the total zMUD user base.

Zugg has looked into it himself, and it's just not profitable for him.
Reply with quote

Joined: 28 Oct 2003
Posts: 164

PostPosted: Sun Nov 23, 2003 10:38 pm   
Yeah, you also have to factor in ongoing support for versions on both Windows and Linux. There will be bugs specific to Linux, just as there are bugs specific to Windows. Speaking as a programmer, it's a simple fact that the OS frequently gets in your way. Sometimes it's your fault, sometimes it's the OS. But it doesn't really matter, because you'll wind up getting bugs in both.

So not only does it have to be worth the initial development, it has to be worth the ongoing support.
Reply with quote

Joined: 26 Dec 2003
Posts: 2
Location: Poland

PostPosted: Fri Dec 26, 2003 10:28 am   
Well, I have actually managed to get MDAC and MS JET installed
under WINE (took me almost a whole day) - and so the zMapper and zMud installs with no problems.
But then when i run zMud it coplains it can't find zsconvert (while it is in its directory) and zMapper starts loading and then produces a very meaningful output 'Error opening file' and lets me press the 'OK' button :( ... Could you please Zugg include some more verbocity in such alerts so I could debug it and get it working?
(Gentoo/Linux, WINE20031212, MDAC2.8, JET4.0SP7, zMapper1.22, zMud6.66)

Reply with quote

Joined: 24 Sep 2000
Posts: 1237
Location: USA

PostPosted: Fri Dec 26, 2003 3:23 pm   
You wouldn't want to deliver an after-Christmas present and document how you got it running, would ya?
Reply with quote

Joined: 26 Dec 2003
Posts: 2
Location: Poland

PostPosted: Fri Dec 26, 2003 4:48 pm   
Well, if I can make a few people happy at once then fine Smile i'll try to describe what I have done, and hope you will help me get further with it ...
OK, I'm writing from the top of my head since I have not made any notes, but most Very Happy of it shall be correct.
First, I have installes a fresh wine 'fake_windows' dir and registry files. Config is basically the same as delivered with wine, emulating 'win98'.
To start with, I had to install the IE (in my case 6SP1) - most MS apps complain if they don't see it so it is a must. There are several descriptions on the web ('frankiescorner' is the site I think I used). It takes several stages. I have not managed to get the fully IE working, but at least the IE window opens when I start it - although it does not display any content. Enough for me since other apps now see the IE and proceed with installation.
Now the MDAC - the trick I have come up with is to install the MDAC 2.5 SP3 (installs with no problems) and on top of this any other MDAC (2.8 in my case) sometimes the installation of the second mdac stops at copying file 'dt16.dll' or something like it - the solution is to kill installation, kill all wine processes, delete this dll from fake c:windowssystem and start the installation again.
After the MDAC is installed remember to reboot the wine (wine wineboot).
Finally, the JET ODBC - I have tried only the 4.0 SP7 - the problem I have encountered, wine seemed not to be able to replace certain dlls in windows/system so I run install of JET once, then run the following script (below) and install JET again

WINE_ROOT='path to your wine 'c' drive'

cd $WINE_ROOT/Windows/System/
for lb in
msjter40.dll msjetoledb40.dll msrd2x40.dll msrd3x40.dll
vbajet32.dll msrepl40.dll mswstr10.dll mswdat10.dll
msjint40.dll msexch40.dll msexcl40.dll msltus40.dll
mspbde40.dll mstext40.dll msxbde40.dll msjtes40.dll expsrv.dll;
rm $lb;

cd $WINE_ROOT/Program Files/Common Files/Microsoft Shared/dao/
for lb in
rm $lb;

ok, thats all so far - the zmapper and zmud installs now without problems ;-)
Ah, and when running any install of MDAC or JET I have used several overrides of dlls (like the one below):

WINEDLLOVERRIDES="ole32,oleaut32,rpcrt4=n" wine Jet40SP7_9xNT.exe

Hope it helps :)
Reply with quote

Joined: 09 Jan 2004
Posts: 4
Location: USA

PostPosted: Fri Jan 09, 2004 7:36 am   
I seem to have Zmud running under wine.

System - Gentoo
Wine version - vanilla wine-20031212 fresh compile and install (didnt use Gentoo ebuild)

Once wine was installed I followed the instructions at frankscorner to install IE6sp1 and DCOM98. I used the manual way (method 2 listed)

ran 'wine wineboot' and tested IE - worked and loaded, quickly exited it before my eyes started to bleed.

installed latest MDAC (i believe it was 2.8) for win98 from microsoft, ran into no problems

wineboot again

Installed Jet4SP3 (had to get these from zugg), install zoomed by so fast i didnt see it, seemed to work ok.

wineboot again

Installed Jet4SP6 same result as SP4

wineboot again

wine config is Managed - no, Desktop 1024x768

Installed zmud 6.62, install went fine

wine zmud.exe, 2 windows come up, one says "runservice.exe blah blah, other is zmud. splash says 'register or die a slow death' or something to that effect. Also asked me to upgrade, didn't yet.

Window looks a little wierd (the max/min buttons were not showing, i guessed where maximize was and it maxed, then showed the max min buttons fine)

clicking on tutorials and other help files yields nothing in view window.

After exiting have to kill processes to get rid of the other window.

I am new to mudding so I havent tested it other than a quick connect to Materia Magica. Fonts were a little ugly, but i still have to set that up.
Reply with quote

Joined: 09 Jan 2004
Posts: 4
Location: USA

PostPosted: Fri Jan 09, 2004 7:46 am   
some screenies:

Here you can see what I am talking about when I say the min/max buttons arent there. Had Desktop size in config too big as you can see my Kicker.


Connected to materia magica
Reply with quote

Joined: 09 Jan 2004
Posts: 4
Location: USA

PostPosted: Fri Jan 09, 2004 7:38 pm   

Automapping wouldn't start up, complained of Richedit txt insertion error. Some reseaerch and the dlls needed are riched20.dll and riched32.dll

I downloaded several versions and finally got it working. Zugg should be able to tell us exactly which versions we need. Someone should try the ones from a windows install or thier windows CD. should be in Cab 22 i think.


You can see the widgets are still a little screwy. Probably need to override a dll or 2.

Reply with quote

Joined: 10 Oct 2000
Posts: 1551
Location: Australia

PostPosted: Fri Jan 09, 2004 9:35 pm   
Now that is very cool. Is the scrolling/mapping fast, or do you have problems like I was getting with the i386 emulator?
Reply with quote

Joined: 09 Jan 2004
Posts: 4
Location: USA

PostPosted: Sat Jan 10, 2004 4:42 am   
Everything seems to work fast, but I don't have windows installled to compare it to.

I had a session open on a smaug mud I put on my box to test with. Automapping worked, but it was unstable when using the menus and eventually crashed. I'll keep playing with it to see if I can get it stable.

Zugg guys.. are you using MS common controls for the menus (cmctl32, commctl)? They seem to be part of the stability issue.
Reply with quote

Joined: 22 Jan 2004
Posts: 1
Location: Sweden

PostPosted: Thu Jan 22, 2004 4:59 pm   
Well, just wanted to report that I've got zMUD 6.62 up and running using wine too. I basically just installed wine, IE, mdac, jet, dcom98, added some dll-overrides and got it running :)

Seems to work quite well, mapper works, triggers/aliases works, speedwalks works.

The only problem so far is that the mapper won't stay on top, and that the textbox seems to have some problems with text scrolling fast. But well, it's fully usuable :)

I'll monitor this thread and answer if someone wants help with setting it up.
Reply with quote

Joined: 24 Jan 2004
Posts: 1
Location: Australia

PostPosted: Sat Jan 24, 2004 1:04 pm   
Well guys just letten you know i tried it out on my new Xandros 2 deluxe version desktop and it seems to be worken fine with a few minor flaws i can live with. Just had to insall the above mentioned files using the codeweavers program included in Xandros 2. Have been playing Materia Magica happily now for 3 days with zmud on linux and my clannies and friends online reckon its cool and want to do it too.

Just an after thought, instead of porting to linux, why not work with the wine program or codeweavers to get zMud to work better on linux. I know other companies have worked with them to get programs to work. I even think DIsney gave the wine project 20000 to get Photoshop 7 to work on linux, so it is worth a shot if you can work something out.
Reply with quote

Joined: 02 Mar 2004
Posts: 2
Location: USA

PostPosted: Tue Mar 02, 2004 10:51 am   
Yup, not too tough even for a complete wine newbie like me (although I *am* a programmer) to get zmud going.

For what it's worth, I'm on Gentoo (2.4.22-gentoo-r5) and using stock wine 20031212 with IE6, DCOM98, and then Zugg's required files on for win98.

I'm not a big "support" person, but I can outline details on the install if anyone cares. Um, but it's pretty crude - install wise. I'm sure it can be improved hugely. Anytime you just dump dlls into a program directory... *shudders* Seems to work pretty close to fully though except for some minor graphical glitches on little painted surfaces like unused menubar spaces. I *know* the DB works pretty well, ran queries through a couple thousand item Medievia item DB I imported. Not sure about the mapper... internet input/output and trigger/alias processing seems darn near perfect. Nice and faaaast. :)

Oh yeah, the elicense stuff seems to work fine too as far as installs go, but BE WARNED, I haven't tried unlicensing yet. Who would? [8D]
Reply with quote

Joined: 25 Oct 2000
Posts: 461
Location: USA

PostPosted: Sat Mar 06, 2004 4:49 am   

As I mentioned over on the Gentoo boards, please post any details you have! Gonna play around with the latest gentoo again if I can get zmud working on it ;)
Reply with quote

Joined: 11 Feb 2004
Posts: 6
Location: USA

PostPosted: Sun Mar 07, 2004 12:59 am   
Just gonna throw in my 2 cents.
I run what once was a slackware machine.. I think it used to be slackware 7.0 but has been upgraded many times.. and many packages I've rebuilt myself. I have codewaeavers wine winex and cvs wine from about january. I've also got OfficeXP and IE6. Zmud 7.01 runs beautifully.
I've had a few issues same as the others. widgets have a lil trouble and the settings window seems to have issues.. like i can;t click and drag any setting from one setting to another setting.
I use the codewaeaver wine for running zmud and it seems to have to real problems accept every once in a while when I close a "spawned" window i get a return error but zmud keeps running.

if you are interested in my setup. I have an installed ( but rarely used ) Windows 98. This is where i pull (native) dlls from. My most major complaint was when uxtheme.dll was added to zmud's startup. uxtheme.dll is windows xp specific i believe. it's the only reason i'm forced to use codeweavers wine. my old install of zmud 6.65 or something ran great under cvs wine.

If anyone is interested I'll post my Config files. and any other requested info.
Reply with quote

Joined: 25 Oct 2000
Posts: 461
Location: USA

PostPosted: Fri Mar 12, 2004 4:37 am   
Well, I could use a few more hints. I'm in Gentoo as well, and I sucked down the latest Wine from portage (the 030904 build). Got IE6 and the MDAC running okay, but JetSP3 doesn't want to behave. However, I can install JetSP6 without error. Sadly, zmud comes up and says that I don't have the appropriate stuff installed to run it (though I get the intro screens okay). So I'm stumped, as I am not getting a specific error!

EDIT: It is a specific error... the window title says it is unable to intialize the database, so it is still a jet issue. Bah!
Reply with quote

Joined: 11 Feb 2004
Posts: 6
Location: USA

PostPosted: Fri Mar 12, 2004 11:05 am   
Just a link for some screenshots on linux

I run ROX desktop. Openbox window manager. CVS wine. zmud 7.04
Kernel 2.4.22
XFree86 Version 4.3.0
Release Date: 27 February 2003
Wine 20040213
Reply with quote

Joined: 21 Dec 2001
Posts: 59
Location: USA

PostPosted: Sun Mar 14, 2004 12:59 am   
anybody know how to get rid of this problem on Wine-20040309?

"sorry, could not get a license at this time, try running this program later.

it's probably simple, I just don't know how to fix it.
Reply with quote

Joined: 21 Dec 2001
Posts: 59
Location: USA

PostPosted: Sun Mar 14, 2004 7:01 am   
A little actual brain activity has made it clear to me that this must be an elicense problem and all you who got 6.62 or whatever version running must have fixed it. How?
Reply with quote

Joined: 21 Dec 2001
Posts: 59
Location: USA

PostPosted: Sun Mar 14, 2004 10:14 am   
ok, so i was an idiot and didn't read the stuff at the top of the forum *slaps forehead*
I sent off an e-mail, see if their fix program works under wine :-)
Reply with quote

Joined: 25 Oct 2000
Posts: 461
Location: USA

PostPosted: Sun Mar 14, 2004 11:43 pm   
Tejing... how did you get mdac/JET installed happily? For the life of me it complains with Thunk errors and other assorted fun when trying to get them on (and without which zmud won't work, of course).

EDIT: Aha! I found the secret to a clean mdac/jet install... I had to go swipe setupx.dll from and drop it into the fake_windows/Windows/System directory. zmud is closer to working now... though not there yet.
Reply with quote

Joined: 31 May 2003
Posts: 49

PostPosted: Fri Apr 16, 2004 10:46 am   
can the people put their config for winex (from cvs) to run zmud?
mine is this, and i can not install jet ole db
# <wineconf>

; This doesn't work in WineX, but its here for WineHQ compatability.
; can be (win95, win98, winme, nt351, nt40, win2k, winxp, win20, win30, win31)
"Windows" = "win98"
; dos version
;"DOS" = "6.22"

"DefaultLoadOrder" = "native, builtin, so"

"commdlg" = "native, builtin"
"comdlg32" = "native, builtin"
"ver" = "native, builtin"
"version" = "native, builtin"
"shell" = "native, builtin"
"shell32" = "native, builtin"
"shfolder" = "native, builtin"
"shlwapi" = "native, builtin"
"shdocvw" = "native, builtin"
"lzexpand" = "native, builtin"
"lz32" = "native, builtin"
"comctl32" = "native, builtin"
"commctrl" = "native, builtin"
"advapi32" = "native, builtin"
"crtdll" = "native, builtin"
"mpr" = "native, builtin"
"winspool.drv" = "native, builtin"
"d3d8" = "native, builtin"
"d3drm" = "native, builtin"
"ddraw" = "native, builtin"
"dinput" = "native, builtin"
"dinput8" = "native, builtin"
"dmusic" = "native, builtin"
"dsound" = "native, builtin"
"opengl32" = "native, builtin"
"msvcrt" = "native, builtin"
"rpcrt4" = "native, builtin"
"msvideo" = "native, builtin"
"msvfw32" = "native, builtin"
"mcicda.drv" = "native, builtin"
"mciseq.drv" = "native, builtin"
"mciwave.drv" = "native, builtin"
"mciavi.drv" = "native, builtin"
"mcianim.drv" = "native, builtin"
"msacm.drv" = "native, builtin"
"msacm" = "native, builtin"
"msacm32" = "native, builtin"
"midimap.drv" = "native, builtin"

; Number of colors to allocate from the system palette
"AllocSystemColors" = "100"
; Number of colors to copy from the default palette
"CopyDefaultColors" = "0"
; Use a private color map
"PrivateColorMap" = "N"
; Favor correctness over speed in some graphics operations
"PerfectGraphics" = "N"
; Color depth to use on multi-depth screens
;;"ScreenDepth" = "16"
; Name of X11 display to use
;;"Display" = ":0.0"
; Allow the window manager to manage created windows
"Managed" = "Y"
; Use a desktop window of 640x480 for Wine
;"Desktop" = "800x600"
; Use XFree86 DGA extension if present
; (make sure /dev/mem is accessible by you !)
"UseDGA" = "N"
; Use XShm extension if present
"UseXShm" = "Y"
; Enable DirectX mouse grab
"DXGrab" = "Y"
; Use XVidMode extension if present
"UseXVidMode" = "Y"
; Create the desktop window with a double-buffered visual
; (useful to play OpenGL games)
"DesktopDoubleBuffered" = "Y"
; Code page used for captions in managed mode
; 0 means default ANSI code page (CP_ACP == 0)
"TextCP" = "0"
; Use this if you have more than one port for video on your setup
; (Wine uses for now the first 'input image' it finds).
;; "XVideoPort" = "43"
; Use this to make your X server execute all commands
; sequentially rather than buffering commands. Will make
; everything really SLOW but can be nice for debugging.
;; "Synchronous" = "Y"

;Read documentation/fonts before adding aliases
"Resolution" = "96"
"Default" = "-adobe-times-"

"Pattern0" = "-adobe-times*"
"Pattern1" = "-adobe-helvetica*"
"Pattern2" = "-adobe-courier*"
"Pattern3" = "-misc-fixed*"

"Com1" = "/dev/ttyS0"
"Com2" = "/dev/ttyS1"
"Com3" = "/dev/ttyS2"
"Com4" = "/dev/modem"

"Lpt1" = "/dev/lp0"

"LPT1:" = "|lpr"
"LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred -q -"
"LPT3:" = "/dev/lp3"

;"read" = "0x779,0x379,0x280-0x2a0"
; "write" = "0x779,0x379,0x280-0x2a0"

"Exclude" = "WM_SIZE;WM_TIMER;"

;These are all booleans. Y/y/T/t/1 are true, N/n/F/f/0 are false.
;Defaults are read all, write to Home
; Global registries (stored in /etc)
"LoadGlobalRegistryFiles" = "n"
; Home registries (stored in ~user/.wine/)
"LoadHomeRegistryFiles" = "Y"
; Load Windows registries from the Windows directory
"LoadWindowsRegistryFiles" = "n"
; TRY to write all changes to home registries
"WritetoHomeRegistryFiles" = "Y"
; Registry periodic save timeout in seconds
; "PeriodicSave" = "600"
; Save only modified keys
"SaveOnlyUpdatedKeys" = "Y"

;; supported styles are 'Win31'(default), 'Win95', 'Win98'
"WineLook" = "Win98"

"Drivers" = "xterm"
;"Drivers" = "tty"
"XtermProg" = "konsole"
;"InitialRows" = "25"
;"InitialColumns" = "80"
;"TerminalType" = "nxterm"

"ClearAllSelections" = "0"
"PersistentSelection" = "1"

; List of all directories directly contain .AFM files
;"1" = "/usr/share/ghostscript/fonts"
;"2" = "/usr/share/a2ps/afm"
;"3" = "/usr/share/enscript"
;"4" = "/usr/X11R6/lib/X11/fonts/Type1"

"Drivers" = "wineoss.drv"
"WaveMapper" = "msacm.drv"
"MidiMapper" = "midimap.drv"

"UseMMap" = "Y"
"FullDuplex" = "N"

;; sample AppDefaults entries
;"shlwapi" = "native"
;"rpcrt4" = "native"
;"ole32" = "native"
;"shdocvw" = "native"
;"wininet" = "native"
;"shfolder" = "native"
;"shell32" = "native"
;"shell" = "native"
;"comctl32" = "native"
;"Desktop" = "800x600"

# </wineconf>
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMUD General Discussion All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 5 of 6

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by