Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
hpoonis2010
Adept


Joined: 18 Jun 2019
Posts: 234

PostPosted: Tue Dec 28, 2021 2:32 pm   

Strange VAR value in editor
 
I have a bunch of vars, each has a unique number. They relate to mud portal tokens. Holds the token, enter the portal.

One portal token ID for area 'goldrush' is 2219436672 and, when I look at the value in the editor I see this number. However, when I use my script to use it it fails as the script seems to be looking for 2465638708.

I searched everywhere in editor and could not find this value. Yet, when I look at the XML for this class (Portal_VARS), I see:

Code:
<class name="Portal_VARS" id="238">
  <var name="academy" id="251">
    <value>2136610473</value>
    <json>2136610473</json>
  </var>
  <var name="immhomes" id="252">
    <value>2178928380</value>
    <json>2178928380</json>
  </var>
  <var name="legend" id="253">
    <value>2170257837</value>
    <json>2170257837</json>
  </var>
  <var name="petstore" id="255">
    <value>2170229212</value>
    <json>2170229212</json>
  </var>
  <var name="reme" id="258">
    <value>2143017789</value>
    <json>2143017789</json>
  </var>
  <var name="goldrush" id="261">
    <value>2465638708</value>
    <json>2465638708</json>
  </var>
  <var name="tao" id="263">
    <value>2286643397</value>
    <json>2286643397</json>
  </var>

etc


How is this possible? I manually altered the XML/JSON value but I am mystified as to why there was this hidden value.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4451
Location: Pensacola, FL, USA

PostPosted: Tue Dec 28, 2021 5:44 pm   
 
Without knowing how you assign the numbers in the first place, I could only offer bad speculation.
_________________
Discord: Shalimar#3679
Reply with quote
hpoonis2010
Adept


Joined: 18 Jun 2019
Posts: 234

PostPosted: Wed Dec 29, 2021 5:12 pm   
 
I checked my equipment dbvars after getting the XML into a text editor and 2465638708 exists nowhere.

This is certainly perplexing. I can find no scripts which write to the above vars which specify that series of digits and no vars which contain that series of digits.

I grabbed the XML from ALL my code and those two values I pasted in the code are the ONLY place where that number exists...and they exist only after being modified by something.
Reply with quote
hpoonis2010
Adept


Joined: 18 Jun 2019
Posts: 234

PostPosted: Wed Dec 29, 2021 5:33 pm   
 
OK. So I re-ran my script to write the portals vars and the editor value was correct but the json value did not change when I viewed the XML.

Then, I changed so that both values were correct and closed client. Opened client again and both values (XML) changed back to the incorrect one...and I still have nowhere which actually writes that number.

Then I changed the value and closed the client. After restarting client I checked the value in the editor and it was correct but when I looked at the XML, both values were incorrect.

HOW is it possible that the value shown in the editor does not match those shown when viewing the XML? I actually have 3 values: 1 correct and 2 incorrect for the same VAR.

Finally, I saved the 'script' for this one var usi9ng the little DISK icon in editor and it saved 2219436672 but exporting that same var as XML gives me

<?xml version="1.0" encoding="ISO-8859-1" ?>
<cmud>
<var name="goldrush">
<value>2465638708</value>
<json>2465638708</json>
</var>
</cmud>

Does this seem like rational and normal behaviour to ANYONE?
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4451
Location: Pensacola, FL, USA

PostPosted: Thu Dec 30, 2021 12:50 am   
 
It's possible you might have two copies of the variable.
_________________
Discord: Shalimar#3679
Reply with quote
hpoonis2010
Adept


Joined: 18 Jun 2019
Posts: 234

PostPosted: Thu Dec 30, 2021 6:24 am   
 
No. I searched everywhere. In the end I deleted it and recreated it. I shall see how that goes.
Reply with quote
hpoonis2010
Adept


Joined: 18 Jun 2019
Posts: 234

PostPosted: Tue Jan 04, 2022 7:24 am   
 
Recreating the variable has fixed that problem.

No need to express my frustration at the client.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net