Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
JRSteensen
Beginner


Joined: 27 Jul 2004
Posts: 25

PostPosted: Mon Apr 24, 2017 10:33 am   

How to hide informational CMUD messages when deleting a trigger, or on a #C+/#C-
 
Good evening! How would I suppress "informational" CMUD messages when I delete a trigger, or use the #C+/#C- commands?

I tried a trigger on the informational message of "Capture text ON" using "^Capture text %w$" with a script of "#IF (DEBUG = 0) {#GAGSPACE}". Unfortunately, #GAG and its child commands don't seem to gag these kinds of messages.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3707
Location: Pensacola, FL, USA

PostPosted: Mon Apr 24, 2017 7:18 pm   
 
The issue there is in your #IF statement, as I can #GAG the capture text line just fine.

DEBUG = 0

is just not true, 'debug' here will be treated as a string, if it was @debug it would be a variable reference and might have a chance of occasionally being true
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
JRSteensen
Beginner


Joined: 27 Jul 2004
Posts: 25

PostPosted: Tue Apr 25, 2017 9:48 am   
 
Oh, that was just a typo when I was typing it out here. Sorry about that.

Still can't gag it though. See here:

Code:
<trigger priority="28740" linecolor="11" id="2874">
  <pattern>Capture text %w</pattern>
  <value>#IF (@DEBUG = 1) {#GAGSPACE}</value>
</trigger>
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3707
Location: Pensacola, FL, USA

PostPosted: Fri Apr 28, 2017 5:45 am   
 
Well did you actually create a @debug variable so you could toggle whether or not you see this?
If not, you are taking an unneeded step with the #IF, just #GAG it directly.
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
JRSteensen
Beginner


Joined: 27 Jul 2004
Posts: 25

PostPosted: Fri Apr 28, 2017 7:28 am   
 
Not just for this - I use the debug variable all over in case I want verbose output for...stuff.

Even cutting everything out and just putting in a #GAG, doesn't seem to gag the CMUD generated output.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 3707
Location: Pensacola, FL, USA

PostPosted: Fri Apr 28, 2017 6:53 pm   
 
Well, that is very unusual.... did you play with the options any?
Set it to prompt instead of newline maybe?
I would just delete your current trigger and just enter this on the command line:

#TR {Capture text {ON|OFF}} {#GAG}
_________________
Windows 10 Home Premium 64-bit
AMD Phenom II x6 1055T 2.8GHz 16GB
CMUD Pro v3.34
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net