Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion

Joined: 26 Mar 2008
Posts: 1547

PostPosted: Thu May 26, 2011 11:23 pm   

[BUG] v3.34 Error Opening pcre810.dll library
Hey there!

When I went to startup CMUD today, I got a neat little dialog which said:
"Error Opening pcre810.dll library
Invalid access to memory location"

I was, of course, a bit shocked, since CMUD had worked fine the previous night and I literally hadn't made any changes to the program that I was aware of. I tried to come on to the website to ask about it, but it was down. So, instead, I did a google search and viewed a cached page. A similar error message, had, apparently, appeared in zMUD once upon a time, but, Zugg said that he couldn't reproduce it and so couldn't fix it.

There was a suggestion in the thread that I tried, backing up, deleting, and then recopying the proper DLL back into place: but it didn't work. So then I tried to uninstall and reinstall CMUD. The error persisted. So then I uninstalled CMUD and removed all of the stored sessions in the "CMUD" folder. Reinstalled. Problem persisted.

Zugg had mentioned that the fact that he could not reproduce it meant it must be something to do with the user's computer. I thought about what I could have done to my computer to cause this to happen. There had been no Windows Updates... nothing, and then I remembered:

Edit Pad Pro

I had been clued into this program by a Regex resource site and decided to give it a try, since I figured I was fairly handy at regex and it would be nice to add some powerful regex find/replace functionality to my text editing program.

I uninstalled CMUD and Edit Pad Pro. Reinstalled JUST CMUD. Still had the problem.

So I uninstalled CMUD and restarted my computer. Reinstalled, voila, problem solved.

So, I don't have the problem, but, perhaps, when Zugg is less busy, this might allow him to reproduce the error and see if it's fixable. It's possible that it's the fault of the other program and beyond his control, but I wouldn't know.

I also made the connection because I recently found out PCRE is used in regex, and thus the connection between the two. My suspicion is that Edit Pad Pro also uses the file and thus, for some reason, system confusion is caused.
Listen to my Guitar - If you like it, listen to more
Reply with quote

Joined: 18 Oct 2000
Posts: 2733
Location: Atlanta, USA

PostPosted: Fri May 27, 2011 4:48 am   
In another post, ( I forgot whose, or the specific issue) the mentioned a DLL loading issue as well. In those scenario, if the CMUD is loaded into memory first, the you avoid the DLL conflict something you can look into.

If it is a DLL loading issue, there's probably not much that can be done.
Asati di tempari!
Reply with quote

Joined: 02 Feb 2004
Posts: 364
Location: USA

PostPosted: Fri May 27, 2011 5:27 pm   
If I remember, the solution to this was to just restart your computer. May have been a different DLL issue, though.
Reply with quote

Joined: 26 Mar 2008
Posts: 1547

PostPosted: Sat May 28, 2011 1:41 am   
This error just popped up again and I have not installed any programs or made any changes to CMUD or my computer.
Listen to my Guitar - If you like it, listen to more
Reply with quote

Joined: 25 Sep 2000
Posts: 23379
Location: Colorado, USA

PostPosted: Tue Jun 07, 2011 7:20 pm   
This error (and similar errors with other DLLs) happens when Windows locks a DLL into memory and doesn't properly unload it. Sometimes it happens if multiple applications use the same DLL, sometimes it happens if you run the same app more than once. Sometimes it just happens. Seems to have happened more in Vista than in Windows 7, but it still happens. Happens more often with SQLITE.DLL than PCRE but can still happen with any DLL.

It's a stupid error message. It just means that Windows could not load the DLL library. It never tells you or me *why* it couldn't load. Sometimes the DLL is to blame (SQLITE.DLL happens much more than the newer SQLITE3.DLL). All CMUD is doing is calling the Windows LoadLibrary API, so there isn't anything else CMUD can do to help this situation, except maybe exit more gracefully when it happens.

The only solution I have ever found to this kind of error is to just reboot your computer. Windows still needs to be rebooted now and then.
Reply with quote

Joined: 15 Sep 2012
Posts: 2

PostPosted: Sun Jan 04, 2015 11:08 pm   Same problem, slightly different cause
I rebooted my Windows 8 computer this morning. On reboot, Adobe Reader offered to install an update, so I let it. After these 2 events, now when I start CMUD, I get the dll error, and my triggers no longer work. I'll try another reboot.
Reply with quote

Joined: 03 Oct 2007
Posts: 66

PostPosted: Mon Mar 20, 2017 7:02 am   PCRE810.dll error (FIXED) 2017
Hello, I got this error today 3/19/2017 running windows 10 and it completely destroyed my Cmud's ability to use triggers or anything script wise. I uninstalled, rebooted, loaded a fresh pkg file with no triggers but every time I added ANYTHING in terms of scripting, and rebooted cmud I'd still get the PCRE8100.dll error and my triggers / aliases and so fourth would no longer work. So, I worked on it for a while, had a few beers and found the easiest fix to this. I just downloaded a free DLL-fixer program, ran it, and there was a plethora of cmud errors. So, I ran the fix from the DLL-fixer, rebooted my computer, and everything works fine. I hope anyone else who gets this error and becomes increasingly frustrated with the error finds this and google searches for a DLL-fixer. Good luck!
Reply with quote

Joined: 21 May 2020
Posts: 32
Location: The Netherlands

PostPosted: Sat May 21, 2022 4:42 pm   Re: PCRE810.dll error (FIXED) 2017
What was the dll fixer called to solve this for free?
Reply with quote

Joined: 04 Aug 2002
Posts: 4677
Location: Pensacola, FL, USA

PostPosted: Sun May 22, 2022 7:18 am   
I find the solution to this was to wait longer after booting up to open CMUD.
Discord: Shalimarwildcat
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by