Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
Hemdall
Wanderer


Joined: 30 Nov 2006
Posts: 50

PostPosted: Fri Nov 12, 2010 5:36 pm   

Walking with double-click veeeery slow.
 
Hi,
I've noticed very big difference between speed of walking in v2 and v3. At this moment every time I got long speedwalk path cmud starts to send direction after direction (I always walk in fast mode) and it looks as it is waiting for some confirmation from mud. An example:
<double-click on map>
<cmud starts sending directions>
10:44:02:283 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:02:611 | <span style="color:#FFDAB9;">n</span><br/>
10:44:02:924 | <span style="color:#FFDAB9;">n</span><br/>
10:44:03:262 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:03:567 | <span style="color:#FFDAB9;">w</span><br/>
10:44:03:883 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:04:223 | <span style="color:#FFDAB9;">n</span><br/>
10:44:04:526 | <span style="color:#FFDAB9;">n</span><br/>
10:44:04:841 | <span style="color:#FFDAB9;">n</span><br/>
10:44:05:178 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:05:496 | <span style="color:#FFDAB9;">n</span><br/>
10:44:05:803 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:06:080 | <span style="color:#FFDAB9;">w</span><br/>
10:44:06:345 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:06:608 | <span style="color:#FFDAB9;">n</span><br/>
10:44:06:869 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:07:137 | <span style="color:#FFDAB9;">ne</span><br/>
10:44:07:401 | <span style="color:#FFDAB9;">n</span><br/>
10:44:07:661 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:07:926 | <span style="color:#FFDAB9;">n</span><br/>
10:44:08:190 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:08:450 | <span style="color:#FFDAB9;">w</span><br/>
10:44:08:710 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:08:979 | <span style="color:#FFDAB9;">w</span><br/>
10:44:09:249 | <span style="color:#FFDAB9;">w</span><br/>
10:44:09:513 | <span style="color:#FFDAB9;">nw</span><br/>
10:44:09:772 | <span style="color:#FFDAB9;">sw</span><br/>
10:44:10:018 | <span style="color:#FFDAB9;">w</span><br/>
10:44:10:278 | <span style="color:#FFDAB9;">w</span><br/>
10:44:10:517 | <span style="color:#FFDAB9;">w</span><br/>
10:44:10:755 | <span style="color:#FFDAB9;">w</span><br/>
10:44:11:002 | <span style="color:#FFDAB9;">s</span><br/>
10:44:11:259 | <span style="color:#FFDAB9;">s</span><br/>
10:44:11:514 | <span style="color:#FFDAB9;">s</span><br/>
10:44:11:770 | <span style="color:#FFDAB9;">most</span><br/>
10:44:12:028 | <span style="color:#FFDAB9;">s</span><br/>
10:44:12:292 | <span style="color:#FFDAB9;">s</span><br/>
10:44:12:545 | <span style="color:#FFDAB9;">se</span><br/>
10:44:12:800 | <span style="color:#FFDAB9;">sw</span><br/>
10:44:13:055 | <span style="color:#FFDAB9;">s</span><br/>
10:44:13:308 | <span style="color:#FFDAB9;">s</span><br/>
10:44:13:560 | <span style="color:#FFDAB9;">s</span><br/>
10:44:13:812 | <span style="color:#FFDAB9;">d</span><br/>
10:44:14:118 | <span style="color:#FFDAB9;">n</span><br/>
10:44:14:390 | <span style="color:#FFDAB9;">w</span><br/>
<After 12 seconds since first direction was sent my character starts to move>
10:44:14:688 | Ruszasz niespiesznie na zachod.<br/>
Any suggestions how to start run path without this delay?
Reply with quote
MattLofton
GURU


Joined: 23 Dec 2000
Posts: 4834
Location: USA

PostPosted: Fri Nov 12, 2010 8:39 pm   
 
If it's waiting for confirmation, you are not in fast mode. CMud doesn't care whether you run into walls or otherwise fail to move when you are in fast mode--you just start the move, CMud immediately moves the location dot, and then you get superspammed with the game output. Because the GMCP functionality was recently included, you are most likely in SAFE mode--which sort of combines the frontloading and speed of fast mode with the careful confirmation of slow mode.
_________________
EDIT: I didn't like my old signature
Reply with quote
Hemdall
Wanderer


Joined: 30 Nov 2006
Posts: 50

PostPosted: Sat Nov 13, 2010 8:21 am   
 
I do walk in fast mode - at last this is option I've chosen, that's why I'm asking why mapper behaving this way. I don't know what is GMCP for so I got it disabled.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Sat Nov 13, 2010 5:36 pm   
 
Maybe something is corrupted in your map. The Fast/Safe/Slow mode is tied to the specific Location object that is active in your session. So maybe the location object is screwed up somehow. You should use the #LOC command on the command line to see what location is active, then make sure this is the location shown in the lower-left corner of the mapper as the tracking location. Then you can try switching to Slow mode and then back to Fast mode to see if it makes any difference.

You might also try turning off your triggers in the Option/Enable Triggers menu to make sure it's not some script running in the background.

I can use fast walk instantly on both of the MUDs that I have tried here without any problem at all. So it's definitely something specific to your settings or session.
Reply with quote
Hemdall
Wanderer


Joined: 30 Nov 2006
Posts: 50

PostPosted: Sun Nov 14, 2010 5:49 am   
 
#loc
#print Walk mode is %walkmode()
> Locations (* is current, - is disabled):
* eidur at room 7982 (blue) <arkadia Map>
Walk mode is 0 also all triggers are disabled and still there is no difference in speed -
11 directions first was sent at 05:28:52:499
second at 05:29:17:512 (25 seconds later)
last one at 05:29:18:278
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4018
Location: Pensacola, FL, USA

PostPosted: Sun Nov 14, 2010 10:11 pm   
 
Try running your map through the map conversion tool and back... that -may- fix a map corruption, and is a lot quicker than trying to remake the map.
_________________
Discord: Shalimar#3679
Reply with quote
teion
Wanderer


Joined: 03 May 2005
Posts: 69

PostPosted: Tue Nov 16, 2010 4:27 pm   
 
My speed walk seems to be getting the same error here. This is a fresh map created with the new database, but I'll recheck my settings. currently even a 25 - 30 room walk takes about 30 seconds to speedwalk.

edit> when i close cmud and reopen it seems to work much much faster
Reply with quote
teion
Wanderer


Joined: 03 May 2005
Posts: 69

PostPosted: Tue Nov 16, 2010 4:32 pm   
 
ok I figured it out. Seems if you have the map zoomed out while double clicking it moves much slower than normal. Try zooming in on the map till you have about 15 rooms or so then using the #walk command and it works much quicker
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Nov 16, 2010 6:13 pm   
 
In your Map Properties in the Speedwalking tab, check the "Center map after every movement" and "update map on each step" options. I have those both turned off here and turning them on might cause CMUD to try and repaint the map for each step which can be slower when you are zoomed out and there are a lot of rooms to draw.
Reply with quote
teion
Wanderer


Joined: 03 May 2005
Posts: 69

PostPosted: Tue Nov 16, 2010 8:07 pm   
 
Worked I think your correct in the mapper was trying to redraw the location
Reply with quote
Hemdall
Wanderer


Joined: 30 Nov 2006
Posts: 50

PostPosted: Sat Nov 20, 2010 3:29 pm   
 
I have both options turned off so reason must be somewhere else. I've noticed another thing - maybe that could be a clue. I double-clicked destination and start to walk toward it with SendDelay set on 3500 ms - as I was walking I switch to window with documentation and after switching back to main window cmud send full path in one single command - 5n2hw2hw2h2j
Reply with quote
kinthelt
Newbie


Joined: 17 Dec 2010
Posts: 4

PostPosted: Mon Dec 20, 2010 3:31 am   
 
I have the same problem. Tried switching to slow walk (and back), tried unchecking "center map after every movement" and "update map on each step". Maybe in upgrading from 2.37 to 3.33 something got missed?

edit:

Okay, this might shed some light. In the Window menu option, I see my mapper listed 5 times. If I choose one of them and close it, it is still listed. Is my mapper permanently open five times?
Reply with quote
khil
Beginner


Joined: 18 Dec 2010
Posts: 17

PostPosted: Mon Dec 20, 2010 2:38 pm   
 
Same thing in 3.33a .The problem is not lag in sending. It looks like a lag while preparing the path, sending is instant as soon as it is done. Loading 40 steps is around 2-3 seconds.
Reply with quote
kinthelt
Newbie


Joined: 17 Dec 2010
Posts: 4

PostPosted: Mon Dec 20, 2010 3:16 pm   
 
I manually hacked my .xly file to get rid of the extra lines. Only one mapper open now, and speedwalk is back to its speedy self.
Reply with quote
khil
Beginner


Joined: 18 Dec 2010
Posts: 17

PostPosted: Tue Dec 21, 2010 5:11 pm   
 
Ok, OP, I have temporary solution. Set the senddelay (#call %pref(senddelay, x)) to anything over 0. Will send the commands immediatelly.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net