Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
Anaristos
Sorcerer


Joined: 17 Jul 2007
Posts: 821
Location: California

PostPosted: Mon Oct 04, 2010 6:48 am   

[328B-330B] CMUD fails to create/save/look for session package in session folder
 
Starting with version 3.28, CMUD has been creating, loading, and saving the session package from the game (top) folder rather than from the session folder. In fact, other files one would normally expect to be in the session folder are now also found in the top folder. such as map files which are created by default, as well as their associated .zfg files. The only files one finds in the session folder at the moment are the .tbz and the .xly file. If one moves any of the session files back to the session folder, they "disappear" from view.
_________________
Sic itur ad astra.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Oct 04, 2010 4:26 pm   
 
Select the Edit Session action and go to your Files/Packages tab and look at the path for your primary package file. That is the directory CMUD will use for your session. There have been no changes to this in a long time and it's working fine in all of my sessions here, so somehow that directory must have gotten changed for your session somehow.
Reply with quote
Anaristos
Sorcerer


Joined: 17 Jul 2007
Posts: 821
Location: California

PostPosted: Mon Oct 04, 2010 10:56 pm   
 
You are correct, the path shown is to the top folder. Is there a way to "correct" this other than re-creating the package? There doesn't seem to be a way to move the file(s).
_________________
Sic itur ad astra.
Reply with quote
Rahab
Wizard


Joined: 22 Mar 2007
Posts: 2307

PostPosted: Tue Oct 05, 2010 12:56 pm   
 
Change it in the File/Packages tab, then manually move the files.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Oct 05, 2010 3:54 pm   
 
Or Move the files first, then in the File/Packages tab use the Browse button to locate the package file and load it. That will reset the path.
Reply with quote
Anaristos
Sorcerer


Joined: 17 Jul 2007
Posts: 821
Location: California

PostPosted: Wed Oct 06, 2010 11:56 pm   
 
Oddly enough, as soon as I moved the files to the session folder, CMUD recognized their location. I didn't have to do anything else. So I am assuming that it looks there first and if it doesn't find them it goes to the Packages folder and then the top folder. I have no explanation as to how the client lost its way. I will let you know if it happens again next release.
_________________
Sic itur ad astra.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net