Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
kentaroh
Newbie


Joined: 18 Sep 2010
Posts: 5

PostPosted: Tue Sep 28, 2010 9:14 am   

[3.29b] Database not open in load Session (Bug?)
 
hello, i have a Test Database with one View with 2 columns.
Database: Players
View: Players
Columns: Name
Race
I close database window and execute this sentence and it's ok.
#say %query("&Name=XXXXX","Players|Players")
its says me correct record.

I close application and reopen the session and this sentence don't say nothing.
i tried put #DBLOAD Players and don't work.
But if i open database windows and try again it works.

if i close application having database window open, when reopen, database is open and works ok.
but if i close app without having database window open (press Exit in database Window and then exit application), when reopen, database is not open and i can't access it until i open database window.

is that OK or is that a bug?

thank you very much
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Sep 28, 2010 4:57 pm   
 
This is how the database module works. The database window must be open for any database command (including #DBLOAD) to work.
Reply with quote
kentaroh
Newbie


Joined: 18 Sep 2010
Posts: 5

PostPosted: Tue Sep 28, 2010 5:21 pm   
 
ok, perfect then.

thank you very much :)
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net