Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
ReedN
Wizard


Joined: 04 Jan 2006
Posts: 1279
Location: Portland, Oregon

PostPosted: Sat Sep 25, 2010 5:35 pm   

[3.29b] Focus not given back to Package Editor for mouse scroll
 
I've found that after the map window has focus, if I switch back to my Package Editor window and try to use the mouse wheel to scroll a script up/down that the map window is still receiving the mouse wheel scroll events. So instead of scrolling my script up/down it changes the zoom level of the map as the map is getting the mouse events.

To reproduce:

1) Have your map docked.
2) Open your package editor. Have a script displayed that sufficiently long that it can use scrolling.
3) Click in the map and use the mouse wheel to change the zoom level of your map.
4) Click back in the script in the package editor. Use the mouse wheel to scroll.
5) Observe that the map is zooming instead of the script scrolling.
Reply with quote
Fizgar
Magician


Joined: 07 Feb 2002
Posts: 333
Location: Central Virginia

PostPosted: Sat Sep 25, 2010 5:54 pm   
 
I reported this back in 3.25 but never got any replies. At least now I know it wasn't just one of the fluke errors I get some times.
http://forums.zuggsoft.com/forums/viewtopic.php?t=35758

Edit:
Between the your procedure and mine it seems the bug should be reproducible with the mapper docked or not. Also in my case the size of the script doesn't matter. Simply clicking back on the package editor anywhere and scrolling the mouse wheel will cause the map to zoom.
_________________
Windows Vista Home Premium SP2 32-bit
AMD Athlon Dual Core 4400+ 2.31 GHz
3 GB RAM
CMUD 3.34
Reply with quote
Moo
Apprentice


Joined: 10 Apr 2009
Posts: 145

PostPosted: Sun Sep 26, 2010 1:30 am   
 
It happens with the help window too.. Trying to scroll the help window (which does have focus) actually makes the map zoom. It's been like that for a long time.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Sep 27, 2010 7:00 pm   
 
Confirmed. This is still on the old bug list, but I'll see if it's easy to fix or not.
Reply with quote
ReedN
Wizard


Joined: 04 Jan 2006
Posts: 1279
Location: Portland, Oregon

PostPosted: Sat Oct 02, 2010 6:56 am   
 
Confirmed fixed in 3.30.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net