Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
gnom
Newbie


Joined: 19 Sep 2010
Posts: 5
Location: Warsaw, Poland

PostPosted: Thu Sep 23, 2010 8:39 am   

[3.xx] Strange problem
 
I get something like that.
Code:
> uklon sie pokracznie
.laniasz sie pokracznie


It should look like that:
Code:
> uklon sie pokracznie
Klaniasz sie pokracznie.


Triggers ON/OFF same problem.
Reply with quote
gnom
Newbie


Joined: 19 Sep 2010
Posts: 5
Location: Warsaw, Poland

PostPosted: Fri Sep 24, 2010 6:02 pm   
 
Other examples:

Code:
 glowa. kreci z niedowierzaniem

insted of
Code:
Ghaid kreci z niedowierzaniem glowa.


------------

Code:
. Ghaid kiwa glowa powitalnie

insted of
Code:
Ghaid kiwa glowa powitalnie.



This is mud or cmud problem? In zmud/telnet/putty works good.
Reply with quote
chamenas
Wizard


Joined: 26 Mar 2008
Posts: 1547

PostPosted: Fri Sep 24, 2010 6:05 pm   
 
Would need to know what triggers you might be using, etc...

Try getting that output while going to "Options -> Scripting -> General Scripting" and check off "Show Trigger Debug Messages", then just turn it back off when you have those instances with their accompanying triggers shown as well.
_________________
Listen to my Guitar - If you like it, listen to more
Reply with quote
gnom
Newbie


Joined: 19 Sep 2010
Posts: 5
Location: Warsaw, Poland

PostPosted: Fri Sep 24, 2010 6:11 pm   
 
I made 'clear' session (default settings, 0 triggers etc), same problem.
Reply with quote
chamenas
Wizard


Joined: 26 Mar 2008
Posts: 1547

PostPosted: Fri Sep 24, 2010 6:23 pm   
 
Without being able to reproduce the error, Zugg will likely be unable to fix it.
_________________
Listen to my Guitar - If you like it, listen to more
Reply with quote
MattLofton
GURU


Joined: 23 Dec 2000
Posts: 4834
Location: USA

PostPosted: Fri Sep 24, 2010 6:32 pm   
 
Sounds like a Unicode problem. CMud doesn't work with Unicode, which can cause problems with oriental, russian, and similar games.
_________________
EDIT: I didn't like my old signature
Reply with quote
gnom
Newbie


Joined: 19 Sep 2010
Posts: 5
Location: Warsaw, Poland

PostPosted: Fri Sep 24, 2010 6:38 pm   
 
I haven't got this problem before (befor i instaled cmud) with zmud (putty,gmud) but now i have.
Others player of this mud don't have this problem.
Anyone know what this is? No system changes, only zmud->cmud.
Reply with quote
Rahab
Wizard


Joined: 22 Mar 2007
Posts: 2307

PostPosted: Mon Sep 27, 2010 1:01 am   
 
Zmud is not the same as Cmud. It is not the same code. Zmud didn't have Unicode support either, but some Unicode still worked. Some Unicode stuff happens to work in Cmud, too, even though it is not supported, but some stuff that worked in Zmud does not work in Cmud. Since it is not supported (in neither Zmud nor Cmud), you can't be sure any Unicode will work. And if it works now, that is not a guarantee that it will work in the next version.

Zugg does intend to get Unicode support eventually, but for now, it is unsupported.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net