Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
XonDK
Apprentice


Joined: 01 Dec 2006
Posts: 178

PostPosted: Mon Feb 08, 2010 10:32 am   

[3.14] Style bug: URLs underline not saved. (updated) zugg?
 
It seems that 3.14 doesn't save it when you turn off underlining in URLs style.


Last edited by XonDK on Sun Feb 14, 2010 9:55 pm; edited 1 time in total
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Feb 08, 2010 5:50 pm   
 
I don't know what you mean by "doesn't save it".

1) Run CMUD, close Session window
2) type:
#LOAD "Clickable URLs"
3) type:
#SHOW testing http://www.zuggsoft.com

the URL should be underlined.

4) Click Prefs, go to Styles page
5) In the URL style, uncheck the Underline option.
6) Click OK to save preferences

notice the underline is now removed from the URL

So it seems to work here.
Reply with quote
XonDK
Apprentice


Joined: 01 Dec 2006
Posts: 178

PostPosted: Tue Feb 09, 2010 7:01 am   
 
Following your information, it still doesn't save.

when I restart cmud, and open the session again now with it loading clickable URLs, the underline under urls is back, and is checked in the style options.

here's what I do

#1: Chose a session and start it.
#2: once loaded I go into the style options and uncheck underline.
#3: press apply and ok

#4 shut down the session
#5 restart cmud
#6 open session again
#7 go into options and look at styles url: there underline is checked.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Feb 09, 2010 5:57 pm   
 
Somehow your session package isn't getting saved then. I just tried it in several of my sessions and it saved just fine. Make sure you are clicking the main session window and editing the preferences for the correct window (the title of the Prefs window will tell you what window you are changing the preferences for). Then check the *.PKG file for your session to see if it is being saved (the Modified date should get updated).

Can anybody else please try to reproduce this?
Reply with quote
hadar
Apprentice


Joined: 30 Aug 2009
Posts: 198
Location: my apt, in california

PostPosted: Wed Feb 10, 2010 1:48 am   
 
i cant, maybe on install he changed the directory or did not give admin privileges, or something, i updated same way as him and closed my cmud within seconds and within a time limit, i am on win 7 x64 for refrence
_________________
if you build it they will come, assuming that they have not already come to build it
Aardwolf Bootcamp
My youtube channel
Reply with quote
XonDK
Apprentice


Joined: 01 Dec 2006
Posts: 178

PostPosted: Wed Feb 10, 2010 4:54 am   
 
everything else is saved if I change it, I'll fiddle around with it..
Reply with quote
wrym
Magician


Joined: 06 Jul 2007
Posts: 349
Location: The big palace, My own lil world

PostPosted: Wed Feb 10, 2010 8:49 pm   
 
hmm i'm able to re-produce this too....

it seems like the hotspots will not save checked

use default text and underline will not save un checked for urls

command line won't save checked hot spots, or use default text

status seems to save everything, text editor didn't want to save checked use default, or hot spots

looks like there might be some sort of loading a default value for hot spots use default and maybe the underline
_________________
"To the engineer, all matter in the universe can be placed into one of two categories: (1) things that need to be fixed, and (2) things that will need to be fixed after you've had a few minutes to play with them" - Scott Adams, The Dilbert Principle
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Wed Feb 10, 2010 9:58 pm   
 
Some of the styles (command line, status) are actually saved in the STYLES.INI file within your Data Files directory, rather than being specific to a session, so also make sure your STYLES.INI file is being updated. You might try deleting it, since CMUD will recreate it as necessary to save some of the global styles (anything in the General style category).

Command line is a bit special because it uses a different component than the other styles. There are really three different kinds of styles in CMUD. a) TRichView component (command line, editor), b) TTerm (MUD Output window), and c) TScintilla (Syntax editor in settings editor). Each of these different input components has a different style system. CMUD tries to tie them all together with it's own style format. The HotSpot style is a feature of the Scintilla editor (I don't even remember what HotSpot is supposed to do). But the command line and text editor doesn't use it, so changes to it are ignored.

The Use Default font option will get unchecked if any of the saved settings differ from the default font.

In general, what I'm saying is that the styles are complicated, and just because there are some weirdness with HotSpots or other styles doesn't really reflect the issue of the original poster. I still cannot reproduce the URL Underline setting not getting saved for sessions. Keep in mind that the URL Style is in the "Session" style category, which means it is saved in the *.PKG package file for a session. So it's not going to save the value if you are just closing the session window and using a blank session. You actually need to load an existing session package, then go change the URL style, then exit CMUD and reload it to see if it saves or not. If it isn't saving, then it has to be some problem with the package file, or setting it for the wrong window or something like that.
Reply with quote
wrym
Magician


Joined: 06 Jul 2007
Posts: 349
Location: The big palace, My own lil world

PostPosted: Wed Feb 10, 2010 11:11 pm   
 
hmm well styles.ini is getting saved,


My point in mentioning the other values not... maintaining a consistent behavior.

Perhaps when the use default box is checked it should update the other text boxes, and gray out, or invis completely the hotspots where it's not used? changing options doesn't appear to unset the default option and setting the use default doesn't seem to set the other values?

and yes, I was using a blank session (ok MOSTLY), that I use for testing funny bugs like this
_________________
"To the engineer, all matter in the universe can be placed into one of two categories: (1) things that need to be fixed, and (2) things that will need to be fixed after you've had a few minutes to play with them" - Scott Adams, The Dilbert Principle
Reply with quote
XonDK
Apprentice


Joined: 01 Dec 2006
Posts: 178

PostPosted: Sun Feb 14, 2010 4:34 pm   
 
Something is weird, uninstalled 3.14, and reinstalled 3.12 as I have used before, there underline is saved with no problem, but in 3.14 it isn't?
Reply with quote
XonDK
Apprentice


Joined: 01 Dec 2006
Posts: 178

PostPosted: Sun Feb 14, 2010 9:56 pm   
 
I've been fiddling around with it a bit, can it be because my settings still seem to associate with the original .mud file, in both name <name>.mud.pkg?
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Feb 15, 2010 5:55 pm   
 
That's just the filename of the package and CMUD doesn't care what the actual file name is as long as it ends in ".pkg". It's not actually still "associated" with your original mud file.

It still sounds like some problem with your session file. Have you tried doing a full XML Export of your session scripts and then importing them into a new PKG file?
Reply with quote
XonDK
Apprentice


Joined: 01 Dec 2006
Posts: 178

PostPosted: Tue Feb 16, 2010 1:57 pm   
 
I will try a full export and import and see where that leaves me


EDIT:

I did a full uninstall of CMUD, deleting the folder it was installed into and the folder in documents, and reinstalled 3.14a and even with a totally new session for aetolia, removing the underline doesn't stick after saving and restarting cmud.
EDIT2: this is a fully new session without anything in it and it still doesn't save it..

Can it be because its vista 64?
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Feb 16, 2010 5:00 pm   
 
I doubt it's a problem with Vista 64 because it works just fine on Vista 32 and Windows 7x64, but maybe somebody else with Vista 64 can test it (I don't have any Vista 64 system).

EDIT:

OK, I just created a new, blank session in a fresh install, and now I *can* reproduce this problem. I don't know why it works in my existing sessions, but not in a new session. But maybe now I can figure out why this is happening.
Reply with quote
XonDK
Apprentice


Joined: 01 Dec 2006
Posts: 178

PostPosted: Wed Feb 17, 2010 4:20 pm   
 
Zugg wrote:
I doubt it's a problem with Vista 64 because it works just fine on Vista 32 and Windows 7x64, but maybe somebody else with Vista 64 can test it (I don't have any Vista 64 system).

EDIT:

OK, I just created a new, blank session in a fresh install, and now I *can* reproduce this problem. I don't know why it works in my existing sessions, but not in a new session. But maybe now I can figure out why this is happening.


ah, at least it can be reproduced now, that's one step closer to the problem being solved.
Reply with quote
dbosst
Apprentice


Joined: 15 Jun 2010
Posts: 121

PostPosted: Mon Oct 11, 2010 9:22 pm   3.30 again
 
for some reason in a past version this was no longer a problem but it reappears in 3.30..

after accidentally resetting the underline option when I try to unset it again.. it ignores the setting saved everytime I restart cmud (this means I have to change the option for all 7 windows I have since they all use links!) (I checked the sql db file and the option is being saved since there is no underline value in any of the config table but the program is just ignoring it)

EDIT:
I've finally gotten around this bug and the other one using a hack where I edited the font I normally use to create my own font with no underline

The font name is "Lucida Console Plain2"
http://www.mediafire.com/?c633yabkyej25ai
get it there and copy it to your windows\fonts folder if you care to use it
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net