Register to post in forums, or Log in to your existing account
 

This forum is locked: you cannot post, reply to, or edit topics.  This topic is locked: you cannot edit posts or make replies.     Home » Forums » TeSSH Discussion
IainMac
Wanderer


Joined: 28 Jan 2006
Posts: 60
Location: Scotland

PostPosted: Mon Feb 01, 2010 8:50 am   

[3.13] Term types wrong
 
Looks like in the latest version the TERM types have all be capitalised i.e. we now have XTERM rather than xterm etc and thus display breaks.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Feb 01, 2010 5:16 pm   
 
That is correct. According to the Telnet Option RFC spec, the values of telnet options are not case sensitive. Here is a quote from RFC 1091 on the TermType telnet option:
Quote:
Within this string, upper and lower case are considered equivalent.

So servers should recognize a terminal regardless of having it capitalized or not. TeSSH 3.13 switched to the capitalized versions because that is how they are listed in the Assigned Numbers RFC (RFC 1010)

But remember that you can always type over the existing value. The drop-down box just gives the default suggestions. But the text field is editable, so just enter "xterm" in lower case if needed.
Reply with quote
IainMac
Wanderer


Joined: 28 Jan 2006
Posts: 60
Location: Scotland

PostPosted: Mon Feb 01, 2010 9:09 pm   
 
Zugg wrote:
But remember that you can always type over the existing value. The drop-down box just gives the default suggestions. But the text field is editable, so just enter "xterm" in lower case if needed.


I tried this but encountered a problem... Opened the General Preferences GUI, went into Session -> Emulation, typed "xterm" in the Terminal Type drop down combo box, clicked the Apply button and the text changed back to "XTERM".

Typing anything else, that is not already in the default list, is accepted ok.
Reply with quote
IainMac
Wanderer


Joined: 28 Jan 2006
Posts: 60
Location: Scotland

PostPosted: Mon Feb 01, 2010 9:19 pm   
 
Zugg wrote:
So servers should recognize a terminal regardless of having it capitalized or not. TeSSH 3.13 switched to the capitalized versions because that is how they are listed in the Assigned Numbers RFC (RFC 1010)


Currently connecting to HP-UX 11, SLES 9/10 and Solaris 10 servers and they all do not like XTERM as a display type. So the RFC may say it can be either way but my 3 main OS's do not like it.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Feb 02, 2010 12:08 am   
 
Thanks for reporting this. Apparently the combo-box control that I am using is trying to be helpful and is auto-filling/correcting your input based upon the existing entry in the list.

Sad that nobody seems to pay attention to the actual standards these days. Since this change seemed to have broken more than it fixed, I'll change it back to lower case and will also add both upper and lower case values to the drop-down list so the auto-correction won't change what you type.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Thu Feb 04, 2010 12:42 am   
 
The way I have fixed this in the next version is to add a new option beneath the Terminal Type dropdown preference called "Send lowercase terminal type". This option is ENABLED by default. I just didn't like the idea of duplicating each terminal type with both a lowercase and uppercase value. When you check this option, it will automatically change the case of the values in the Terminal Type drop-down box.
Reply with quote
IainMac
Wanderer


Joined: 28 Jan 2006
Posts: 60
Location: Scotland

PostPosted: Mon Feb 08, 2010 10:27 am   
 
Zugg wrote:
The way I have fixed this in the next version is to add a new option beneath the Terminal Type dropdown preference called "Send lowercase terminal type". This option is ENABLED by default.


Installed 3.14 and found that on a clean install, with no session imported, it still thinks the TERM is set to XTERM even though the General Settings GUI tells me that it should be "xterm". I had to press the "Set as defaults" button before it set itself properly to what was set in the Settings GUI.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Feb 08, 2010 5:40 pm   
 
Just clicking the "Use lowercase for terminal type" option off and on again should have also fixed it. TeSSH doesn't change the value that was stored in your previous session.
Reply with quote
IainMac
Wanderer


Joined: 28 Jan 2006
Posts: 60
Location: Scotland

PostPosted: Tue Feb 09, 2010 11:11 am   
 
Zugg wrote:
TeSSH doesn't change the value that was stored in your previous session.


Thats the thing... I did not have a previous session and it thought the term type was XTERM (on clean install) even though the GUI said it was lowercase xterm.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Feb 09, 2010 5:48 pm   
 
Yep, I see it in the code now. TeSSH is initializing the default terminal type to "XTERM". I'll fix that in the next version.
Reply with quote
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.     Home » Forums » TeSSH Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
© 2009 Zugg Software. Hosted on Wolfpaw.net