Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
Loftaris
Adept


Joined: 24 Aug 2004
Posts: 270

PostPosted: Fri Jan 29, 2010 2:11 pm   

Keyboard problems
 
Has anyone else had this problem, and do you know how to fix it without restarting the computer...

It happens on Windows XP, Vista, and 7, so it`s not an OS problem.
I`ve only really noticed it with CMud Beta (any version, atm I`m using the current version)

It didn`t happen until I loaded CMud.

My computer has been on for at least a week without a restart (will happen after a fresh restart too.) Everything was fine, and since I haven`t been playing my mud lately, didn`t launch CMud until just now.

What happens, is a couple of my keys will change their character map. Most notably the question mark is now É .. and the apostraphe (as you can see above) is now ` instead of facing left, it`s facing right.

This only happens when I launch CMud, and it affects every program I use, so it`s directly mapping the windows key registry...

Thanks.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4254
Location: Pensacola, FL, USA

PostPosted: Fri Jan 29, 2010 2:14 pm   
 
Are you using a basic QWERTY style keyboard? I have never heard of such an issue.
_________________
Discord: Shalimar#3679
Reply with quote
Loftaris
Adept


Joined: 24 Aug 2004
Posts: 270

PostPosted: Fri Jan 29, 2010 2:15 pm   
 
wow that was lightning quick. it`s just your regular ol laptop keyboard, nothing special. happened on 2 different laptops too...
Reply with quote
Loftaris
Adept


Joined: 24 Aug 2004
Posts: 270

PostPosted: Fri Jan 29, 2010 2:21 pm   
 
I did transfer my scripts, triggers, settings etc from one laptop to another, so its possible I have a broken alias or trigger or something in there... But I have no idea what to look for. Ive never changed any keys other than the function keys...

ok hey I just realized something... it switched my keys to the alternate keys on my keyboard.. (like how if you hit (FN) and F7 on a laptop itll turn the screen brighter, well it made it so its using the blue colored part of those keys..

interesting...
Reply with quote
Loftaris
Adept


Joined: 24 Aug 2004
Posts: 270

PostPosted: Fri Jan 29, 2010 2:35 pm   
 
Hey, I found the problem....

Here are some things I've figured out, in case it helps anyone track down this problem in the future.

A search online made me realize it may be limited to HP laptops, because both my laptops are HP.

It also appears to be limited to the Canadian laptops, or at least these blue keys are french characters.

To turn it on/off, you have to hold left CTRL+SHIFT and RIGHT SHIFT all at the same time (L-CTRL+SHIFT+SHIFT).

There is no such macro or trigger or alias that I've ever used that I've had to do that before, so it wasn't by accident. And, it happened when I launched CMud, but I didn't even play. I logged in to see who was on, and logged off..

Thanks Shalimar, you inadvertently helped me realize the problem!
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4254
Location: Pensacola, FL, USA

PostPosted: Fri Jan 29, 2010 3:16 pm   
 
Well... glad its resolved.
_________________
Discord: Shalimar#3679
Reply with quote
Fizban1216
Apprentice


Joined: 03 Feb 2007
Posts: 170

PostPosted: Fri Jan 29, 2010 4:01 pm   
 
Hmm, never had this problem, but I have always found it annoying that when cmud launches it by default turns on numlock. Especially since my laptop doesn't have a numpad so with it on:

The string of text in question.

will be written as:

The str5ng 6f text 5n q4est56n.
Reply with quote
charneus
Wizard


Joined: 19 Jun 2005
Posts: 1876
Location: California

PostPosted: Fri Jan 29, 2010 4:26 pm   
 
Fizban1216 wrote:
Hmm, never had this problem, but I have always found it annoying that when cmud launches it by default turns on numlock. Especially since my laptop doesn't have a numpad so with it on:

The string of text in question.

will be written as:

The str5ng 6f text 5n q4est56n.


That's why there's an option to turn it off. ;) Just open up preferences and it'll be under User Interface/Command line. The second box down is 'Activate Numlock'. By unticking that, you will never have CMUD turn it on again while on your laptop. :)

Charneus
Reply with quote
nexela
Wizard


Joined: 15 Jan 2002
Posts: 1644
Location: USA

PostPosted: Fri Jan 29, 2010 9:07 pm   
 
Loftaris if you do not need to switch between keyboard layouts you can turn off the hot keys sequence for this in [Control Panel -> Region and Language settings -> Keyboards and Languages -> Change Keyboards -> Advanced Key settings] or on the general tab just remove any layouts you don't need
_________________
Zmud Support Library
Zmud Knowledge Base
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net