Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » zMUD General Discussion

Joined: 25 Feb 2009
Posts: 3

PostPosted: Wed Feb 25, 2009 8:21 am   

ZMud 7.21 map Room Properties box does not open when selected
Subject says most of it. This is a problem that I believe started sometime around the time that I installed Windows XP SP3 on the systems.

I run ZMud on my desktop and my travel laptop. Both are WinXP with SP3. Both have been wiped and re-installed to attempt to resolve two ZMud problems: 1) the room properties 'pop-up' window does not open when selected in any mode in the mapper (mapper off, follow position, or edit position) and 2) an issue of the map not keeping up with my movement when spamming around to avoid attacks. This I know I can recenter with the #find command, but it is repeatedly occurring at very bad times and is most annoying. Crying or Very sad

Additional background: every other menu item that should open a pop-up window, in the entire program, works as it should; just the room properties fails to open. This is preventing me from changing room colors on newly mapped rooms to match my current schema. I have looked for any switch or configuration change that might be causing it. I have verified that the map is unlocked. The same problem occurs whether I am using a map someone else has given me, or I create a fresh new map of a zone; I just can not access the room properties.

I am at a loss and would appreciate any assistance and suggestions you folks may offer.

Thanks in advance for your time.
Reply with quote

Joined: 23 Dec 2000
Posts: 4834
Location: USA

PostPosted: Wed Feb 25, 2009 10:18 pm   
1)Have you tried to reset the mapper windows? On the main window menubar go to Layout, scroll down to the Reset Windows submenu, and when that pops up, choose Mapper. Your window problem sounds like it got moved entirely offscreen or somehow put behind the main game window, and if that's the case this method will absolutely fix it.

I've never had any issues with any mapper windows however, so this is all based on the assumption that this option actually works instead of being plagued by an unknown bug.

2)sounds like lag issues, a bad configuration, or simply that there's some line you need to #NOMAP or #NODIR but haven't yet. When you spam, ZMud's not always going to perform as solidly, so have you tried controlling your spam?
EDIT: I didn't like my old signature
Reply with quote

Joined: 25 Feb 2009
Posts: 3

PostPosted: Thu Feb 26, 2009 12:52 am   
Thanks for the quick response Matt.

I just tried your suggestion in #1 and then attempted to open the properties for the room I am in, on line in mapping mode. No Luck. The Task Bar icon flickers momentarily, then all returns to normal and I am still not able to work with that rooms properties. Sad So, barring a fix for this, is there a way to set the room color for the current room in the map from the input/command line?

Regarding #2 - I have discovered that if I disable my FreeAVG the problem virtually clears itself up. As you can imagine, I am uncomfortable sitting out in the WWW without active antivirus protection. Spamming, or rather 'controlling' my spamming is not always an option as that is how one avoids RIPing in player kill. (Big bad OPFOR player gets off a surprise attack or comes upon you with overwhelming resources, you must run far and fast to live to talk about it later on with your buddies.) Ok so what does Antivirus software have to do with ZMud implementation? No clue? Me neither! Laughing

Like I mentioned in the original post, these problems seemed to occur simultaneously after the installation of Service pack 3 (or was it the updated AVG). Man I hate CRS syndrome.... Mr. Green

Any other assistance you or others can offer/suggest will be welcome. I am going to install VirtualBox on my Mandriva Linux laptop and see if I can get ZMud to run there, and if so, if the problem is resolved. Probably be slow as heck running in a VM, but it will allow me to trouble shoot this problem a bit more.
Reply with quote

Joined: 25 Feb 2009
Posts: 3

PostPosted: Fri Feb 27, 2009 8:24 pm   
Ok VirtualBox on my Mandriva Linux laptop was a bust. The old beast is just not powerful enough to support a VM running an XP install on top of the main OS. It works fine for creating sandboxes within Mandriva for trying new software before I permanently install, but can not support the overhead of a full Windowz install on top of it's base OS.

I am going to load a new hard drive into my laptop and do another clean install of WinXP Pro SP2, immediately install Zmud and verify functionality. If all is well, I will then start stepping though the patches and service packs until I find the critter that is crippling my fun. I will try to post something back here once I have isolated the problem in case anyone else experiences the same symptoms I have.
Reply with quote

Joined: 08 Dec 2005
Posts: 35
Location: Sweden

PostPosted: Fri Apr 12, 2024 12:42 am   
I had this same problem today, and it took me a while to solve.

In my case zmud.ini was botched, so replacing it with a backup solved the problem.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMUD General Discussion All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by