Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
frasten
Beginner


Joined: 06 Jan 2006
Posts: 24

PostPosted: Sat Dec 13, 2008 1:45 pm   

[3.03] No "down" exit anymore [SOLVED]
 
From v3.03, all my "down" links in the mapper aren't working anymore.
If I go "down", the mapper doesn't follow me, I see the exit in the mapper, but it seems that cMud doesn't recognize it anymore.

As you can see:
Code:
#echo %roomexit

returns, for example:
Code:
s|n|e|w|

"d" is missing.

I tried to delete the new .dbm file and regenerating it, but it doesn't work.


Last edited by frasten on Tue Dec 16, 2008 7:35 pm; edited 2 times in total
Reply with quote
Seb
Wizard


Joined: 14 Aug 2004
Posts: 1244

PostPosted: Sat Dec 13, 2008 4:00 pm   
 
Check you still have all the directions configured. Maybe the down direction has been deleted...
Reply with quote
Tech
GURU


Joined: 18 Oct 2000
Posts: 2733
Location: Atlanta, USA

PostPosted: Sat Dec 13, 2008 4:01 pm   
 
I haven't a chance to play with it yet, but did you check the English Keypad and English Directions package?
_________________
Asati di tempari!
Reply with quote
frasten
Beginner


Joined: 06 Jan 2006
Posts: 24

PostPosted: Sat Dec 13, 2008 6:26 pm   
 
Thank you for your suggestions. My "d" in "english directions" got disabled during the upgrade (!?). Enabling it fixed the issue.
Thank you very much! :-)
Reply with quote
frasten
Beginner


Joined: 06 Jan 2006
Posts: 24

PostPosted: Sat Dec 13, 2008 6:44 pm   
 
An update: it was only my fault: one script was disabling a class named "d", but obviously it disabled the direction "down".
Sorry for spamming! Embarassed
Reply with quote
intoK
Apprentice


Joined: 18 Feb 2007
Posts: 190

PostPosted: Sun Dec 14, 2008 12:41 pm   
 
thats interesting, related problem : 3.03 upgrade completely messed up my directions... creating new direction fixed old ones tho, oddness
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23379
Location: Colorado, USA

PostPosted: Mon Dec 15, 2008 5:42 pm   
 
Not sure what happened with this. Nothing I changed in 3.03 should have effected your directions and none of the directions on my MUD sessions here got messed up at all. So I have no idea.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23379
Location: Colorado, USA

PostPosted: Tue Dec 16, 2008 7:18 pm   
 
Btw, just a quick comment to frasten: Please don't put "B" at the end of the version just because it's a beta. It gets confused with "quick fix" releases, such as the 3.03a version. Thanks.
Reply with quote
frasten
Beginner


Joined: 06 Jan 2006
Posts: 24

PostPosted: Tue Dec 16, 2008 7:35 pm   
 
Ok, post edited :-)
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net