Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
kevlar
Beginner


Joined: 27 May 2005
Posts: 18

PostPosted: Fri Oct 31, 2008 1:37 am   

separator character not working
 
very sorry if this is something that has already been brought up, i did a quick search and didn't find anything.

i upgraded from zmud to cmud a while back and haven't been able to get the Separator Character to work. i haven't changed anything from the default, so it's still ;
it is checked enabled. i tried switching it to something else and it still didn't work.

my CMUD is version 2.36
i'm using Vista Ultimate with Service Pack 1 (if that matters)


thanks in advance,
kevlar
Reply with quote
Seb
Wizard


Joined: 14 Aug 2004
Posts: 1244

PostPosted: Fri Oct 31, 2008 2:59 am   
 
You'll need to give the example(s) that don't work, because I'm not aware of any issues with it.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23379
Location: Colorado, USA

PostPosted: Fri Oct 31, 2008 3:22 am   
 
Yeah, you always need to remember to give specific examples. Something as basic as that isn't likely to be broken after 2+ years of CMUD development and testing.

Make sure you have the Parse option turned on in the settings menu...otherwise CMUD isn't going to parse anything in the command line.
Reply with quote
kevlar
Beginner


Joined: 27 May 2005
Posts: 18

PostPosted: Fri Oct 31, 2008 4:08 am   
 
i use it to string commands in the command line.

like

open door ; go through door

try to use separator character ; cry because i can't get it to work


that kind of thing.

i clicked on settings but did not see parse option. so i'm not sure what it's set to. am i looking in the right place?
Reply with quote
charneus
Wizard


Joined: 19 Jun 2005
Posts: 1876
Location: California

PostPosted: Fri Oct 31, 2008 2:32 pm   
 
The reason why is because you're putting spaces between your separators. The syntax is

open door;go through door.

I believe this is intentional because of the smart command line. It allows you to do things like

say Hi! I really like your equipment. ;) Want to be friends?

without having to parse the separator character so you can get the winking smilie in.

Charneus
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net