Register to post in forums, or Log in to your existing account
 

This forum is locked: you cannot post, reply to, or edit topics.  This topic is locked: you cannot edit posts or make replies.     Home » Forums » TeSSH Discussion
Seb
Wizard


Joined: 14 Aug 2004
Posts: 1241

PostPosted: Thu Jul 24, 2008 2:12 pm   

[2.33] Ability to turn off local echo when not in character mode?
 
If you are not in character mode, there seems to be no way of turning off local echo, meaning everything is printed twice. So pressing Enter on a blank line results in:
Quote:
[root@x ~]#

[root@x ~]#

Note the blank line. Feels weird.

[Edit: this also applies if you give focus to the command line (which I discovered is a way of sending stuff not in character mode when that is enabled: quite neat).]
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Thu Jul 24, 2008 4:51 pm   
 
Hmm, you are correct. That's probably a bug that needs to be fixed in CMUD as well.
Reply with quote
Seb
Wizard


Joined: 14 Aug 2004
Posts: 1241

PostPosted: Thu Jul 24, 2008 7:53 pm   
 
BTW, PuTTY has options for Local echo: Auto; Force on; Force off. I always use Auto and it's always worked fine. I think it asks the server if it is going to do Local echo. But of course this only works if the server is a telnet or SSH server or similar. I also use PuTTY for connecting to simple sockets like SMTP servers, in which case I need to set the connection type to Raw sometimes (instead of telnet) or the first thing I enter gets garbled due to the telnet stuff PuTTY has already sent. Although actually this may be fixed in the newer version of PuTTY I use these days - I can't replicate this problem with telnet mode on raw servers now.

EDIT: I had been thinking of requesting a Raw mode, but I haven't yet found a need for it.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Jul 28, 2008 7:45 pm   
 
Actually, there *is* an option for this. It's in the Scripting Preferences and is called "Echo commands". Turn this off and your command line sent to the MUD will not be echoed on the screen locally. Sorry it's in kind of an obscure location in the preferences.
Reply with quote
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.     Home » Forums » TeSSH Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
© 2009 Zugg Software. Hosted on Wolfpaw.net