Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
alluran
Adept


Joined: 14 Sep 2005
Posts: 223
Location: Sydney, Australia

PostPosted: Wed Jun 11, 2008 12:26 am   

Status of LUA dlls
 
I asked a while back if there would be any way of including the lua dll + forwarding dlls in the default cmud, has this been set up yet (haven't got time to check right now :P) or will I still need to manually replace these DLLs if i want to import LUA mysql functionality?

I'd imagine a bunch of other LUA extensions would require these forwarding DLLs too.

Or perhaps you could make them a seperate install / plugin available for download here.

Once again, I've got a zip with the DLLs that you just need to extract to the cmud directory if you need/want them. I know it's around here somewhere...
_________________
The Drake Forestseer
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Wed Jun 11, 2008 12:38 am   
 
I thought I changed the name of the Lua DLL used in CMUD to comply with the naming standard that was needed for sql support. Is the DLL name still wrong?

I really don't want to include a bunch of forwarding DLLs with CMUD. I might be willing to put them in the download area as a separate download if that is really necessary.
Reply with quote
alluran
Adept


Joined: 14 Sep 2005
Posts: 223
Location: Sydney, Australia

PostPosted: Wed Jun 11, 2008 12:50 am   
 
I was just asking for a status update, still haven't had a chance to check this stuff, was just wondering if anything had been done to combat it. I originally used the forwarding DLLs so that cmud would still work, if they're not needed now, then they're not needed now ;D
_________________
The Drake Forestseer
Reply with quote
Dharkael
Enchanter


Joined: 05 Mar 2003
Posts: 593
Location: Canada

PostPosted: Wed Jun 11, 2008 3:13 pm   
 
Well you really wouldn't need to include a bunch of dll's if you did decide to include any, just one would do,
same if you decided to simply place them in the download area.
If library is looking for lua5.1.dll , lua51.dll , lua.dll or whatever
as long as it's trying to load a lua 5.1 interpreter then there's no reason you can't just copy and rename the forwarding dll.
I would either change CMUD's native lua.dll to lua5.1.dll or leave as is and put the forwarding dll as lua5.1.dll as IMHO that's the one that's used the most.
As that is the format that lua.org luaforge.net and luabinaries.luaforge.net uses.
_________________
-Dharkael-
"No matter how subtle the wizard, a knife between the shoulder blades will seriously cramp his style."
Reply with quote
alluran
Adept


Joined: 14 Sep 2005
Posts: 223
Location: Sydney, Australia

PostPosted: Wed Jun 11, 2008 3:31 pm   
 
Ok, my patch has the following file sizes (and i'm gonna assume the big one is the original, especially seems the lua.old file has the same size)

lua.dll (4kb)
lua.old (59kb)
lua5.1.dll (59kb)
lua51.dll (4kb)

(And the following 2, in various directories)
libmysql.dll (739kb)
mysql.dll(40kb)

All I do is extract that into the cmud directory and things work, yet when I checked, you're still using "lua.dll", not the "lua5.1.dll" that luasql requires
_________________
The Drake Forestseer
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Wed Jun 11, 2008 6:10 pm   
 
OK, in v2.27 I will change LUA.DLL to LUA5.1.DLL and also modify CMUD so that it will try to load this DLL first, and if it doesn't exist, then CMUD will still look for the plain LUA.DLL file.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net