Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  This topic is locked: you cannot edit posts or make replies.     Home » Forums » CMUD General Discussion
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Aug 07, 2007 11:32 pm   

Correcting VISTA problem
 
OK, I have some new information that might help with these Vista problems.

I think the problem is with something in Vista called DEP (Data Execution Prevention). It appears that DEP is being enabled by default on new Vista machines, and it might be getting turned on by a new Vista patch.

To see if DEP is enabled on your Vista system:

1) Press Win+R to open the Run dialog box.
2) Type "SystemPropertiesDataExecutionPrevention" (without the quotes) and press Enter.
3) Click Continue, if prompted by User Account Control.
4) Under Performance, click Settings.
5) In the Performance Options dialog box, click the Data Execution Prevention tab. If your processor supports this feature, a sentence to that effect appears in the lower part of the dialog box.

You can turn off DEP for user applications by selecting the option "Turn on DEP for essential Windows programs and services only". Then click OK and close all of the dialog windows. Then you MUST REBOOT for this change to take effect.

After turning off DEP and rebooting, then try running CMUD to see if it works.

If CMUD works and you don't want to leave DEP turned off, you can go back into the DEP dialog and select the option: "Turn on DEP for all programs and services except those I select" and then click the Add button and add the CMUD.EXE program to the list of exceptions (and make sure there the checkbox next to CMUD.EXE gets checked). You'll again need to click OK and again need to Reboot to save the changes.

Please let me know if this helps. The new version of Armadillo seems to be full of bugs, so I am *not* going to upgrade the Armadillo in the 2.0 version of CMUD. I need to wait until they fix their bugs before I'll change the copy protection. But this DEP issue seems to be causing the same crash in other Armadillo applications, and it only happens on Vista systems with DEP enabled, which is currently the minority, but it slowly increasing.

Btw, apparently the latest update to Windows Server 2003 also enables DEP, so this same problem might be occuring on non-Vista systems with DEP enabled.


Last edited by Zugg on Wed Aug 08, 2007 4:47 pm; edited 1 time in total
Reply with quote
Vijilante
SubAdmin


Joined: 18 Nov 2001
Posts: 5182

PostPosted: Wed Aug 08, 2007 1:52 pm   
 
Zugg, it seems making topics sticky takes a bit more access then I have. So when you get a chance please sticky the topic.

Also you might want to replicate this in the zMud forum so it is posted with your name. I was thinking about using a move with shadow, but I don't know if the shadow topic can be stickied.
_________________
The only good questions are the ones we have never answered before.
Search the Forums
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Wed Aug 08, 2007 6:29 pm   
 
I've stickied this topic. I don't want to post this to the zMUD forum, because I don't want to give the false impression that zMUD is supported on Vista. While this DEP stuff helps, there are still several issues with zMUD and Vista that will not be resolved.
Reply with quote
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net