Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion

Joined: 18 Dec 2006
Posts: 47

PostPosted: Thu Dec 21, 2006 3:35 pm   

Complex Trigger Causing CMUD to Fail Loading Package
I'm working on porting over my (well, mostly Larkin's) system over to CMUD, and taking a stab at rewriting it as I go. Yesterday I created triggers, without values, for all the affliction messages. I noticed when I entered the infamous paralysis trigger, that CMUD really wasn't too happy with it, as it took a long time to process anytime I did anything with it.

Today, trying to load the package just causes CMUD to hang, with max CPU usage, indefinitely.

Duplicated on both my laptop and desktop. I rolled back to an earlier version of my package, and it loaded fine. I entered that trigger into the earlier version, closed the package editor, and tried to reopen it. It looked like it was going to hang, but after a couple minutes it did manage to get the package editor open. I then closed CMUD, restarted, and tried to reload this package that had loaded fine without the paralysis trigger, and as expected CMUD is sitting at max CPU cycles still trying to load the package... it's been about 10 minutes now.

Here's the trigger pattern as entered:
([A~*]?[ ~*]?[p~*]?[r~*]?[i~*]?[c~*]?[k~*]?[l~*]?[y~*]?[ ~*]?[s~*]?[t~*]?[i~*]?[n~*]?[g~*]?[i~*]?[n~*]?[g~*]?[ ~*]?[o~*]?[v~*]?[e~*]?[r~*]?[c~*]?[o~*]?[m~*]?[e~*]?[s~*]?[ ~*]?[y~*]?[o~*]?[u~*]?[r~*]?[ ~*]?[b~*]?[o~*]?[d~*]?[y~*]?[,~*]?[ ~*]?[f~*]?[a~*]?[d~*]?[i~*]?[n~*]?[g~*]?[ ~*]?[a~*]?[w~*]?[a~*]?[y~*]?[ ~*]?[i~*]?[n~*]?[t~*]?[o~*]?[ ~*]?[n~*]?[u~*]?[m~*]?[b~*]?[n~*]?[e~*]?[s~*]?[s~*]?[.~*]?)

So aside from the application issue, my other problem is trying to repair the package file I have now, so I don't lose all the work of copying over triggers. Anyone have any suggestions on how I can remove just that trigger without being able to open it in CMUD?
Reply with quote

Joined: 25 Mar 2003
Posts: 1113
Location: USA

PostPosted: Thu Dec 21, 2006 10:07 pm   
Things like this are the reason that I script everything in text files and import. Binary formats are easier to corrupt and harder to fix, generally speaking. The trigger you have here is from a fairly old copy of my system, as everything I have now is regex only. Maybe the regex trigger would work better, or maybe the problem is really in some other aspect of the package.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by