Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » zMUD General Discussion
Cleaner
Newbie


Joined: 09 May 2004
Posts: 5
Location: South Africa

PostPosted: Tue Dec 27, 2005 10:19 pm   

Ctrl+V causes double paste
 
Whenever I copy any text into the command line, it pastes it twice.

Like if I copy "run 2s3e;open east" to the command line, the command line would then read:
run 2s3e;open eastrun 2s3e;open east

Sometimes it does a multi-line paste so it reads:
run 2s3e;open east
run 2s3e;open east

I've even disabled Multi-line paste and it still pastes it multi-line!

I've got a big ? on my face at the moment. Please help.

This problem does not occur when clicking "Edit" and clicking "Paste".
_________________
The first step to Control is Understanding.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4348
Location: Pensacola, FL, USA

PostPosted: Tue Dec 27, 2005 10:49 pm   
 
sounds like the key is sticking to me
_________________
Discord: Shalimar#3679
Reply with quote
Vorax
Apprentice


Joined: 29 Jun 2001
Posts: 198
Location: USA

PostPosted: Wed Dec 28, 2005 5:04 am   
 
This is an issue I also have with only one of my characters. All the others seem unaffected. I have not recieved a solution to the problem or a cause of the problem. The only answer I got was that my MS rich text box control was out of date, at which I checked and it was not. The issue persists.
Reply with quote
Draconar
Beginner


Joined: 26 Dec 2005
Posts: 21

PostPosted: Thu Dec 29, 2005 6:28 pm   
 
I can also verify that this is happening to me, and no, my key is not sticking.
Reply with quote
Slaem
Apprentice


Joined: 20 Sep 2005
Posts: 135

PostPosted: Thu Dec 29, 2005 6:55 pm   
 
A couple threads out there on this. Doesn't seem to be a standard resolution though. What zMUD version is being used?

http://forums.zuggsoft.com/phpbb/viewtopic.php?t=21498&highlight=double+paste
http://forums.zuggsoft.com/phpbb/viewtopic.php?t=21816&highlight=double+paste
_________________
Show your love.
Support Zugg Software!
Donate to zugg@zuggsoft.com with PayPal Send Money.
Reply with quote
Cleaner
Newbie


Joined: 09 May 2004
Posts: 5
Location: South Africa

PostPosted: Thu Dec 29, 2005 11:50 pm   
 
Okay I've read those other threads. I have rebooted several times since going to version 7.20b, and this problem only started when going to this version. I'm using Windows XP Pro, SP2.

I'm going to install 7.21, then do Windows Update, then reinstall 7.20b, in that order, if it doesn't come right.

If this all still doesn't work, I'll just go back to 7.05, which treated me just fine. :-)

Will let you know how life treats me :p
_________________
The first step to Control is Understanding.
Reply with quote
ragbash
Newbie


Joined: 08 Mar 2008
Posts: 3

PostPosted: Tue Jul 08, 2008 12:57 pm   Solution (in my case)
 
I noticed the same double pasting problem start when I was playing around in character mode. I disabled the "Enable Menu Key Shortcuts" option to allow key combinations to be sent with Zmud in character mode. This caused an unintended side-effect of double-pasting clipboard contents.
This option can be found by following these steps:
View -> Preferences -> General

In the tree view on the left panel, expand "General" and select "Command Line"
There are a series of options in the right panel. When enabling "Enable Menu Key Shortcuts" the double-paste problem seems to solve itself.


Useful info for Zugg:
My software specifics:

OS Name Microsoft Windows XP Professional
Version 5.1.2600 Service Pack 2 Build 2600
zMUD version 7.21


Reloading zMUD, rebooting the machine, etc did not help the situation. This option is enabled by default, which would explain why some users have reported that a clean install also solves the situation.

Thanks, Zugg for the world's greatest mud client!
-Ragbash
Reply with quote
Ranger_Aja
Beginner


Joined: 22 Apr 2001
Posts: 15
Location: USA

PostPosted: Tue Jul 22, 2008 6:46 am   
 
I've been having the same problem. But my experience has a twist!

I have the exact same os on two different machines - one at work, one at home. They are both running XP pro SP2. I'm using the exact same installation of 7.21 on both as well. I had the double pasting issue on one machine only until I copied my settings to the other machine. Now they both have the double pasting issue.

I've just gotten around it with right-click+paste. But the ctrl+v was much nicer. I think I'm going back to 7.05 as well. I can live without the speed difference.
Reply with quote
Leitia
Adept


Joined: 04 May 2007
Posts: 292
Location: Boston

PostPosted: Tue Aug 05, 2008 8:25 pm   
 
I've had that too, I was able to stop mine by un-checking local echo, or something in that area, though mine was not Menu Key Shortcuts. Echo Commands perhaps? I liked whatever feature I was using and was able to re-enable it at some point

Perhaps globally un-checking all the boxes (and noting the ones you need). Then reboot and enable.

Change is good?
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net