Register to post in forums, or Log in to your existing account
 

Post new topic  Reply to topic     Home » Forums » zMapper Discussion
McGyver
Newbie


Joined: 11 Oct 2003
Posts: 4
Location: USA

PostPosted: Mon Nov 17, 2003 7:11 pm   

Room & Grid scale
 
Is it possible to configure the mapper so that when using keyboard creation that it moves over 2 spaces instead of 1? Wanted to use larger room icons, but dont want them to be side by side.
Reply with quote
Vijilante
SubAdmin


Joined: 18 Nov 2001
Posts: 5182

PostPosted: Mon Nov 17, 2003 11:59 pm   
 
You can change the exit properties to have different dimmensions. However I believe that change would have to be made map wide to be bound to the keyboard creation. Perhaps in a future version the abliltiy to bind different directions and exit types to specific keys will be added or it might already be there and I have just not found it yet.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Nov 18, 2003 2:33 am   
 
Actually, the way you do this is in the Edit/Properties and then to the Directions tab. You will see the X,Y,Z offset for each direction. This is a percentage of the X,Y spacing values. So, for example, you'll see that the N command has a X offset of 200%.

So, change those values to 400% and that will double the default spacing between rooms when creating new rooms with the keypad.

This is really a zMUD answer, but you can bind any key to any direction you define in zMUD/zMapper. Look at the default keypad definitions and you'll see that is just sends the 'n', 's', etc commands. zMUD checks your View/Direction settings to convert these direction commands to a direction index for the mapper.
Reply with quote
McGyver
Newbie


Joined: 11 Oct 2003
Posts: 4
Location: USA

PostPosted: Tue Nov 18, 2003 4:34 pm   
 
That worked great. Only problem I ran into is the line linking rooms starts and ends as if it was a smaller room shape. So the lines for my larger room size start inside the room instead of at the edges. Any suggestons?
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Wed Nov 19, 2003 2:43 am   
 
The size of your bitmap does not control the size of the room at all. If you want your rooms to be created twice as large by default, then change the X and Y spacing values in zMapper (and then you'll probably want your Directions set back to 200%).
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMapper Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
© 2009 Zugg Software. Hosted on Wolfpaw.net