Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » zMUD General Discussion
DanaLea
Beginner


Joined: 31 Jul 2002
Posts: 19
Location: USA

PostPosted: Sun Aug 31, 2003 11:20 pm   

zmud menu shortcuts
 
there is something that zmud does that really irriates me and I'm hoping someone can help me change it.

If the focus is not on the command line, and I type wa (for wake) it opens the mapper. I don't want a single letter to open menus. If I want to access a menu, I'll use Alt-letter or the mouse. I'd rather is did nothing if I type something when the focus is not in the command line. I have accidently done some bad things to my settings, and triggers, and who knows what else with this very annoying "feature" of zmud.

Can anyone help me?

-Dana
Reply with quote
etali
Beginner


Joined: 22 Aug 2003
Posts: 12
Location: United Kingdom

PostPosted: Mon Sep 01, 2003 12:17 am   
 
I could be wrong but I don't see how you can get the focus away from the command line other than by pressing Alt.

I think what you're doing is maybe planning to press Alt-H for health potion or something, changing your mind after you've already pressed Alt and the menus have focus.

All you have to do is press Alt again, or press Escape, and then the focus will return to the command line.

I could well be wrong, and either way I'd love to know the way around it. I do it myself and it drives me mad!

I think you can turn Ctrl shortcuts off, but I've never seen a way to turn Alt off.
Reply with quote
DanaLea
Beginner


Joined: 31 Jul 2002
Posts: 19
Location: USA

PostPosted: Mon Sep 01, 2003 1:29 am   
 
i'm losing focus because i use alt-tab to move between windows. like this one and zmud.

but really, my question has to do with not activing the menus, not how i lost focus.

-dana
Reply with quote
LightBulb
MASTER


Joined: 28 Nov 2000
Posts: 4817
Location: USA

PostPosted: Mon Sep 01, 2003 7:02 am   
 
Activating the menus when you press ALT is a Windows function. I don't know of any way to disable it, but if one exists it will be in Windows not zMUD.
Reply with quote
WDog
Newbie


Joined: 01 Sep 2003
Posts: 5
Location: Australia

PostPosted: Mon Sep 01, 2003 10:43 am   
 
I have the same problem and itís within the program when I have a mud window active that has no command line. My standard setup has 1 main window 4 text capture windows multiply tabbed, a floating info/button window, the mapper and various property / setting windows open.

If I start typing when the main window does not have focus I get the menus popping up. I do not us ALT key I left click usually to scroll and forget to click back in the main window. I have corrupted my settings a few times already because of this before I worked out what has happened.

I tried an alarm to automatically return the focus to the main window but itís a pain with the mapper and settings windows.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net