Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » zMUD General Discussion
sav
Wanderer


Joined: 09 Jan 2006
Posts: 86

PostPosted: Mon Jan 09, 2006 5:34 am   

2 small problems
 
1)
hi, i set up my ansi for auction as: aset auction white+underline
before i switched to zmud my auction line was fine(it was white and underlined) but for some reason in zmud isn't underlined. no idea why. there anyone who can help?

2)
is there anyway i can set up a macro such that i repeat my last command? for example i type 'shout boo me' how do i set it up such that if i press the macro(+ key on the numpad) i'll 'shout boo me' again and again and again.

thanks
Reply with quote
Slaem
Apprentice


Joined: 20 Sep 2005
Posts: 135

PostPosted: Mon Jan 09, 2006 7:34 am   
 
1) Does it underline in any other colors?

2) You can set up a macro to do the #H- command.
_________________
Show your love.
Support Zugg Software!
Donate to zugg@zuggsoft.com with PayPal Send Money.
Reply with quote
sav
Wanderer


Joined: 09 Jan 2006
Posts: 86

PostPosted: Mon Jan 09, 2006 9:27 am   
 
1) nope, doesn't underline at all no matter the colour

2) ok, if i do this i'll still needa to hit enter. there anyway to make it such that if i press + the command is sent to the mud immediately?
Reply with quote
Slaem
Apprentice


Joined: 20 Sep 2005
Posts: 135

PostPosted: Tue Jan 10, 2006 7:04 am   
 
Slaem wrote:
2) You can set up a macro to do the #H- command.


See #KEY for info on how to set that up via command line.

I think it's easier to do this in the Settings Editor as a Macro Key (the picture of a button). Open a new Macro, click in the Key field and then press they key you want to use. The Key field will be populated with the name of the key you pressed. Then enter your command into the Value field.

See Macro Keys in the zMud online manual for an example.
_________________
Show your love.
Support Zugg Software!
Donate to zugg@zuggsoft.com with PayPal Send Money.
Reply with quote
Vijilante
SubAdmin


Joined: 18 Nov 2001
Posts: 5182

PostPosted: Tue Jan 10, 2006 11:05 am   
 
I believe a command of !! will immediately send the last command. I am quite sure that pulls only from the caommand history which is set in the command line so it should not be affected by other script actions.
_________________
The only good questions are the ones we have never answered before.
Search the Forums
Reply with quote
sav
Wanderer


Joined: 09 Jan 2006
Posts: 86

PostPosted: Tue Jan 10, 2006 11:21 am   
 
cool thanks. any idea bout the ansi thingy though?
Reply with quote
Vijilante
SubAdmin


Joined: 18 Nov 2001
Posts: 5182

PostPosted: Thu Jan 12, 2006 12:36 am   
 
Check your preferences, in the section "Colors|Ansi Mapping". Make sure the underline attribute is correctly set, beyond that I am clueless.
_________________
The only good questions are the ones we have never answered before.
Search the Forums
Reply with quote
Pseudo
Wanderer


Joined: 25 Oct 2005
Posts: 99

PostPosted: Thu Jan 12, 2006 4:05 pm   
 
It is possible that your mud is using a nonstandard ansi escape sequence to display the underline. If Vijilante's suggestion does not work, I would try View->Preferences->General->Emulation->Uncheck Emulate Control Codes.
Now look at a line with the underline normally being used inside the mud. It should say <27>[4m to start where the underline is at. Post the entire line with the control codes if you'd like to get more information. (This will allow us to make sure it isn't something else too)
Reply with quote
sav
Wanderer


Joined: 09 Jan 2006
Posts: 86

PostPosted: Sat Jan 14, 2006 8:14 am   
 
i think this is it,
<27>[37;1m<27>[4mauction
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4348
Location: Pensacola, FL, USA

PostPosted: Sat Jan 14, 2006 6:00 pm   
 
Vijilante wrote:
I believe a command of !! will immediately send the last command. I am quite sure that pulls only from the caommand history which is set in the command line so it should not be affected by other script actions.


be nice if !!! and !!!! got the second and third commands from the command line, respectively.
_________________
Discord: Shalimar#3679
Reply with quote
sav
Wanderer


Joined: 09 Jan 2006
Posts: 86

PostPosted: Mon Jan 23, 2006 7:05 am   
 
hi, so i still haven't been able to get anything underlined on my mud.
no one know anything bout it?
Reply with quote
sav
Wanderer


Joined: 09 Jan 2006
Posts: 86

PostPosted: Mon Jan 23, 2006 7:05 am   
 
hi, so i still haven't been able to get anything underlined on my mud.
no one know anything bout it?
Reply with quote
TonDiening
GURU


Joined: 26 Jul 2001
Posts: 1958
Location: Canada

PostPosted: Mon Jan 23, 2006 7:20 am   
 
Could you be using a font that doesnt support it or someother weird oddity?

What about trying a MXP tag substitution to see if that works?
Reply with quote
sav
Wanderer


Joined: 09 Jan 2006
Posts: 86

PostPosted: Wed Nov 26, 2008 7:11 pm   
 
is there anyway to add new fonts to zmud?
Reply with quote
ralgith
Sorcerer


Joined: 13 Jan 2006
Posts: 715

PostPosted: Wed Nov 26, 2008 7:33 pm   
 
FYI, the !! is taken from UNIX. For terminal emulation compatibility I would assume, though only Zugg could verify this. It IS a nice feature though... but preferable to just hit up twice for the 2nd command back than holding shift and hitting 1 three times. Or 3 ups compared to shift and 4 1s.
_________________
CrossOver: Windows Compatibility on Mac and Linux CMUD Advocate
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net