Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » zMUD General Discussion

Joined: 29 Jun 2002
Posts: 10
Location: USA

PostPosted: Wed Nov 26, 2003 4:39 pm   

zmud/mxp oddities
I have been working slowly on implementing fuller support for MXP into my mud. Recently I added support for using colour tags rather than ANSI codes, and actually sending <br> line breaks instead of cr/lf (that part actually is a concession to Pueblo which prefers that)...

Like any good developer, I use Linux. I also have to test out all this stuff. So I have a copy of Windows ME installed on a VMWare box. Anybody that knows about VMWare knows that it's not "windows emulation", it's actually emulating the hardware and running a full windows OS.. So I run zMud on ME in Vmware to test it all out - and it's beautiful. Couldn't ask for better...

But then I notice that anybody who logs on with zmud is just logging right back off... Odd... I fire up vmware and zmud again, it looks just fine.

Then yesterday, I happened to be booted to booted to windows 2000. Fired up zMud and connected to the mud - and got spammed with a garbled mess! My MXP was broken and I didn't even know it!

Now, both are running 6.62 versions of zMud. Both are in windows, both are configured just like they are out of the box.

Why would the zMud 6.62 installed in VMWare under Windows ME display my MXP just fine, and the zMud 6.62 instealled in Windows 2000 on dual-boot (ie, not in VMWare) barf on it all?

Specifically, when using <br> tags instead of crlf, this works on the copy in ME... Doesn't work at all in zmud from win2k...

Also, what worked in ME was colour. I basically prefixed every colour change with a </c> to close the previous colour. This worked everywhere, except on the final prompt. I realized that's because zmud saw no additonal closing tags, so I added another just to make sure.

So I had to disable the <br>... spacing is back to normal... however, now, in win2k, EVERY line is getting a broken colour tag at the end, not just the prompt. That is, colours mid-line are working fine, but the colour at the end of the line isn't being parsed (MXP debug shows the unparsed tag at the end of each line), presumably because zmud is thinking there's not a closing tag. But of course, there is - there always is, it just either comes with the next colour, or at the end of the prompt when the data is all output. It's like the packets are getting broken up different coming across the network or something... No idea, but it's just not working.

What's really annoying is that this WORKED in zmud 6.62 under windows ME ran from vmware.. and it *DOESN'T* work in zmud 6.62 under windows 2000....

Any suggestions?
Reply with quote

Joined: 29 Jun 2002
Posts: 10
Location: USA

PostPosted: Wed Nov 26, 2003 5:16 pm   
Actually... I figured out *part* of the problem...

When I fixed the garbled-ness by changing back to cr/lf from line-break (<br)> codes, that caused the colourcode problem... Colour-codes flowed across line-breaks because they were HTML breaks, not cr/lf breaks (actually this works... I like it, keep it)..

However, it still doesn't explain why on zmud 6.62 in ME under VMWare, the <br> codes were working fine, and in 6.62 under 2k, they were spewing garbage (lines were overwriting other lines, <br> codes weren't always processed, horrid)...

hmm... no idea...
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » zMUD General Discussion All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by