Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
rwagner76
Beginner


Joined: 03 Dec 2010
Posts: 13
Location: Wausau, WI

PostPosted: Mon Jun 01, 2015 9:50 pm   

Color oddities... suggestions?
 
Aardwolf player here, having some oddities with colors, wondering if anybody has a suggestion.

As with many setups, I have a primary window and a channel capture window. Using a GCMP capture for the channel, such as:
#WIN Chat %gmcp.comm.channel.msg

My issue is this: My main window output appears to be using dumbed down colors (like simplifying to standard ANSI color), but my Chat window above
is showing the colors properly. Not sure why. I've combed through every setting I can find, but I'm probably still missing something.

Any suggestions would be appreciated.
Reply with quote
Anaristos
Sorcerer


Joined: 17 Jul 2007
Posts: 821
Location: California

PostPosted: Fri Jun 05, 2015 3:00 pm   
 
Perhaps if you could post a screenshot we could tell more. I use full ansi color sequences (including xterm) and it works, though if the window you are writing to does not have the focus the colors have a tendency to migrate.
_________________
Sic itur ad astra.
Reply with quote
Daern
Sorcerer


Joined: 15 Apr 2011
Posts: 809

PostPosted: Fri Jun 05, 2015 11:34 pm   
 
This actually seems to be a bug on Aardwolf. I'm guessing you don't have the xterm option turned on mudside. With it off, xterm colors are correctly converted to their ansi equivalent, but they're still sent in gmcp.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net