Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion

Joined: 24 Jan 2013
Posts: 6

PostPosted: Sun Mar 10, 2013 6:13 pm   

Another Data Corruption/Package issue
I am having some issues with cMUD data corruption and Rahab kindly told me that

"The problem in this case is not the software, but that you are not properly using packages."

I mud from several computers, and in an attempt to keep all my settings sync'd across different computers I store my package files in my "Dropbox" folder (

It seems that cMUD doesn't like this, because every time I fire up a character on a different computer, I get what appears to be data corruption. I'll choose a particular session, and instead of getting my main session window that displays mud input/output, I only get my "talk" window that is used to capture and display specific messages from the mud. I have no idea what is going wrong here, and the only thing that I can figure is that cMUD is choking when it's trying to read my packages from my Dropbox folder.

Additionally, I am looking for a way to have some standard settings for the mud that I play. There are certain words that I like to color, or fonts that I want to change for every session that I create for my mud. I understand that packages are the way to do this, and I can create a base package that has these global type settings, and then add that package to every session that I create. However, this will inevitably lead to data corruption.

Is there a way to prevent data corruption and use Dropbox to keep my sessions/settings in sync, or am I just attempting an exercise in futility? Does anyone else use Dropbox to successfully sync all their cMUD session data?

Reply with quote

Joined: 15 Apr 2011
Posts: 809

PostPosted: Sun Mar 10, 2013 9:13 pm   
I would imagine it could cause conflicts if you have CMUD running on multiple computers trying to access the same files. Dropbox syncing itself shouldn't affect it, it should be no different than copying the folder between computers with a flash drive.
Reply with quote

Joined: 22 Mar 2007
Posts: 2320

PostPosted: Mon Mar 11, 2013 12:20 am   
It would be a problem if you were trying to access them at the same time, but that doesn't sound like what is happening. Actually, it doesn't sound like data corruption at all. It sounds like you simply have a problem with the layout, not with the packages. They are stored in different files. Could you explain exactly which files you have in your dropbox?
Reply with quote

Joined: 19 Jun 2005
Posts: 1876
Location: California

PostPosted: Mon Mar 11, 2013 3:37 am   
It's going to depend on what packages you're accessing.

I have CMUD set up to go through Dropbox myself, and I don't have any issues. There was one time I left CMUD running at home, then ran CMUD at work for the same session. What wound up happening was Dropbox created a "Home_Conflicted" (or some such) prefix of my package.

Not sure what issue you're having, though.
Reply with quote

Joined: 24 Jan 2013
Posts: 6

PostPosted: Tue Mar 12, 2013 1:09 am   
I think that at this point the better question would be:

How do I need to install/setup cmud so that I can use dropbox? What files should be in dropbox? I clearly don't understand exactly what files cmud needs in order to operate correctly, and my knowledge is based on how zmud worked.

The latest thing I did was try to create a new session and copy my package from another session. These are the files that I have in my dropbox:

cmud_sessions\<session folder>


Currently with the blahblah.pkg loaded I can see my aliases as loaded, but I am unable to execute them. I have 'c' aliased to 'rest;mem;med' and whenever i hit 'c' the alias doesn't expand. I ensured that the 'expand' computer screen in the bottom right is turned on. I also made sure that the alias' group was enabled. Still no dice. Tried closing/reopening cmud and still doesn't work.

This is NOT my main problem, just a symptom of the overall problem. My main problem seems to be that none of my settings persist. This includes, fonts, custom colors, and screen layouts. I'd like to start over, but I have several auto-maps generated and over a hundred aliases and almost a hundred triggers.

I wouldn't even mind re-doing all of that if I could understand what I am doing wrong and how to fix it.
Reply with quote

Joined: 24 Jan 2013
Posts: 6

PostPosted: Tue Mar 12, 2013 1:26 am   
I guess i should mention that I'm using cmud pro if that matters any.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by