Register to post in forums, or Log in to your existing account

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion

Joined: 02 Aug 2008
Posts: 25

PostPosted: Thu May 12, 2011 3:29 pm   

System Debugger Must Be Closed
I mentioned this to Zugg before (to which I got the suggestion that I check another site - the security provider's site) for a solution.

When I start CMUD I get this error:
For Security Purposes, this program will not run while system debuggers are active.

I pointed out the following:

1. I am a an ex-programmer and am aware that I am not running a system debugger.
2. I don't want to go to "some other" site to fix my problem. I want the dude to whom I gave my $$ to fix the problem.
3. I would like to continue to use CMUD, but am willing to change.

I'm currently running Vista 64 with a shitton of memory and HD, running plenty of programs in the background but not one of them is a system debugger. As a matter of fact, as an ex-software guy, I don't have anything remotely like a programming environment on my computer.

Please fix. I need something a bit reliable.
I remember feeling good back in the 90s buying zMud to show my support rather than using the pirated versions that were available everywhere. All I ask is that the darn thing works when I click the little icon.

Reply with quote

Joined: 22 Mar 2007
Posts: 2320

PostPosted: Thu May 12, 2011 3:55 pm   
Certain programs from Microsoft contain internal debuggers, such as the Windows Explorer. This is a problem with Microsoft. Third party security systems have complained about it in the past. Cmud is using one of those third party security systems. Until Windows fixes the problem, the only solution is to close Explorer or whatever other Microsoft program is causing the problem before starting Cmud.
Reply with quote

Joined: 18 Oct 2000
Posts: 2733
Location: Atlanta, USA

PostPosted: Thu May 12, 2011 4:10 pm   
Hi Moab,

I'm sorry that you are having a difficult time with CMUD. I should point out that problem may not be a formal debugging environment at all. Often times it is really tied to a security sub-system like anti-virus or anti-malware software. These programs often use in-memory analysis and heuristics to detect not only existing threats but attempt to identify new ones. I'm certain you already know this. I bring it because CMUD uses Armadillo, a theft prevention engine by Silicon Realms. It basically decrypts the encrypted CMUD executable (in memory) to allow it to run. Unfortunately, as I'm sure you're also aware, such complex systems don't always play nice.

Norton Antivirus has been identified as a culprit in the past, and in some cases even malware can trigger a response. I use Avast and have not run into any issues (even when I was on Vista). You can try disabling you're various security components (while offline of course) to identify the culprit. The WinSpy tool may also help to show exactly what's triggering the conflict.

I know it's little consolation but CMUD does work for most, and Zugg has no direct control over the Armadillo compatibility barring removing it altogether. It is a large enough, and widely-distributed enough, solution that most software vendors will work to ensure they have compatibility, provided they are aware of the problem. I hope this was helpful.
Asati di tempari!
Reply with quote

Joined: 28 Sep 2000
Posts: 1395
Location: United Kingdom

PostPosted: Thu May 12, 2011 5:48 pm   
Having spent some time over at the Silicon Realms site it appears that a number of things can cause this. Other programs that also protect themselves against debugging can cause this issue. In the past it appears that DivX 5.1 and Nero caused this issue, I was unable to ascertain if this is still the case.

Zugg would need to turn off the Armadillo debugging protection in order to fix this issue which doesn't quite amount to not using it all but would make the pirates job exceptionally easy. One imagines since he is so heavily invested in keeping CMUD going as a product that he is currently downsizing his house that it isn't an option he is willing to take.
Taz :)
Reply with quote

Joined: 02 Aug 2008
Posts: 25

PostPosted: Thu May 12, 2011 7:23 pm   Thanks
I appreciate the informational posts certainly - however it seems a poor choice of a security system. I have many programs (as we all do) installed on my computer and none of them have this problem - but CMUD does? Clearly it's not an "MS issue" and while it might be a conflict with anti-virus software, guess which two of those win out? My anti-virus only argues with CMUD? (It's not an anti-virus issue, btw, checked.)

So I'm left with something is causing CMUD to not run when I want to play a game because of some issue with CMUD.

Without Zugg reconsidering (for my sake, heh) what goes into his work, I guess I'm out the subscription cost of the game.

On the other hand, I doubt I'm the only one on the planet with this problem.

Thanks again for the advice. Perhaps when I have some time I'll fire up winspy - but tintin++ is just as easy.
Reply with quote

Joined: 25 Sep 2000
Posts: 23379
Location: Colorado, USA

PostPosted: Fri May 13, 2011 4:01 am   
It's not a Microsoft issue. It's not Explorer that is causing this. It is some other software running on your computer that is interfering with the copy protection. As Tech mentioned, it's usually the anti-virus or network security software. Nothing I can do about it. I use Avast and CMUD works fine with it. It also works fine with AVG. Norton/Semantec software is notorious for problems like this.

But as I said, there is nothing I can do about it. I use one of the most popular copy protections systems available on Windows (Armadillo/Software Passport). You can go over to their forums at Silicon Realms and complain and maybe get some help if you list all of the software you have running in the background. But there is no way I am going to turn off copy protection and put myself out of business.

This is exactly why I offer a free 30-day trial of all my software. You could have easily tried it for free to determine if it worked on your computer or not.
Reply with quote

Joined: 02 Aug 2008
Posts: 25

PostPosted: Sat May 14, 2011 11:17 pm   Figured it out
I suppose it must have been something like a system debugger.
For years as a developer I used UltraEdit - and I use it also to keep notes from various muds.

After toying around I discovered that if UE is open prior to CMUD, CMUD won't open and gives the system debugger alert.
When UE is opened after CMUD, no problems.

Thanks everyone for your patience and I apologize for my snarky message. I was frustrated.
Reply with quote

Joined: 25 Sep 2011
Posts: 1

PostPosted: Sun Sep 25, 2011 7:00 am   Firefox 6 also causes this
This thread is a little old, but I had this same problem. Turns out, Firefox 6 also causes this problem. You have to close it before you open CMud and then you can open it again. Not sure what about Firefox triggers this.
Reply with quote

Joined: 07 Feb 2002
Posts: 333
Location: Central Virginia

PostPosted: Mon Sep 26, 2011 4:59 pm   
I use the latest firefox 6.0.2 and have no such issues. This sounds more like an add-on you have installed for firefox than the core program that is causing the issue.
Windows Vista Home Premium SP2 32-bit
AMD Athlon Dual Core 4400+ 2.31 GHz
CMUD 3.34
Reply with quote

Joined: 18 Oct 2005
Posts: 7

PostPosted: Mon Feb 18, 2013 11:18 pm   
If I try to open Cmud with Notepad++ open I get this error as well. In order to run Cmud I have to close notepad++ then run it, then open notepad++. Just posting here in case it might be helpful to people who search for this error like I did.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by