Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
dbosst
Apprentice


Joined: 15 Jun 2010
Posts: 121

PostPosted: Tue Sep 21, 2010 4:59 pm   

%walkconfirm not updated by gmcp vnum matching
 
when using match rooms with VNUMs option, and slow walking to a room that has been already automatically confirmed by the mapper using VNUMs, %walkconfirm has not been set...

this makes it impossible to do my own confirmation of rooms when confirming rooms without vnums on the map since I do not know whether the room has been confirmed or not:

1) move from vnum marked room to unmarked room %walkconfirm is 0, and the mapper hasn't moved yet obviously
2) move from vnum marked room to vnum marked room, %walkconfirm is still 0, but the mapper has already moved...
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Sep 21, 2010 5:25 pm   
 
Try using Safe mode instead of Slow mode. Slow mode is still designed for scripted #OK triggers to set the %walkconfirm flag.

Why is it that everybody seems to be using Slow mode instead of Safe mode? The vast majority of users should be using Safe mode.

As far as using %walkconfirm to set your own vnum, you shouldn't need to do that. If you are using a GMCP Room.Info trigger, then the room is confirmed since GMCP issues the equivalent of the #OK command internally. Just use the %roomload to determine if the Real vNum bit has been set, and if not, set it with the vnum from the gmcp table.
Reply with quote
dbosst
Apprentice


Joined: 15 Jun 2010
Posts: 121

PostPosted: Tue Sep 21, 2010 5:48 pm   
 
Slow mode is better?

I am doing my own room name matching....

The problem is GMCP does issue an internal#OK when the map has the correct vnums this isn't the problem... the problem is What to do when the map doesn't have VNUMS ? For my own room name confirmation I have to know when the internal #OK was issued so I know if I should issue my own #OK or not and I don't know that if %walkconfirm isn't set

For now I have just disabled the option completely for USE vnums.. and added to my own confirmation script to check if the next room has a valid vnum using %roomload
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Sep 21, 2010 5:55 pm   
 
I think I already mentioned this in another thread, but if you are completely overridding the mapper with your own confirmation functions, then you definitely should turn off the "Use vNums" option. The "Use vNums" option is for the vast majority of players who just want to use their map and have it work without messing around with scripting. Using Safe mode with this will work fine for most people.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Tue Sep 21, 2010 7:08 pm   
 
Actually, it's possible for me to improve this issue if you can give me a test script that I can use to debug this on either Aardwolf or Achaea. At this last stage before a public release, I can only fix bugs that are easy to reproduce and easy to fix. So if you make it easy for me, I'll see what I can do.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net