Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD Beta Forum
Erasmus
Wanderer


Joined: 04 Aug 2004
Posts: 82
Location: Philadelphia

PostPosted: Thu Jun 03, 2010 5:07 pm   

[3.17]onConnect/Disconnect Fires Only When Module is Set to Global
 
I'm not sure this is a bug because I'm throughly confused as to when onConnect/Disconnect is supposed to work or not, but it seemed odd so I'm reporting it.

I created an onConnect event that turns the tick timer on when connecting to the MUD (#TIMER 1 "" 0 5), and an onDisconnect event that that turns it off when disconnecting (#TIMER 0). If I put the events as settings under the session window where I want them to fire everything works as expected with the timer being turned on or off accordingly. However, if I put the events under a separate module I get odd results.

If the module is set to Global the events will fire properly regardless of whether or not the module is in the same package as the session window, or a separate package. However, if the module is set to either Local or External the events do not fire.

I tested cases in which a module containing the events is in the same package as the session window, and one in which a module was in a different package. For the module in the same package, if the module is set to Global the events fired as expected, but when changed to Local (obviosuly External wouldn't work anyway) they did not fire. Change back to Global and it fired. When the module was in a different package, again, if set to Global the events fired, but if changed to External (Local should not work anyway) the events would not fire. Change back to Global and the events fired again.

Sorry if this was really long-winded, and repetative.
_________________
Erasmus
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Thu Jun 03, 2010 5:29 pm   
 
You are correct that this is a bug. I've added it to the bug list.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD Beta Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net