Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
Slaem
Apprentice


Joined: 20 Sep 2005
Posts: 135

PostPosted: Thu Aug 07, 2008 4:57 am   

No MSP sound
 
I'm playing Materia Magica and "set sound on" but I'm not getting any sound. I've read through the forums and followed previous advice. Here's my MSP settings:



What happens is CMUD recognizes the needed file but cannot find it (it's listed in red).



I followed MM's website for settings up MSP sounds, but CMUD still can't find the files. I can manually locate the files locally, select them, and CMUD play the sounds.



However, I have to do that for each sound and that's only good for the current session since the MSP Sounds list is cleared when CMUD is closed.


What am I doing wrong and how do I get this to work?

Thank you.
Reply with quote
Seb
Wizard


Joined: 14 Aug 2004
Posts: 1244

PostPosted: Fri Aug 08, 2008 2:24 am   
 
Maybe CMUD is looking in the wrong directory for the files... I note there is no path to the filename. Did you install your data to %INSTALLDIR% or to your documents\MUDs folder, or whatever? Could be a bug where CMUD is looking in the wrong place.
Reply with quote
Slaem
Apprentice


Joined: 20 Sep 2005
Posts: 135

PostPosted: Fri Aug 08, 2008 3:24 am   
 
Hi, Seb. Thanks for the reply.

I can use the #PLAY command and CMUD plays music files properly. In fact, after I #PLAY or manually set up the MSP music file CMUD plays it properly. I'll disable the package to see if it's one of my settings or something, and then try Zugg's #SH command he suggested here, if needed.
_________________
Show your love.
Support Zugg Software!
Donate to zugg@zuggsoft.com with PayPal Send Money.
Reply with quote
Slaem
Apprentice


Joined: 20 Sep 2005
Posts: 135

PostPosted: Fri Aug 08, 2008 4:35 am   
 
CMUD finds the sound file properly and plays them, like:

#PLAY mm_door_close1.mp3


CMUD plays this request properly:

#SHOW "!!SOUND(mm_door_close1.mp3 U=http://www.materiamagica.com/sounds/wav/)"


CMUD doesn't process an asterisked file name, like what MM sends:

#SHOW "!!SOUND(mm_door_close1.* U=http://www.materiamagica.com/sounds/wav/)"


The MSP Specifications page stated asterisked file names are acceptable. Is this a problem with CMUD?
_________________
Show your love.
Support Zugg Software!
Donate to zugg@zuggsoft.com with PayPal Send Money.
Reply with quote
Seb
Wizard


Joined: 14 Aug 2004
Posts: 1244

PostPosted: Fri Aug 08, 2008 11:22 am   
 
Yeah, sounds like a bug. What version of CMUD are you using?

The examples in the spec do not have an * after the . (dot), so can you try this:
#SHOW "!!SOUND(mm_door_close1* U=http://www.materiamagica.com/sounds/wav/)"
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23379
Location: Colorado, USA

PostPosted: Mon Aug 11, 2008 5:43 pm   
 
Sounds like a bug with the * in the file name, so I'll add it to the bug list and take a look at it when I get a chance.
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23379
Location: Colorado, USA

PostPosted: Tue Aug 12, 2008 8:29 pm   
 
There was a bug with using * in a filename. However, keep in mind that in order for the * to work, you must already have the sound files downloaded into your sounds directory. In other words, * is a LOCAL option...it tells CMUD to select all matching files that it finds in the directory. It does not tell the MUD server to download a random sound. The U option for the URL download only works when you specify an exact filename to download.

But I'll fix the * so that it works as in zMUD for local random sound selection.
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net