Register to post in forums, or Log in to your existing account
 

Play RetroMUD
Post new topic  Reply to topic     Home » Forums » CMUD General Discussion
hykou
Wanderer


Joined: 29 Apr 2004
Posts: 63
Location: USA

PostPosted: Sun Jan 21, 2007 9:47 am   

Wildcards im cMUD?
 
In zMUD you could use * as a wildcard for as much text within limits, how do I use it in cMUD...

Example..

#trigger {^The Powers accept your sacrifice of the *} {#t+ temp}

This is supposed to turn the temp class back on after sacrafcing the corpse of the mobile you killed. Any help would be thankful!
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4042
Location: Pensacola, FL, USA

PostPosted: Sun Jan 21, 2007 10:09 am   
 
the wildcard is really unneccary here, at there is no further text after for it to catch

#TR {^The Powers accept your sacrifice of} {#T+ temp}

I see no reason why yours wouldnt work either though... what is the problem?
_________________
Discord: Shalimar#3679
Reply with quote
hykou
Wanderer


Joined: 29 Apr 2004
Posts: 63
Location: USA

PostPosted: Sun Jan 21, 2007 10:34 am   
 
Because ther IS text after that. I wouldn't post some stupid question if there wasn't text after it.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4042
Location: Pensacola, FL, USA

PostPosted: Sun Jan 21, 2007 11:47 am   
 
My point is... ending in a wildcard is unneccary.. according to the trigger you posted there is nothing after the wildcard, which makes the wildcard redundant.

You still have yet to say what is wrong however.

#T+ and #T- work fine for me.
_________________
Discord: Shalimar#3679
Reply with quote
mr_kent
Enchanter


Joined: 10 Oct 2000
Posts: 698

PostPosted: Sun Jan 21, 2007 12:30 pm   
 
hykou - We're here to help, but we can't see your monitor. Please explain what happens when you try your example trigger. What behavior is different than what you'd expect? I think we can tell what you'd like to have it do.

shalimar - I believe hykou is asking specifically about the wildcard. He provided an example for illustration, but he may not care about that particular trigger only. #T+ and #T- don't seem to be what he's asking about. I don't have CMUD installed right now, or I'd try to address his issue. Are you able to use the '*' wildcard successfully in situations where there might be redundant text after the part you'd like to capture?
Reply with quote
hykou
Wanderer


Joined: 29 Apr 2004
Posts: 63
Location: USA

PostPosted: Sun Jan 21, 2007 7:41 pm   
 
I know how to work the #t- and #t+. Thats not the question, read the title of the fourm.

Code:
#trigger {^The Powers accept your sacrifice of the *} {#t+ temp}

When I use this nothing happens.
Code:
#trigger {^The Powers accept your sacrifice of the} {#t+ temp}

When I try this, again nothing happens.

Reminder that it shoulkd turn the class 'temp' back on after you sacrafice any corpse. The wildcard is supposed to be the -different- types of corpses.
Reply with quote
MattLofton
GURU


Joined: 23 Dec 2000
Posts: 4834
Location: USA

PostPosted: Sun Jan 21, 2007 8:04 pm   
 
#trigger {^The Powers accept your sacrifice of the *} {#t+ temp}

That's exactly how you use it in CMud, though like Shalimar said the * is unnecessary as it will match anything all the way to the newline (well, assuming there are no special characters before then) AND you are not doing anything with the matched text specifically.

If the absence of the wildcard still doesn't produce any result, you are simply suffering a logical problem OR are suffering from the lingering effects of corruption or bugfix (neither of which would really apply if this is a new settings file created in 1.24). For instance, are the trigger options set correctly? If it's set to trigger on prompt it probably isn't going to fire, and if neither trigger on prompt nor trigger on newline is checked it's never going to fire at all. The same thing if the trigger is in a class that is disabled.
_________________
EDIT: I didn't like my old signature
Reply with quote
Fang Xianfu
GURU


Joined: 26 Jan 2004
Posts: 5155
Location: United Kingdom

PostPosted: Sun Jan 21, 2007 9:56 pm   
 
And it could also be that triggers themselves are turned off. People have made that mistake before.
_________________
Rorso's syntax colouriser.

- Happy bunny is happy! (1/25)
Reply with quote
hykou
Wanderer


Joined: 29 Apr 2004
Posts: 63
Location: USA

PostPosted: Mon Jan 22, 2007 12:45 am   
 
They are on and still no response. I realize that with a new program comes bugs, or maybe it is my computer. Just tell me if my syntax and usage is correct or not. Jesus christ.
Reply with quote
Fang Xianfu
GURU


Joined: 26 Jan 2004
Posts: 5155
Location: United Kingdom

PostPosted: Mon Jan 22, 2007 12:55 am   
 
MattLofton wrote:
#trigger {^The Powers accept your sacrifice of the *} {#t+ temp}

That's exactly how you use it in CMud, though like Shalimar said the * is unnecessary

It's already been answered, hykou, more than once. In the first post, even. Don't get shirty, we're offering help.
Reply with quote
SBG
Novice


Joined: 05 Mar 2003
Posts: 44
Location: Australia

PostPosted: Mon Jan 22, 2007 3:54 am   
 
Gday hykou,

Your syntax is correct but personally I'm finding a lot of trouble with ^ triggers in Cmud
try removing it and make sure case switch is off. If it fires then at least you've got something to work with.
class folder toggle seems to be working fine here.

hth

Mark.
_________________
Windows 7U x64 SP1
AMD Phenom X4 9650
8 Gig mem
CMUD Pro v3.34
Zmapper v1.30
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Jan 22, 2007 6:53 pm   
 
Quote:
Your syntax is correct but personally I'm finding a lot of trouble with ^ triggers in Cmud


There are not any known bugs with ^, so if you are having trouble with them, then post a new topic about this problem so that we can try to help.

hykou: zMUD/CMUD do not require a * at the beginning or end of a trigger. They always fire with extra text on the line unless the pattern ends with a $ character. I tried both of your examples and they worked fine here (both enabling the temp class), so the problem must be elsewhere in your script or in your trigger options.
Reply with quote
mikeC130
Wanderer


Joined: 03 Jul 2006
Posts: 66

PostPosted: Tue Jan 23, 2007 12:54 am   
 
Just to throw in something that may help (or may not)-

Did you copy the text from your MUD input or type it manually? If you typed it in, you may be missing the trigger because the person who programmed the message put in an extra space or a tab somewhere in the sentence.

Mike
Reply with quote
hykou
Wanderer


Joined: 29 Apr 2004
Posts: 63
Location: USA

PostPosted: Wed Jan 24, 2007 10:55 pm   
 
It was tested from the Mud ^ is used so others cant mess with my scripts using tells, or shouts.
Reply with quote
balrugh
Newbie


Joined: 20 Apr 2004
Posts: 9

PostPosted: Mon Jan 29, 2007 10:22 pm   
 
I have problems with "^" in my scripts, in cmud i use the "Trigger in Newline" param.

For the *, it doesn't function for me in the next trigger:

(%w) @no_obj_plural1{,| }*estan aqui.

Any idea?

Thanks and sorry for my english
Reply with quote
Zugg
MASTER


Joined: 25 Sep 2000
Posts: 23377
Location: Colorado, USA

PostPosted: Mon Jan 29, 2007 11:32 pm   
 
Quote:
I have problems with "^" in my scripts


Please tell me what "problems" you are talking about. I don't have any known bugs regarding ^ in patterns on my bug list.

For reporting a problem with a trigger, you should also post the sample text from the MUD that isn't working with the trigger so that the rest of us can try it.
Reply with quote
balrugh
Newbie


Joined: 20 Apr 2004
Posts: 9

PostPosted: Tue Jan 30, 2007 7:37 am   
 
balrugh wrote:
I have problems with "^" in my scripts, in cmud i use the "Trigger in Newline" param.

For the *, it doesn't function for me in the next trigger:

(%w) @no_obj_plural1{,| }*estan aqui.


Sample text: Oruga y Dos ladrones estan aqui.

@no_obj_plural1 = ladrones.

--------------------------------------------------------------------------------
--------------------------------------------------------------------------------

For the "^" , today i comprobe my failure. It fuction now :), thanks.

Sorry for my english.
Reply with quote
shalimar
GURU


Joined: 04 Aug 2002
Posts: 4042
Location: Pensacola, FL, USA

PostPosted: Tue Jan 30, 2007 12:54 pm   
 
Variables should be enclosed in brackets, its good for catching whole arrays that way.

#TR {(%w) {@no_obj_plural1}{,|} *estan aqui.} {stuff}
_________________
Discord: Shalimar#3679
Reply with quote
Display posts from previous:   
Post new topic   Reply to topic     Home » Forums » CMUD General Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

© 2009 Zugg Software. Hosted by Wolfpaw.net